Emergency Calls Only on Galaxy S2Support

Last Updated:

  1. SCPadgeebar

    SCPadgeebar Well-Known Member

    So I bought a used Samsung GS2 from a known supplier for PhP17,000 or 405USD.
    I wasn't minding the emergency calls only message at the lock screen at first because Globe Telecom SIM usually go to Emergency Mode even in my old phone.
    It starts annoying me because I can't call or text anyone!
    Things that I did:
    1.) Tested the SIM on my old phone to check if it is working - it is.
    2.) Tried my brother's SIM on mine, suddenly, it worked!
    3.) I put back my SIM again and it is still working.
    4.) After a while, I got the emergency calls only again. Tried turning on and off the phone itself. - nope. nothing happened.
    5.) Bought a new prepaid SIM of the same carrier(Globe Telecom). - it worked for just the 1st 12hrs. Then I got stuck at emergency calls only again.

    The seller told me it still has Samsung Warranty but I don't know how to check if how long my warranty still is.
    If anyone would tell me how to get/know my warranty time remaining, I will try to give Samsung the call to address this problem and try to ask if I can give it to them to take a look or get a replacement unit.

    Thanks in Advance guys. :)
    Sorry if my English is also not that perfect since it is not my native language. :)
    BTW I'm from the Philippines. ;)

  2. Hawker

    Hawker Well-Known Member

    How long did you try your brother's sim in your phone for?

    Type *#1234# at the dialer to give us some more info on your phone. (PDA/PHONE/CSC)

    Also settings>about phone to tell us:
    Kernel version and Build Number
  3. SCPadgeebar

    SCPadgeebar Well-Known Member

    For about a minute or 2 or 3. Since he has to go somewhere so I gave back his SIM immediately.

    PDA : I9100DXKL3
    PHONE : I9100DXKL1
    CSC : I9100OLCKL2
    Kernel Version: #2
    Build Number: GINGERBREAD.DXKL3
  4. Hawker

    Hawker Well-Known Member

    As you are in the Philippines and you are on DXKL1 modem, then this seems fine for your particular region.

    Did you go through a setup procedure when you first switched your phone on?
    If not it may be worth performing a factory reset on the device, as it's possible that there is a 3rd party app (such as a power saver) that might be switching your device into flight mode.
  5. SCPadgeebar

    SCPadgeebar Well-Known Member

    Actually I did 2 Factory Resets.
    One via Settings > Privacy > Factory reset and one via dialing numbers.
    The supplier did the first one so that I may go through the setup procedure but I wasn't satisfied so I did the one by dialing numbers.
    And no, Flight mode and Power Saving isn't turned on.

    BTW I'm running Android 2.3.6
  6. Hawker

    Hawker Well-Known Member

    I cant remember exactly on GB (on ICS this is Settings>More>Mobile Networks>Network Operators), but try (i think):
    Settings>Wireless and Networks>Mobile Networks>Network Operators

    Let it scan, then select a DIFFERENT network.
    Then do the same again, but choose the correct one.
  7. SCPadgeebar

    SCPadgeebar Well-Known Member

    Says unable to connect. And shockingly, I didn't find my service provider which is Globe Telecom. O_O

    EDIT: Found my provider. Hahaha

    EDIT2: Says "Unable to connect to network. Select automatically."
    asad297 likes this.
  8. ferret141

    ferret141 Well-Known Member

  9. SCPadgeebar

    SCPadgeebar Well-Known Member

    ^Nope. Still the same even after restarting the device.
  10. pavsam

    pavsam Member

    Did you review the security options at "Settings> Location and security" and remove any locking features ?
  11. SCPadgeebar

    SCPadgeebar Well-Known Member

    No locking features are enabled.
  12. ironass

    ironass Well-Known Member

    It is worth going to this site and inputting your IMEI number to see if your phone is blocked for any reason.

    It wouldn't be the first time that a carrier or vendor has issued a phone with a blocked IMEI.
  13. SCPadgeebar

    SCPadgeebar Well-Known Member


    I don't get what it says.
  14. ironass

    ironass Well-Known Member

  15. SCPadgeebar

    SCPadgeebar Well-Known Member

    Says "Your IMEI Number is currently unblocked."
  16. ironass

    ironass Well-Known Member

    At least that rules out another possibility that has cropped up in the past.

    My feeling is that the problem may lie with Globe Telecom and not your handset, as this seems to function with another sim card. It does seem odd that you can connect for a period but are then cut off. I note from the Globe Telecom site that they are currently carrying out, "extensive", network upgrading across the network. It might be an idea to give their support team a call and explain your problem in detail.
  17. SCPadgeebar

    SCPadgeebar Well-Known Member

    I might give Samsung and Globe a ring tomorrow.
    Thanks for the tips and advice guys. :D

    I'll give updates after I'm done calling both of their support teams.
  18. ironass

    ironass Well-Known Member

    I would be inclined to start with Globe first. Good luck!
  19. SCPadgeebar

    SCPadgeebar Well-Known Member

    Random Feedback:
    AndroidForums is very different if it will be compared to other forums. Faster replies from experience people. Kudos for that.

    Why did I give this random feedback?
    - I posted this problem to random tech forums and AF is the only who responded to my problem.

  20. SCPadgeebar

    SCPadgeebar Well-Known Member

    Can't call Samsung nor Globe due to my busy sched here at home.
    Will have it checked tomorrow at a trusted cellphone repair shop and will give you guys updates. :D
  21. SCPadgeebar

    SCPadgeebar Well-Known Member

    Due to sudden schedule change, I have not yet went to the shop, I gave Samsung a call before I leave the house.

    Warranty is still up to May 31, 2013.
    I stated the problem and they said its not a hardware/software malfunction and might be a Service Provider Problem.
    They asked me to put on a SIM Card of a different carrier, which in this case, I borrowed my mother's Smart SIM Card, and to my surprise, it worked!

    When my mother gets home later, I'll try her Sun Cellular SIM to test if this phone is Smart-locked or not.
  22. Dusty Bin

    Dusty Bin New Member

    I have the same problem.

    Two weeks ago, the phone developed the ubiquitous battery warning/temperature issue and would only power on if attached to charger. I replace the USB circuit and this solved that problem but almost immediately I began getting low signal issues and, frequently, this 'emergency calls only' issue. I have tried another SIM so it isn't that. Haven't spoken to my supplier yet but am curious if this issue is something brought on after the USB replacement.

    Incidentally, a firmware upgrade to ICS failed to solve the issue.
  23. SCPadgeebar

    SCPadgeebar Well-Known Member

    ^Maybe your antenna chord(or something) is loose.

    Tried the insert-SIM-in-other-phone-and-back-to-my-SGS2 trick and Globe worked again. JUST FOR THE 1ST 2MINS. <_<
  24. Dusty Bin

    Dusty Bin New Member

    Where's that located?

    Anyway, judging by Google, this is not an uncommon issue on S2.
  25. SCPadgeebar

    SCPadgeebar Well-Known Member

    Ok, I think I know what the problem is(i guess?).
    Last night I was able to use my Globe SIM without and issue.
    Went to Settings > About Phone > Status > Mobile Network Type and it says EDGE.

    At morning, when I checked my phone, I got the Emergency Calls Only and the last message I received was 10:26PM and my guess is that ECO went back at approx. 11PM~12MM.
    Went to Settings > About Phone > Status > Mobile Network Type and it says UMTS.

    I dunno, just a guess. Maybe it's that. :v

    @Dusty Bin: Search for a Disassemble Video on YouTube. ;)

Share This Page