Emulator crash!


Last Updated: 2009-05-01 15:45:54
  1. Costa

    Costa Active Member

    Hi everybody!

    I'm trying to run the Android tutorials and i'm getting a crash when i execute the emulator.

    Does anybody have an idea why is this happening? Is not only on tutorials Android give, is in any application i create this error happens.

    [​IMG]

    Somebody can help me!? Please :eek:

    Advertisement
  2. RozzaC

    RozzaC Well-Known Member

    Did you install Eclipse and the SDK properly?

    That's always a good place to start...
  3. Costa

    Costa Active Member

    Yes they are. I already installed them 2 times and updated the SDK to v1.1 and still geting the error. :(
  4. RozzaC

    RozzaC Well-Known Member

    Have you got the latest JDK from Sun.com?
  5. Costa

    Costa Active Member

    Yes. i reinstall Eclipse, JDK, JDE, Android SDK, everything and i still get that error! :(
  6. RozzaC

    RozzaC Well-Known Member

    I'm assuming there's a conflict somewhere then...

    Hmmmm....

    When you tried installing it all again....did you uninstall it all first?

    And were you using Eclipse before you started working with android?
  7. Costa

    Costa Active Member

    I made it all correctly. I used Eclipse with PHP plugin before.

    When i start the computer it works fine on 1st "emulation", but when run the 2nd "emulation" the emulator crashes.

    When i try run the adb in command line it says "device not found". :confused:
  8. RozzaC

    RozzaC Well-Known Member

    I'm guessing that plugin might be causing the issue....but I can't confirm that...

    Maybe the 2 plugins don't like each other....
  9. Costa

    Costa Active Member

    No. I already uninstall all eclipse and only installed Android plugin and still get the error.

    Even if i go to \tools folder and run emulator.exe the error appears!
  10. RozzaC

    RozzaC Well-Known Member

    Hmmmmm....

    I'm at a little bit of a loss right now then....

    If the emulator is still giving you problems without Eclipse..then it's definitely something to do with the Android SDK....

    Something about your computer doesn't like it....

    Here's another idea...normally works for me when I have issues....

    Go to Start -> Run and type "msconfig"

    The System Configuration Utility should come up...

    Go to the "Startup" Tab and press the button "Disable all".....

    Press "Apply" and then "Close"

    Restart the computer...and then try running the Android Emulator again...

    Doing that...SHOULD (not guaranteed) ensure that there is nothing conflicting with the SDK Emulator...
  11. Costa

    Costa Active Member

    I made it and the emulator still crash :mad:

    I don't know more what to do. :eek:
  12. RozzaC

    RozzaC Well-Known Member

    Gah.....this is getting to be a little frustrating.... -_- ...

    Ok...I did some research....

    Open up command prompt and try typing this command

    emulator -wipe-data ....
  13. Costa

    Costa Active Member

    :( i can't understand what is wrong with this

    [​IMG]
  14. RozzaC

    RozzaC Well-Known Member

    To be honest...neither can I.....

    Only other thing I can suggest is a clean windows install...but that's just stupid...

    I'll do some more research and get back to you on it because I'm fresh out of ideas right now...
  15. Costa

    Costa Active Member

    I instaled NetBeans with the plugin for Android and give me this description from an error when i run it.

    Can this help in something?

    Code (Text):
    1.  init:
    2. deps-jar:
    3. Compiling 2 source files to C:\project\AndroidApplication3\build\classes
    4. compile:
    5. Created dir: C:\project\AndroidApplication3\dist
    6. Updating jar: C:\project\AndroidApplication3\dist\AndroidApplication3.apk_
    7. Updating zip: C:\project\AndroidApplication3\dist\AndroidApplication3.apk_
    8.  
    9. [COLOR=Red] Unable to access jarfile ..\framework\apkbuilder.jar[/COLOR]
    10. C:\project\AndroidApplication3\nbproject\build-impl.xml:440: exec returned: 1
    11. [COLOR=Red] BUILD FAILED (total time: 1 second)[/COLOR]
  16. RozzaC

    RozzaC Well-Known Member

    Is this when you are trying to run an application in NetBeans...or just NetBeans itself?

    ---EDIT---

    Found something about that problem through Google...

    http://kenai.com/projects/nbandroid...le-to-access-jarfile-framework-apkbuilder-jar

    It says on that website to try and set two variables explicitly in the apkbuilder.bat file...

    set frameworkdir=[your_path]\android-sdk-windows-1.1_r1\tools\lib\
    set libdir=[your_path]\android-sdk-windows-1.1_r1\tools\lib\

    Find those 2 lines and change them to match that....looking from your screenshots..it would be..

    set frameworkdir=D:\android-sdk-windows-1.1_r1\tools\lib\
    set libdir=D:\android-sdk-windows-1.1_r1\tools\lib\

    ---EDIT 2---

    I just opened my apkbuilder.bat file...and it's a mess...

    If yours is the same...

    Then maximise the notepad window to full screen and look on the third from last line...

    Here's a screenshot to show you what I mean...

    ---EDIT 3---

    MY screenshot doesn't show the right section...
    Don't change set jarfile=apkbuilder.jar The "set libdir=" command is in front of the "set frameworkdir=" command...

    [​IMG]
  17. Costa

    Costa Active Member

    RozzaC i appreciate your help very much and i'm very thankfull to you, but that solution didn't solve the problem :(
  18. RozzaC

    RozzaC Well-Known Member

    Wow....that's annoying =/ ....

    They had another fix in that site too...

    Remove this line as well...

    cd %~dp0

    IT's right behind the "set jarfile=..." command I was talking about earlier...
  19. Costa

    Costa Active Member

    Same......... :(

    It is very very annoying when i have a work with a dateline to finish and i can't do it because the emulator doesn't work. :(
  20. RozzaC

    RozzaC Well-Known Member

    Can you post a screenshot of your apkbuilder.bat file?

    Or just send me the file through PM...
  21. Costa

    Costa Active Member

    My apkbuilder.bat looks like this after the changes you told me.

    [​IMG]

    I still don't get why the emulator works fine durint the 1st execution and after that crash everytime i try run it.
  22. RozzaC

    RozzaC Well-Known Member

    Try this line in command prompt:

    "emulator -verbose -wipe-data"
  23. Costa

    Costa Active Member

    :( no

    Maybe it is something Android needs and is disabled on my PC?
  24. RozzaC

    RozzaC Well-Known Member

    If you've got everything on the System Requirements List...

    Then I don't think it should need something else...
  25. RozzaC

    RozzaC Well-Known Member

    Ok..I found something again....

    I was able to reproduce the error you were getting in NetBeans....

    Change these 2 lines...

    set frameworkdir="<your directory>"
    set libdir="<your directory>"

    to these 4 lines....
    REM set frameworkdir=
    REM set libdir=
    set frameworkdir=%~dp0\lib\
    set libdir=%~dp0\lib\

    Apparently...it's an issue that a lot of people and will be sorted....

    Issue 2017 - android - apkbuilder.bat path issue if project drive != SDK drive - Google Code

    They could be talking about Android 1.5 though...

Share This Page