Emulator crash!


Last Updated:

  1. RozzaC

    RozzaC Well-Known Member

    Ok...Here's one more thing to try...

    I was able to re-create the error you get in NetBeans....

    And here's the fix I used..that worked...

    Change these lines...

    set frameworkdir=D:\android-sdk-windows-1.1_r1\tools\lib\
    set libdir=D:\android-sdk-windows-1.1_r1\tools\lib\

    to these 4 lines....

    REM set frameworkdir=
    REM set libdir=

    set frameworkdir=%~dp0\lib\
    set libdir=%~dp0\lib\

    Save the file and then run NetBeans....
    That seemed to work for me...

    Advertisement
  2. Costa

    Costa Active Member

    Hm... that fixed the NetBeans error, but not 100%. Now i can run the application, but the emulator doesn't appear. It ends saying "jar:" NetBeans and the emulator doesn't popup. I think this is now because the emulator crash.

    grrrrrrrrrrrh!!!
  3. RozzaC

    RozzaC Well-Known Member

    Hmmm...

    Can you just confirm for me...

    1. What version of Eclipse you have installed?

    2. What version of the Sun JDK you have installed?


    ---EDIT---

    While you are at it....

    Try these 2 commands in the command prompt...

    1. emulator -audio none
    2. emulator -debug-all
  4. Costa

    Costa Active Member

    Eclipse - Version: 3.4.1
    JDK - jdk1.6.0_13

    :(
  5. RozzaC

    RozzaC Well-Known Member

    When you ran the second command....

    Any error messages pop up in the command prompt window?

    It might be a good idea to try and run that command while running DDMS
  6. Costa

    Costa Active Member

    The pop up error message that appears is the one i wrote on my 1st post.

    DDMS? Can you explain better?
  7. RozzaC

    RozzaC Well-Known Member

    In the tools folder of the SDK...there's a file called DDMS.bat


    Run that and then run those 2 commands i said previously...
  8. Costa

    Costa Active Member

    Nothing happened, only crashed.

    Just opened a debug screen, but didn't look debug was working while i was runing the comands.
  9. RozzaC

    RozzaC Well-Known Member

    Hmmm...

    Strange....only thing I can think of now...

    Is something to do with your registry maybe...(after I researched some more)

    But I really wouldn't know where to start...

    Have you got another computer that you can try running the SDK from?

    ---EDIT---

    http://www.ccleaner.com/

    Just remembered this site...download this program and clean up your registry with it...

    But make a backup before hand though...(also done inside the program..)
  10. Costa

    Costa Active Member

    I clean my computer with ccleaner but still get the error :(

    In other computers should work of course. :) But i need to work in this one i'm now.
  11. RozzaC

    RozzaC Well-Known Member

    Well I wouldn't just assume it will work on another computer...better to actually and make sure you can actually get it working on another computer...

    I'm kind of out of ideas now to try out....
    I'll have to do more research into it...
  12. justjimjpc

    justjimjpc Premium Member VIP Member

    This may have been check and already done or tried.

    In the Device Manager (G1 not connected to Computer) ....
    Are there any Yellow Question Marks ot Exclamation marks ...
    If there are ... Please Delete each of those Devices ... Then Restart computer and try a fresh install ...
  13. Costa

    Costa Active Member

    I already try in my job computer and worked fine. But unfortunally in mine home pc doesn't work.

    I'm sorry but i didn't understand what you mean? I don't have any G1, i'm just trying to make an application using the emulator, but the emulator crashes when i try to run it.
  14. justjimjpc

    justjimjpc Premium Member VIP Member

    The thing with the G1 was a precaution ... just in case there was one ...

    Do you not know what the Computer device manager Is ?

    On most desktops there is an ICon "MyComputer" Right Mouse it and then select Properties ...

    Depending on what version of Windows ... Then Select hardware and then Devices Manager ...

    If there are not any problems with installed Devices you will not see any alerts to these conflicts ... they are marked with Yellow ? marks or YelLow Exclamation marks ...

    If there are any of those ... right mouse them and Delete them ...
    Then after they are all cleared ... Restart Computer and Reinstall the programs you are trying to get to work ...
  15. justjimjpc

    justjimjpc Premium Member VIP Member

    Are the windows versions the same for your Work and home Computers ... and the Service Packs Installed ... Same ...

    What is your home Windows version and service pack configuration ?
  16. Costa

    Costa Active Member

    Yes, they are both Windows XP Professional with service pack 2.

    About Device manager they are all ok, just Bluetooh have a red cross in it, but i think doesn't have nothing to do it.
  17. RozzaC

    RozzaC Well-Known Member

    Oh yeah....Service Packs....how could I forget that...?

    You can tell I'm not suited to be a troubleshooter.. >_>
  18. justjimjpc

    justjimjpc Premium Member VIP Member

    OK ... that sounds good ....

    I will yield you back into the hands of RozzaC.... who is doing a great job of trying to find your problem ...
  19. RozzaC

    RozzaC Well-Known Member

    Why thank you...but you are more than welcome to assist if you do manage to find a solution to the problem =D

    Anyway...Costa....

    Seeing as you are on Service Pack 2...try updating to Service Pack 3 and getting all the latest updates from Windows Update.

    http://update.microsoft.com

    In case you are using another browser...open the site in Internet Explorer...otherwise it won't work...

    It may take a while...so you better get yourself a cup of tea or something while you wait....

    I'll be doing the same...lol...
  20. Costa

    Costa Active Member


    And thats it!! Service Pack 3 installed and emulator working!! :D

    Thank you very much for your help RozzaC!! If you were from here i would invite you to take a beer or something with me!

    Lets wait and see if when i start working the error doesn't come back again. hope not!
  21. RozzaC

    RozzaC Well-Known Member

    You're welcome...

    Thanks to justjimjpc as well...for asking about the Service Packs...

    Probably never would have thought of it if he didn't ask you... =D

    Google should really make that clear on their installation guide that you need WinXP SP3...
  22. justjimjpc

    justjimjpc Premium Member VIP Member

    Glad I was able to help in a small way ....

    "It is not good enough to know to kick it .... but where to kick it" (c) 2009 JustJimJPC :cool:
  23. RozzaC

    RozzaC Well-Known Member

    Hehe...another JustJimJPC original, I see... =P
  24. justjimjpc

    justjimjpc Premium Member VIP Member

    Yeah I thought that would make you chuckle..:D
  25. RozzaC

    RozzaC Well-Known Member

    Indeed it did... :p

Share This Page