Enable Background DataSupport

Last Updated:

  1. kGGG

    kGGG New Member

    So every time I open Google Play on my browser and send an App to install on my s3, I get an error notification saying " Error downloading "App". There is insufficient space on device.

    Now when I try to load up Google play App it says there is no connection even when there is.

    Now when I try to download a Google Play app I get this saying Background Data Disabled, Google Play Store Needs background data to be Enabled. I have two options and it says Quit and Enable, so I choose Enable and I get redirected to the Accounts and Sync. I dont know what to do since my Accounts and Sync are on in Gmail. Someone please help. I want to keep downloading Apps but if this keeps going then I am going to be truly upset.

  2. tmobuser

    tmobuser New Member

    I have exactly the same problem on my Samsung Galaxy SIII. When I access the App Store, I get the "Background Data disabled" message; I click on "Enable" and it takes me to the screen to pick a gmail account. I pick an account, but nothing happens. The same cycle repeats every time I access app store.
    I called TMobile with this issue and after working with them for an hour, which involved unchecking and checking various options in Mobile Networks "Use Packet Data" and "Data Roaming", taking battery off and rebooting etc. it seemed to work for a while. But its back again to its old state.
    Any help would be appreciated.
  3. SUroot

    SUroot Well-Known Member Developer

    Best Answer
    Dudby think we still had that as a setting since Gingerbread. Tried clear data on play?
  4. zemerick

    zemerick Well-Known Member

    There should be a toggle above the accounts, have you tried turning that on ( if its off. )

    Like SUroot I didn't think we actually still had a special setting for background data. I'm going to keep poking around for a bit and see if I can find anything that causes and fixes that problem.
  5. tmobuser

    tmobuser New Member

    Thanks for your help. It works now, here's what I did -
    Task Manager -> RAM Manager -> Clear Memory. I got a message saying 51 applications were closed.
    I could access the play store after that. So it seems like one of the applications/processes is interfering with the play store ?
  6. tmobuser

    tmobuser New Member

    Update :

    The above steps worked for me initially, not anymore.
    I have not been able to access the Playstore for the last week. Same error - "Background Data needs to be enabled". Sometimes it just says "No Connection" with a Retry button.
    This happens even when the signal strength is strong and also if I am on wifi.
    I have tried cleaning up memory, closing all open apps, rebooting etc.

    Any clues as to what could be causing this ?
    Appreciate any help.
  7. nailzer

    nailzer Well-Known Member

    Settings>Data usage. Scroll down and see if Play Store is listed. Open it and at the bottom there a tick box that restricts background data. If it's checked and you're using mobile data un-check it and see if that helps.
  8. Jerred 8448

    Jerred 8448 New Member

    It means that you have filled up your storage space.. I don't know why it doesn't just day that but every time it says "background data needs to be enabled" I go into my files or astro file manager and delete a few things that I don't need. Preferably large files to clear up more space. Every time I do it, it seems to work so just try it before you knock it. Hope it works cheers!!
  9. Jerred 8448

    Jerred 8448 New Member

    That is true Nailzer but every time that it gives me the message.. It shows that its not checked so I'm like what? There's nothing else you can do really. You know?
  10. Synackz

    Synackz New Member

    So this appears to still be a problem. Sorry to bump an old thread but I think I was able to figure it out. Might just be fixed for a short time but here's how I did it.

    Why did it happen?
    While travelling, I was wanting to conserve on data usage. I set the option under SETTINGS > DATA USAGE to "Limit mobile data usage".
    What I think that did was to flip some other toggles in other menus.

    How did I fix it?
    1. SETTINGS > DATA USAGE and UNCHECK "Limit mobile data usage", of course.

    2. Drop down in the same menu to "GOOGLE PLAY STORE". Go to the bottom and uncheck "Restrict background data" which I don't think I checked in the first place.

    If you have a download waiting and you see the arrow at the top right of your droid screen acting like it's currently downloading, you have to stop that to clear the queue.

    Scroll down and choose "Clear data" and "Clear cache"

    So far mine's working. I'll come back here if it stops for some reason. It's a bug, clearly. But I think it's manageable.


    Samsung Galaxy S3
  11. bundalov

    bundalov New Member

    Hi. I had similar issue, Market required Background Data to be Enabled.
    BUT, I had one more thing which worried me: I was getting this error message also: google.process.gapps stopped working blah blah blah.
    So, I went into Settings > Application Manager > All > and scrolled all the way down and saw that DOWNLOADS was stopped. So I enabled it and voila, Market works again :)
    I hope that this will help someone.

  12. lamagu21

    lamagu21 New Member

    I know this post is a little old. But i had the same problem and figured it out, so i thought i would go ahead and post just in case someone comes across this and needs help.

    just because you go to Settings: Data Usage and Press your menu button and Restrict Background Data is unchecked doesnt mean it isnt checked for certain applications.

    To Fix that go to the same place to start Settings: Data Usage. Then scroll down to the list of applications and seleect the app that needs background data (in this case Google Play Store) Then scroll down and make sure the Restrict data is unchecked on that one.

    Sometimes this may become checked/enabled because we opted to not have apps automatically update or run in the background. Thats the only explanation i have anyway, because i have no idea how mine became selected.

    I had tried all the other stuff that was posted ( resyncing, taking battery out, forcing stop, etc.) and it all worked temporarily. This was a permanent fix. :)
    Deebwebs, funkylogik and Mikestony like this.
  13. samsung galaxy s3 are all requesting that the background data should be enabled when going to play store...
  14. Deebwebs

    Deebwebs New Member

    Hi all,
    I had the same problem (Enable background data request when trying to open Play-Store), it happened yesterday when my device (Samsung Galaxy Note II) was updated (Firmware).
    I tried most of the solutions mentioned above, but they did not work. So the only way out was to uninstall the Play-Store Updates, and to get back to the Factory Version of the app., and now it's working again.
  15. atchoo

    atchoo New Member

    "To Fix that go to the same place to start Settings: Data Usage. Then scroll down to the list of applications and seleect the app that needs background data (in this case Google Play Store) Then scroll down and make sure the Restrict data is unchecked on that one. "

    THANK YOU!! This worked for me!
  16. Lhtiller824

    Lhtiller824 New Member

    I have a verizon tablet. I had to go to wireless & networks and hit more...then go to mobile networks and check enable. Hope this helps someone!

Share This Page