Enabling mobile network after idle time not working


Last Updated:

  1. Tolomaüs

    Tolomaüs New Member This Topic's Starter

    Joined:
    Aug 20, 2009
    Messages:
    3
    Likes Received:
    0
    Hi,

    All I want to do is from time to time check my mails. For this, I want to activate the mobile network connection (3G) manually for a short period of time, and then de-activate it again.

    The problem is that enabling the "mobile network" checkbox after my phone has been idle for some time, doesn't actually activate the 3G connection. (no "H" or "G" icon in the notification bar)

    So when I open the mail app it complains with a "connection failed" message.

    Anybody with the same problem?

    Even better would be if I could find a way to have my mails automatically checked whenever the connection is activated ...

    Other than that I'm very happy with the phone.
     

    Advertisement
  2. Tolomaüs

    Tolomaüs New Member This Topic's Starter

    Joined:
    Aug 20, 2009
    Messages:
    3
    Likes Received:
    0
    No one with the same problem? Now, that's strange ...

    Is there a way to troubleshoot the phone and see what's going on under the hood? I'm a regular linux user so don't be afraid to go a bit technical ;-)

    Thanks in advance!
     
  3. rotkehlchen

    rotkehlchen New Member

    Joined:
    Oct 2, 2009
    Messages:
    2
    Likes Received:
    0
    I only got my hero a couple of days ago, but I experienced the same.
    I used to switch the mobile network off during the night, and when switched on in the morning, the connection wasn't established again.
    I have been using this 2G / 3G switch app too (2G / 3G Umschalten v1.0.1 Applikation für Android | Tools) and thought maybe it's an issue with this app, but that app is nothing more than a shortcut to the setting... Anyway, when I switched between 2G and 3G, the connection was established properly. Don't know what's going on under the hood, but it looks like the network interface is restarted when switching?

    As for the email check, this question was going through my mind too :) Sometimes they come automatically, sometimes I have to manually update? Haven't figured out yet how the tasks are managed by android. Does anyone know a good (short) article? If I could only find the time to fight through the SDK...
     
  4. andy d

    andy d Well-Known Member

    Joined:
    Aug 19, 2009
    Messages:
    595
    Likes Received:
    18
    No problem with mine works every time.
     
  5. tobiasbladh

    tobiasbladh New Member

    Joined:
    Oct 2, 2009
    Messages:
    2
    Likes Received:
    0
    I have the same problem. When turning off the mobile network during night, it won't connect again when turned on. Even though it already says in the menu that I have a connection I have to do the following: settings > wireless controls > mobile network settings > network operators > select automatically. Then the mobile network will begin to function again.

    Hope that helps!
     
  6. rotkehlchen

    rotkehlchen New Member

    Joined:
    Oct 2, 2009
    Messages:
    2
    Likes Received:
    0
    I must admit I don't know anything about mobile network operating modes, but maybe that helps:
    ---
    General Packet Radio Service - Wikipedia, the free encyclopedia
    Multiple access schemes

    ... During a session, a user is assigned to one pair of up-link and down-link frequency channels. ...

    ---
    Since the switch on problem only exists after an offline night, maybe the session expired, but the Hero still tries to re-connect to the "old" session instead of creating a new session? And when the interface is re-initialized (2G / 3G switch or operator selection) a new session is started...

    I'm wondering if this is a Hero only problem? Shouldn't stuff like that be handled deeper in the OS?
     
  7. Nominally

    Nominally New Member

    Joined:
    Oct 9, 2009
    Messages:
    1
    Likes Received:
    0
    My Hero has the same problem.

    Tobiasbladh's suggestion works but doing this every time is a bit annoying.

    Does anyone else have an idea?
     

Share This Page

Loading...