Encryption Broke Wimax?


  1. zendritic

    zendritic New Member

    My Design is rooted with the stock ROM. I recently used Android's native encryption, encrypting the device. Since I did that, 4G only searches and never connects. Anyone have any idea what's going on?

    Advertisement
  2. zendritic

    zendritic New Member

    Hi all. I installed CWM and rooted my device and 4G worked fine. Then I encrypted the device with Android's native encryption. Now 4G scans and disconnects. I tried checking the wimax partition with adb and this is what I got in response:

    1|shell@android:/ # wimax_mtd
    wimax_mtd
    Open WiMAX partition ........ OK
    Get HTC WiMAX Tag ........ OK
    Verify WiMAX Tag (HTC-WiMAX-SQN1130)........ PASS
    Read WiMAX partition ........ OK
    Check Firwmare Version (R4624-US-29490) ........ R4624-US-29490
    Check Firwmare File ........ MATCH
    Dev MAC = D8:B3:77:C9:07:57
    Read properties from flash ..... OK
    + in wmx_PropSetFromFlash.
    + in wmx_CheckPropTag.
    - out wmx_CheckPropTag.
    wmx_PropSetFromFlash: Find matched property name in flash.
    persist.wimax.Cold_Boot_Flag = 4
    isColdBoot = 0

    Then when I try to check the RSA keys with this command:
    # grep RSA /dev/mtd/mtd0
    I get this:
    shell@android:/ # grep RSA /dev/mtd/mtd0
    grep RSA /dev/mtd/mtd0
    grep: /dev/mtd/mtd0: No such file or directory

    How do I check to see if I still have my RSA keys? Is it possible that encryption wiped them or is interrupting their use somehow? Should I flash a new unencrypted ROM to see if it fixes the problem? I want my 4G back.
  3. damewolf13

    damewolf13 live~laugh~love VIP Member

    Welcome to AF, Zendritic!:)

    I have moved this into the "all things root" portion of this forum since it involves a rooted phone.
    Threads merged for same content.
  4. MIGzNYC

    MIGzNYC Well-Known Member

    I would try and do a factory reset and see if it helps...

Share This Page