End call button sometimes not responsiveGeneral


Last Updated: 2012-05-22 05:02:34
  1. bc1080

    bc1080 Member

    My phone has been having issues with the end call button. Sometimes it works ok, other times I have to fight with the phone to get it to end the call. Often I will hit the end call button and even though I can see the animation of a button press, nothing happens. Repeated presses do nothing, it can take up to 5-10 seconds for the call to end. I even turned on the accessibility feature using the power button to end calls, but this has the same unreliable behavior as the onscreen button.

    This is resulting in me having a lot of awkward end of calls and unintentionally leaving messages for people because I can't disconnect before the machine starts recording. Including a humorous one where I cussed at the phone for not hanging up and it was recorded on the machine. Has anyone had this happen on an android before, is there a known issue or fix?

    Advertisement
  2. 916x10

    916x10 Well-Known Member

    I noticed this too on 2.3.5, its much better on 2.3.6 in my experience.
  3. macgiobuin

    macgiobuin Well-Known Member

    I have noticed this happening, occasionally. It hasn't been too much of a problem yet, however.
  4. 916x10

    916x10 Well-Known Member

    Just to clarify....I never had it as bad as the op but it def didnt hang up instantly
  5. bc1080

    bc1080 Member

    Hmm, sounds promising about 2.3.6, guess I will see what happened when it gets pushed to my phone. This is my first Android phone, so I don't know if this might be a problem across the OS or just with certain phones.
  6. macgiobuin

    macgiobuin Well-Known Member

    This has been an issue for several people. It happens to me occasionally.
  7. Pappy425

    Pappy425 New Member

    Having similar issue. What seems to work best is to tap the button ONCE and then waiting a second or two for the call to disconnect.

    I was originally either holding the button or pressing it repeatedly which would just reengage the call.
  8. motomod

    motomod New Member

    I've had an Atrix 2 for about a month and it seems to have a hard time disconnecting/responded to End Call, same as suggested here. I have to be careful about what I might say after hanging up. Someone suggested turning off haptic feedback, but that's already off. Have tried different keyboards, still an issue.

    AT&T, Android 2.3.6, BTW.
  9. bc1080

    bc1080 Member

    Just updating on how mine is going. Last week the tech support guys told me I had to factory reset my phone for another reason. When I did I finally got the 2.3.6 push, and this did seem to improve on the issue drastically for my unit. It was not completely fixed, but it did seem to reduce the lag to 2-3 seconds or so in nearly all cases (still not the half second my old phone with a physical end call button did, but an improvement.)

Share This Page