EPAD Upgrade


Last Updated:

  1. aepagsuyuin

    aepagsuyuin Member

    hi! can someone please help me how to fix my Epad.
    its stuck on the home screen, my last option is to upgrade its firmware, (read it, from one of your blogs) but the problem is, my PC cannot detect my Epad when i try to connect the otg.
    please help me. i've been trying to solve this problem for a week now. hoping there's still a way to fix my epad.
    thanks!

    Advertisement
  2. olbriar

    olbriar Moderator Moderator

    For the best help here at the forums for your device, you should check into the sub forum for your tablet. Here is a list of the Android tablets we have sub forums for. Just click on the link in the list that is your device and ask for help there. The friendly users there will be able to help you out.
  3. aepagsuyuin

    aepagsuyuin Member

    where can i see that sub forums? sorry im new here.
  4. aepagsuyuin

    aepagsuyuin Member

    hi i have an android. ive been using it for 2 months already. when i downloaded a map, it suddenly crashed. and when i try to open it again, it freezes on the homescreen where i need to slit to unlock.
    i've read lots of forum suggesting that i need to reflash my epad. so i started downloading necessary firmwares to guide me through the process.
    and when i tried the uburn process, my PC (windows vista 32) cannot detect my EPAD when i tried to connect it from OTG.

    my other dilemma is im not sure what brand is my epad, i already threw the box. im not sure about its specs either because i can no longer navigate my EPAD to see its specs. here's the only thing i'm sure abot it is:
    - an epad (thats what it says on the homescreen
    - it has a penguin on the top left of the screen after the ePad flashed.
    - an android after the penguin on the center left of the screen
    - some sort of a google logo forming on the center of the screen.
    - its a 10 inches tablet.

    please, someone help me fix my epad. i spent my savings buying this product, i dont want it to put to waste after 2months.
    thanks.
  5. xmr405o

    xmr405o Well-Known Member

    Welcome to the forums aepagsuyuin!

    Its hard to tell what epad you have with more info but the way you describe it, you might have a ZT-180. That's one of the more popular epads. Here's the link to the subforums..

    Zenithink ZT-180 - Android Forums

    If it is the ZT180, you might want to google for burntool for ZT-180. You can reflash a stock rom or custom rom with that.

    Good luck!
  6. aepagsuyuin

    aepagsuyuin Member

    thanks, i already tried burntool, but the is, my PC can not detect my Epad when i try to connect it with OTG. i know there is still something im missing, i just cant figure out what.
  7. ralfsac

    ralfsac New Member

    help meeeee...!!!!! please!!!!

Share This Page