Eris 2.1 Feature EnhancmentsGeneral


  1. triphumphrey

    triphumphrey Active Member

    So, I mean no ill will towards any of the people positing about 2.1, but I am a little tired of hearing the same thing over and over so here are my questions about 2.1.

    Can you create Cisco IPSEC based VPN Connections natively?

    Can you use an imported certificate to create 802.1x wireless connections?

    Can you change the lock-screen wallpaper natively?


    Is there a packaged widget to adjust backlight brightness like there is to toggle wifi bluetooth and 3g? (Answered: superchaos)

    Any posted benchmarks on performance?

    Does the Swype Beta work on 2.1? (Answered:ericDylan)

    Has bluetooth control been improved/fixed in 2.1? (Answered: ofTheDamned)

    Are you able to download/install/generally manage both personal and root certification authority certificates? (Answered:effinay)

    Thank you all you brave souls...

    Trip

    Advertisement
    :
  2. tuahogary

    tuahogary Well-Known Member

    +1
  3. ericDylan

    ericDylan Well-Known Member

    those there words were confusinin. anyways the only question i can answer is swype beta. yes it works. hope you get your other questions answered
    triphumphrey likes this.
  4. triphumphrey

    triphumphrey Active Member

    Thanks for the prompt response. I work in a large enterprise environment ...hence.. .the more complex questions but I dont think I could live without the swype keyboard.
  5. triphumphrey

    triphumphrey Active Member

    These may require a little digging so I appreciate anyone that can assist...
  6. triphumphrey

    triphumphrey Active Member

    Added another questions regarding 2.1 to my original post. Still looking for answers.
  7. bjanow

    bjanow Well-Known Member

    Cisco VPNs are very particular and don't even work with 64bit systems yet. Why you would want to do that with a phone is beyond me, but I doubt you will have much success or continued connectivity even if you were able to initialize.

    As for 802.1x, what would be the reason to do that on a phone? The phone would have to authenticate to a radius server or have port based security. To what end?

    I would merely buy a low end laptop for under $500, keep it light, perhaps even a netbook. That sounds like it would be a whole lot easier and more efficient. Then you can use the phone for important things like making phone calls. jk. ;-
  8. effinay

    effinay Member

    I'm going to attempt to install a root cert today so I can get my activesync working without throwing security warnings. The warnings seems to only appear after a reboot of the phone.

    I've tried putting the .CER file on the SD and then used ES File Explorer to open it, but the phone doesn't know what to do with the file. I can't remember what I did to make it work on 1.5, or if I even attempted it.

    I'll post results.

    UPDATE: I was able to install a personal certificate (.p12) with no issues. Still trying to install a root cert.

    UPDATE #2: I have not been able to figure out a way to import a CA Root cert at all. I've tried everything I can think of. If anyone has any ideas, please share them.
    triphumphrey likes this.
  9. smoked_toast

    smoked_toast Member

    Yes- after applying the 2.1 update - specifically bluetooth has improved for me in the following ways:


    • When playing music from my phone over my car stereo, the sound used to suffer from weird pitch and tempo changes, which made the music sound TERRIBLE. There were also small gaps of silence. All of that is now fixed and audio over bluetooth works perfectly.
    • Connectivity to my car stereo is automatic now. I used to have issues with my phone not auto-connecting wheneever the phone was in rage.
    • Call quality over bluetooth is noticeably better for me as well.
    With 1.5 my biggest complaint was the issues with bluetooth, which have all been fixed. Couldn't be happier.
  10. triphumphrey

    triphumphrey Active Member

    I want to be able to connect to my place of work using their IPSEC based vpn servers. I am able to connect to this type of server with Windows 32 or 64 bit, Mac, Linux, and iPhone. I am unclear what part of the process leads you to believe that it would have connectivity issues unless of course the android phone just does not support it.

    The reason is similar to the one mentioned above. I want my phone to be able to access Intranet resources within my enterprise. Furthermore, you do not need either of the methods you mentioned above for authentication if certificates can be used on the android phone.

    I have two laptops and two phones. I do not need an additional item to tote around. While i realize it was a joke....making phone calls is the least frequent reason I use my eris.
  11. triphumphrey

    triphumphrey Active Member

    Are you now able to use the voice command function from your headset to make a call?
  12. smoked_toast

    smoked_toast Member

    I'm not using a BT headset, just a bluetooth car stereo with a built-in microphone for dialing / talking. But I can say that voice commands do not work for me over it after the update, although they never did before the update either.
  13. OfTheDamned

    OfTheDamned The Friendly Undead VIP Member

    This is a global Android issue and has not been addressed for any phone so far. We can all keep our fingers crossed for 3.0 I guess.
    triphumphrey likes this.
  14. GoenMo

    GoenMo Well-Known Member

    Dude. its a phone! Not a portable IT department. :p
  15. bjanow

    bjanow Well-Known Member

    Wow, do tell. I can't get my Cisco VPN client to run on Win7 64bit. It's simply not supported by Cisco at all. I thought you said Cisco VPN earlier but maybe I was mistaken.

    I'm sorry, but I don't know why you would want this little, itty bitty thing to connect to a corporate network when you carry 2 laptops. Not bustin' ya, just wondering. Maybe I'm missing something I should be doing too.
  16. triphumphrey

    triphumphrey Active Member


    Naw man I like the conversation. I run an internal XMPP server and I woudl liek to be able to access it from home without having to vpn in on my desktop. Just as an example.
  17. jmastron

    jmastron Well-Known Member

    In fact, BT Voice Dialing is being actively ignored by Google (listed as a medium priority enhancement for well over a year; no updates from Google and all attempts to file as a bug get merged with no comment), and is the second most starred issue with Android:

    Issue 1181 - android - [VoiceDial] Voice confirmation for Voice Dialer - Project Hosting on Google Code

    Feel free to go star it some more. I love my Eris, but this is a major defect that virtually every other phone supports (including iPhone and most 5 year old dumb phones). I almost returned it over this, and I still curse it every time I have to fumble to get it out of my pocket, hit 3-4 keys to dial, and have to leave it on the seat (where I forget it half the time) because the screen is still unlocked. And I only make a few calls a week in the car...

    It does appear that the Blueant Q1 headset has its own speech recognition and speed dialing that may work with the Eris; I'm going to get one to try.
  18. effinay

    effinay Member


    I got it to work... it took A LOT of playing around but it seems to be working. On our CA, I ran MMC and added the snap-in for certificates for both personal and local computer. While browsing through one or the other, I was able to locate the Root CA Certificate that had the keys included. I exported that file and included the keys and saved it to the desktop. When I did that, it allowed me to save it as a .p12 file, which CAN be installed on the Eris using Menu --> Settings --> Security --> Install from SD. After the import, make sure you selct the option for "Use Secure Credentials" in the same menu.

    I'm not sure if this is the correct procedure for any of this, but I seem to have been able to get it working. No more security warnings in the Exchange sync or when visiting OWA in the browser.
    triphumphrey likes this.
  19. maddog015

    maddog015 Well-Known Member

    Can't you just use google voice dialer? Or does it not work like that?
  20. OfTheDamned

    OfTheDamned The Friendly Undead VIP Member

    Not through the bluetooth headset. You can hold the phone up and press the green call button and use voicedial, but we want to hit the button on the headset while the phone is in our pocket or purse and have it ask us who to call.
  21. r2d2

    r2d2 Well-Known Member

    My experience with bluetooth has been great.

    Prior to the upgrade, any Google contacts that I had that was only company named (no first or last name entered, just company) would only show blanks on my car's bluetooth. Also, sound quality was bad. Couldn't understand anyone that called me. And they couldn't hear/understand me...

    After the update to the leaked 2.1, any entry without a first and last name (just company) displays correctly - no blank entries. I can use the hands free in the car now. Sounds good.

    No way I'm going back to 1.5 (even if I could).
  22. dirtmouth

    dirtmouth Well-Known Member

    after installing the leaked 2.1 i can only take calls and hang up now. no voice and no LNR for some reason.
  23. alprazolam

    alprazolam Well-Known Member

    I really miss that feature and it's ridiculous not to be built in and working even better than the dumb phones. One plus is that I can now use voice search while the bluetooth is connected. Before, I had to turn the bluetooth off to even be able to hold the phone up to my mouth for the search.

    I have a Motorola S9 stereo headset and it constantly asks for a pair request in which I have to enter 0000 to get it to connect. Is it just my headset?
  24. r2d2

    r2d2 Well-Known Member


    There's a setting in the bluetooth area (on the phone) to always grant permission to this device. Look there - if not, I'll check in the morning to let you know...
  25. bjanow

    bjanow Well-Known Member

    I believe it is the correct procedure. However, I just bought a wildcard cert from one of the big boys, costs about $199 / year and every warning went away. I don't even get them on my browsers any longer. That was such a royal pain.
Loading...

Share This Page