Eris no longre gets hot or eats battery! But, can't sync google contacts...General


Last Updated:

  1. Slugdoc

    Slugdoc Well-Known Member This Topic's Starter

    Joined:
    Nov 15, 2009
    Messages:
    211
    Likes Received:
    13
    So, like many of you, my phone would occasionally get hot, and the battery would just zoom down to nothing. Usually this was just intermittent, and a restart would cure it.

    On June 10, it was happening, and persisted despite restarts, battery pulls, etc.

    I finally found that the problem was google trying to sync contacts. It was having some problem and cycling forever.

    When I unchecked the google contacts sync in the accounts preference panel, problem stopped. My battery life has never been better. Routinely getting 18-20 hrs or more.

    BUT I want to sync my google contacts! Every time I trial re-checking that box, it cycles and cycles, every few seconds giving a little error at the bottome of the screen (in prefs) "Sync is currently experiencing problems. It will be back shortly".

    It ain't back.

    I have 700-something contacts (Only 250 real "My Contacts" but another 500 or so auto-created contacts from gmail use.
    Presumably one of those entries has some corruption, but I can't figure out which, and I don't want to potentially lose all the contacts.

    I have seen that for some people this was fixed by factory reset and resync, but then the problem came back a few weeks later.


    ANy suggestions?
     

    Advertisement
  2. DaveDragon

    DaveDragon Active Member

    Joined:
    Apr 22, 2010
    Messages:
    26
    Likes Received:
    4
    My wife and I's Eris's started having the exact same problem 3 days ago. I plugged my phone in to charge overnight. When I work up the battery was quite warm and the battery percentage didn't go up overnight. Same Google Contacts Sync error. Unchecking fixed the battery problem but I can't sync my contacts!

    Sent from my Eris using Tapatalk
     
  3. v941726

    v941726 Well-Known Member

    Joined:
    Jun 2, 2010
    Messages:
    357
    Likes Received:
    4
    you can uncheck auto sync and still sync on demand. check your contacts under "people". sometimes you will see double or triple or more of your actual contacts from your phone and/or google. i delete them from the phone and re-sync
     
  4. Slugdoc

    Slugdoc Well-Known Member This Topic's Starter

    Joined:
    Nov 15, 2009
    Messages:
    211
    Likes Received:
    13
    In this situation, sync-ing manually doesn't help, it hangs as well, until you cancel the sync.

    There are many double and triple contacts but they've all been "linked" using that nice feature of the People app.
     
  5. v941726

    v941726 Well-Known Member

    Joined:
    Jun 2, 2010
    Messages:
    357
    Likes Received:
    4
    yeah. i meant syncing manually after deleting all from your phone. forgot about the linking thing too. i dont link mine. did once by mistake. no more
     
  6. Slugdoc

    Slugdoc Well-Known Member This Topic's Starter

    Joined:
    Nov 15, 2009
    Messages:
    211
    Likes Received:
    13
    I've always been afraid that if I delete all, then sync, it will synchronize the deletions, and delete all my contacts on google... I know this won't happen with factory reset, but i'd rather not factory reset.
     
  7. v941726

    v941726 Well-Known Member

    Joined:
    Jun 2, 2010
    Messages:
    357
    Likes Received:
    4
    syncing is supposed to mean sync. not overwrite. unless you want it to do that, which could be the case sometimes. but always have your own backup on your sd card of each. phone and google separately. thats what i do anyway
     
  8. digitaljeannie

    digitaljeannie Well-Known Member

    Joined:
    Mar 26, 2010
    Messages:
    109
    Likes Received:
    28
    Why don't you un-check the sync for the contacts auto-created by gmail and have it only sync your actual self-created contacts?
     
  9. JRJ

    JRJ Well-Known Member

    Joined:
    Dec 6, 2009
    Messages:
    69
    Likes Received:
    16
    I had the same problem and what worked for me was turning on the wifi to sync. I only have the sync problem when connected to 3g so I leave the contacts and calendar sync turned off during the day and sync at night when I get home and can use my wifi. This worked for my eris as well as my wifes eris.
     
  10. Busbar

    Busbar Active Member

    Joined:
    Jan 4, 2010
    Messages:
    29
    Likes Received:
    2
    I fought this problem. Ended up going into settings/applications and deleted the contacts database (after making a backup). Just to be sure I rebooted the Eris and resynced. Took quite awhile (900+ contacts) but it's been syncing fine now for over a week. There's no need to do a hard reset!

    I since resyncing have noticed that some of my contacts on the Eris appear with multiple groups in edit mode, one of which is "System", though I don't have a "System" group. When I find a contact assigned to "System", I edit my groups back to where they were. Too bad there's no easy way to do this.

    I've seen reports from others who said that they had entered contact birthdays without a year, and that that turned out to be the problem syncing their contacts.
     
  11. Slugdoc

    Slugdoc Well-Known Member This Topic's Starter

    Joined:
    Nov 15, 2009
    Messages:
    211
    Likes Received:
    13
    My problem tested the same in wifi or 3g
     
  12. Slugdoc

    Slugdoc Well-Known Member This Topic's Starter

    Joined:
    Nov 15, 2009
    Messages:
    211
    Likes Received:
    13
    Where is this "un-checking" done. In the People app there is option to view only the self-created contacts, but I can't stop them from syncing.

    I did end up deleting all the contacts (By going to Prefs->Applications->Contact Storage and deleting the DB.) then allowing it to resync with google. Seemed to at least temporarily allow syncing to work again (though I lost all the google contacts I had created on the phone since the last successful sync prior), but still all the auto-google-contacts (>500 of them!) were synced as well.
     

Share This Page

Loading...