Error [132]: SIGNARURE ERROR - Magic 2.1 update


  1. Calab

    Calab Well-Known Member

    I am trying to update my Rogers Magic to 2.1 from 1.5. It's not working. When I try it gets as far as updating the signature on the phone and then reports:
    Code:
    Error [132]: SIGNA[B]R[/B]URE ERROR
    Yes, that says SIGNARURE not SIGNATURE! Way to go HTC.

    Anyhow, I've download the file several times with no change. I can't see any reason it wouldn't work. Some details:

    - I'm running Windows XP SP3
    - Phone is NOT rooted
    - I have done a factory reset
    - The OTA update says that the phone is up to date
    - Build number is 3.05.631.7
    - Firmware is 1.5 and has the 911 update
    - I downloaded the 2.1 update from http://www.htc.com/ca/support/h/magic-update
    - I just ran the 911 RUU update and it worked without any issue at all. (Downloaded from http://downloads.rogers.com/wireless/products/htc/magic/RUU_Sapphire_Rogers_WWE_3.05.631.7_R_release_signed_NoDriver.zip)

    How can I log the update progress to find where it is failing? What can be done to correct this issue?

    Advertisement
  2. tridemt167

    tridemt167 Member

    I have same problem with OTA and the manual update running Windows 7.
    Tried with the phone rooted and unrooted.
    Tried factory reset.

    I wonder what the numbers are in terms of people with a working update vs. non-working update?
  3. vikingisson

    vikingisson Well-Known Member

    If you're rooted have your tried the recovery mode update? There are a couple of stock rogers roms that seem to flash nicely. and you keep root. otherwise it looks and acts like stock. ;)
  4. Calab

    Calab Well-Known Member

    I'd just install the Cynogen 6.0 stable, but the instructions are a bit on the confusing side.

    I'd rather stay stock since there's really nothing that root gives me that I need.
  5. JasonSeagull

    JasonSeagull New Member

    I have the same problem, but I know why it's not working...ish.

    Supposedly no one has been able to get the HTC's Android Update working by doing it the manual way! The way you're supposed to do it, is by going to
    Settings>About Phone>System software update, and search for an update "Over The Air" (you must have already updated after the 911 New Years updade).

    Problem is, that isn't working anymore...it worked for the first day the update's been up, but for some reason the phones can no longer find the update! I found this out by going here: Mary @ Rogers (RogersMary) on Twitter . I've been stalking that site, waiting for them to mention that HTC fixed the issue.

    Hope that helps!
  6. Calab

    Calab Well-Known Member

    Well, in the RUU, the file "rom.zip" appears to be defective. I can't open it with WinZip. This appears to be why the update is failing.

    Is there any way to verify this file?
  7. gohan22

    gohan22 Member

    getting the same error.....anyone solved this yet?
  8. aaplus12

    aaplus12 New Member

    OTA started working again last night.... cheers
  9. tridemt167

    tridemt167 Member

    Last night I saw the OTA update came through so I tried installing and kept getting the same "signature error" pop up. Factory resets didn't work. So I started thinking that maybe the E911 update needs to be installed on the phone in order to install the update. That's perhaps what it's looking for.
    Went back and installed the E911 update. Completely wipes the device. Once completed, the phone recognized the new 2.1 update available. Downloaded and installed. It hangs at the three quarter mark and I thought, here we go again. Waited and it worked.
    Hope this helps anyone else.
  10. gohan22

    gohan22 Member

    but u didn't update it manually...i believe anyone that is getting this error and trying to update it manually and not OTA.
  11. tridemt167

    tridemt167 Member

    I was getting the error with both methods. Plus I couldn't find the manual update on the HTC site.
  12. gohan22

    gohan22 Member

    ok this is kinda getting stupid. I just called HTC and i was right...the whole time they were referring to the OTA update and they didn't even know a manual way existed. He could not understand where that file on there website came from and suggested that this is a special case for an individual basis (load of BS). Hes telling me the only option is to do the OTA update.
  13. Dfube

    Dfube New Member

    Good news everyone!

    After much failure with the upgrade I think I made a discovery.

    I started off with the HTC Magic and tried getting the update via OTA. This just repeated "You have the newest update." I then tried updating manually. After trying both in Windows 7 and in Windows XP, I kept receiving the notorious 132 Error "Signarure Error." Because of past issues with Rogers and updates, I decided to call HTC, who told me that it was most likely a hardware issue. I then contacted Rogers, who promptly sent me a refurbished phone.

    Now with my old HTC Magic and a refurbished HTC Magic, I ran some tests. New phone has exact same issues. Back on the phone with HTC, who claimed that they have never heard of this issue. Well, not letting the off that easy, I used my old Magic to do exactly what he told me to do. Hard reset, reboot, check for update OTA. BAM, update starts downloading. I'm dumbfounded until I realised my SIM card was NOT in the phone. REVELATION!

    Now I'm trying with my new phone, downloaded in under 3 minutes. It's installing as I type.

    I believe there is an issue with the SIM cards. I have not tried installing manual install without the SIM card but I will try with my old phone before returning it to Rogers, and will update this thread.

    So here are the steps to install 2.1 if you have the 132 Singarure Error.
    1. Turn off phone
    2. Take out battery, take out SIM Card.
    3. Put in battery and boot.
    4. Check for OTA update.
    4.5 If update is not there, hard reset phone and retry.
    5. ENJOY!


    I will be keeping the old Magic for a day or two, please reply if you want me to try update methods with it.

    Cheers,
    Dfube
    Gooberoo likes this.
  14. T-sang

    T-sang New Member

    :confused: still doesn't work for me. I tried all the above.. and i even tried to update the manual method and still giving me signature error message (and w/o the sim card)...
  15. kkannan1982

    kkannan1982 New Member

    use the 2.1 update from brazil... it works fine with gold card...
  16. kkannan1982

    kkannan1982 New Member

    The link for the SAPPIMG is
    http://www.heartbit.com.br/HTC/SAPPIMG.zip

    download the SAPPIMG.zip and save to your computer.

    Run the following command to flash
    fastboot flash zip SAPPIMG.zip

    (Remember you need gold card for this)

Share This Page