error: bad tasker package version


Last Updated:

  1. thahim

    thahim Well-Known Member

    I am getting this error when trying to create apps
    From tasker

    Bad tasker package version 4023, need 4025
    Wonder how to work around this
    I dont have a domain web aite iam using my invert email id
    Com.domain.myname.coumtry.app

    Advertisement
  2. electricpete

    electricpete Well-Known Member

    It indicates that your app factory is not the correct version for your tasker. If you updated your tasker recently, then you need to update your app factory too.
  3. thahim

    thahim Well-Known Member

    How can I update if I havnt got any updates in play store.
  4. electricpete

    electricpete Well-Known Member

    Just to verify-
    Play/menu/My Apps...
    There is nothing under "updates" or "manual updates"?
  5. thahim

    thahim Well-Known Member

    No update for App Factory
  6. electricpete

    electricpete Well-Known Member

    I searched the Tasker google groups forum for the words ""Bad tasker package version" and there were 5 diferent threads addressing this. The number combinations folowing those keywords were all different, but every one involves a mismatch between the Tasker version and the App factory version. For some reason I haven't encountered before, the resulting messages show up in a link that is tied to the search (similar to link above) and doesn't seem to work when I cut/paste, but here are the links anyway:
    https://groups.google.com/forum/?fromgroups=#!searchin/tasker/%22Bad$20tasker$20package$20version%22/tasker/240UNuLxi5s/C0xpM0YD3K8J
    https://groups.google.com/forum/?fromgroups=#!searchin/tasker/%22Bad$20tasker$20package$20version%22/tasker/AN8ibOaAydw/3UShN7vKh98J
    https://groups.google.com/forum/?fromgroups=#!searchin/tasker/%22Bad$20tasker$20package$20version%22/tasker/P6SYY8u6Kgc/JoeLeUwFzpkJ
    https://groups.google.com/forum/?fromgroups=#!searchin/tasker/%22Bad$20tasker$20package$20version%22/tasker/TrU8GOWaJ1M/-aGDbrooQDsJ


    Here is a google search that may provide a better link to all of the threads:
    https://www.google.com/search?q="Ba...s.google.com/forum/?fromgroups=#!forum/tasker

    Here are App factory Apk's
    Index of /releases

    As I said, it seems reasonably certain your problem is that your Tasker and App Factory versions don't match. I don't follow the version numbers and error numbers closely enough to know the ones you need. I'd think if you have most recent version of each you're ok, but there are also two most recent versions of each...one for Android 4.0+ and one for Android 2.3. Maybe you have 4.0 version of Tasker and 2.3 version of App factory? (beats me). I think if you pore through the messages you might find the path to resolve your particular mismatch. Or else contact Pent via email or forum and ask him.
    thahim likes this.
  7. thahim

    thahim Well-Known Member

    Thanks I downloaded differwnt version of app factory from that index and it worked.
    But I cant find the exported apk. Do u know where it is?
  8. electricpete

    electricpete Well-Known Member

    My kid apk's show up in directory:
    /sdcard/Tasker/factory/kids/
    thahim likes this.

Share This Page