Error: Device not found (adb issue)


  1. MK_9

    MK_9 Active Member

    K my frustration level is definitely climbing.

    I've checked and don't see anything related to this specific issue.

    I'm following the step by step instructions on RootYourDroid. Have tried both the custom recovery image (adb shell is what's getting me that message) and the busybox instructions. Each time, in the adb window when I try either option I get an "error: device not found" After doing some research, I found info saying it likely had something to do with the debugging drivers. So I uninstalled them, reinstalled them and went through that whole process again. Tried both the busybox and custom recovery image steps. Still getting the error message.

    Anyone have any experience with this issue that might be willing to sling some help my way?

    Advertisement
  2. Fabolous

    Fabolous Superuser VIP Member

    Do you have USB debugging enabled under your settings, application, development?
  3. MK_9

    MK_9 Active Member

    I do.
  4. DiegoMejia

    DiegoMejia Well-Known Member

  5. MK_9

    MK_9 Active Member

  6. vincentp

    vincentp Well-Known Member

    I'm stumped. I had the same problem when I first installed ADB, but installing the Motorola drivers fixed it.

    "adb devices" doesn't list anything? Did you check to make sure the drivers are properly installed? They should show up in Device Manager under ADB interface or something like that.
  7. esocid

    esocid Well-Known Member

    This happpened with me, but when using rds lite. It wouldn't recognize it, so I uninstalled drivers, rebooted, reinstalled and tried a different usb port and it started working again. So try another port.
  8. MK_9

    MK_9 Active Member

    K tried this. No longer getting that message and adb is showing in the device manager.

    Unfortunately now, I'm getting a permission denied message when I try to copy the flash_image file. :(
  9. esocid

    esocid Well-Known Member

    Copying it to where? Certain directories will require root access. So type su first. If it just sits there you may have to look at your phone and press allow in the little permission box that pops up.
  10. natediddy1120

    natediddy1120 Member

    To the OP, are you using Windows? Or Linux or something...
  11. SagayIam

    SagayIam New Member

    Below is the content of the text file named "adb_has_moved.txt
    You will find it in the following path:

    C:\Program Files\Android\android-sdk\tools
    or
    C:\Program Files (x86)\Android\android-sdk\tools
    =============================================

    ---The adb tool has moved to platform-tools/

    If you don't see this directory in your SDK,
    launch the SDK and AVD Manager (execute the android tool)
    and install "Android SDK Platform-tools"

    Please also update your PATH environment variable to
    include the platform-tools/ directory, so you can
    execute adb from any location.---

    ==============================================

    adb shell Solution:

    I am assuming you have downloaded and installed Java JDK (not JRE) and Android SDK.

    Open your environment variables. How?
    Right-click My Computer, properties, advanced system settings, environment variables.

    Now update your adb path as follows:

    In the System Variables group, double-click path
    1. scroll to the end of the environment string
    2. Type ;
    3. type C:\Program Files\Android\android-sdk\platform-tools
    ** Please note that the path is case sensitive

    If you have a 64 bit system
    3. type C:\Program Files (x86)\Android\android-sdk\platform-tools

    4. click ok, ok

    Now your adb shell will work flawlessly.

    If it worked for you (I know it will), a little thank you will be proper.
  12. chbhargava

    chbhargava New Member

    I had similar problem.. my device *some times* does not get detected.
    But, it works fine after restarting the computer - which was real pain!

    Following steps worked for me, with which we can avoid restarting of computer:
    1. Start -> run: type "services.msc" and enter
    2. Search for "FsUsbExService" -> right click restart.
    3. Restart adb server
    Open command prompt (Start -> run "cmd" and enter)
    <Go to "platform-tools" dir OR add this to system's PATH variable>
    adb kill-server
    adb start-server

    Hope it works!
  13. androiddev561

    androiddev561 New Member

    But,I have different path for sdk (E:sdk/...).when I set that path error occured 'Failed to set data for path'.
    I used adb devices command to check device it gave me name of device connected.
    what to do now?Please help me
    Thanks in advance.

Share This Page