Error geeting Apps form Play Store


Last Updated:

  1. Paul30824

    Paul30824 New Member This Topic's Starter

    Joined:
    Nov 12, 2012
    Messages:
    1
    Likes Received:
    0
    Hi All

    First time posting.

    Just recently got the following message when trying to download/install from PlayStore: "Error retirieving information from server. [RPC:S-5:AEC-0]

    any thoughts?
     

    Advertisement
  2. eyebeam

    eyebeam Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    5,418
    Likes Received:
    3,091
    Hi Paul - Welcome to Android Forums.

    Ok, give this a try: Make sure you know your Google username and password, then go to settings > accounts and Sync (or something like that - it will depend on your phone) and remove your Google account. Now open play store and either re-add, or select your account.

    Hope that helps.
     
  3. kokotele

    kokotele Member

    Joined:
    Apr 7, 2010
    Messages:
    7
    Likes Received:
    1
    I'm getting the same error on an HTC Thunderbolt today.

    I went to remove the account as you suggested, but it's the only account I have on the phone and it won't let me remove it without doing a factory reset. Since I just did a factory reset yesterday and have been downloading apps without problem so far, I'm hesitant to do that again.
     
  4. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Joined:
    Sep 5, 2012
    Messages:
    12,645
    Likes Received:
    3,552
    If you already performed a factory reset as suggested above, removing the account causing a factory reset would do the same thing as performing any old factory reset, so just keep redownloading apps and hopefully the problem will not arise again.
     
  5. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Joined:
    Feb 15, 2012
    Messages:
    9,109
    Likes Received:
    2,920
    You could also try clearing the data or cache on the Play Store app. Hope this works and welcome to Android Forums. :)
     
    eyebeam likes this.
  6. eyebeam

    eyebeam Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    5,418
    Likes Received:
    3,091
    Hmmm... That's odd. I have an HTC too (Evo 3D) and when I got to Accounts and Sync, then tap on Google, I get the option to Delete Account.

    Maybe see if this does the trick - Settings > Applications > Manage Apps > find and click on Google Play Store > Clear Data & Cache

    Also, it could just be that since more than one of you is getting this error, that Google Play is being a little wonky today.
     
  7. Atma

    Atma Well-Known Member

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,900
    Welcome to the forums Paul. :hello:

    I don't think it is just you. I'm also getting an error on my phone and I've seen posts from several other people on different devices having this trouble. It seems like it may be Google. I just got home and tried on my Nexus 10 and it is working. I just tried my phone and it is working again so it may work for you now.
     
  8. kokotele

    kokotele Member

    Joined:
    Apr 7, 2010
    Messages:
    7
    Likes Received:
    1
    FWIW, I just tried downloading again without doing any other troubleshooting steps and it's working, so it must have been a Google thing.
     
    Metroid Prime likes this.
  9. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Joined:
    Feb 15, 2012
    Messages:
    9,109
    Likes Received:
    2,920
    Glad it resolved itself. :)
     

Share This Page

Loading...