ERROR "SD Card Unmounted or Not Present"


Last Updated:

  1. Flashrat

    Flashrat Member

    Hi All. Can anyone help.

    I have put some pictures from my PC onto the SD card and plugged it back into my Flytouch 3.

    Using MYPAD I can see the card as SD1, which then shows me the directory I put my pictures into. All the picture files show up on the screen, but when I touch the filename twice (double click I suppose), I get the message "SD Card Unmounted or not present" then just a black screen.

    Same error if I try to read from a USB stick.

    Next I tried (using MYPAD) to COPY & PASTE a jpg file into the DCIM/Camera folder on the LOCAL drive, but this gives me a "Paste failed because disk cannot be written. Please check the disk" error.

    Am I missing something basic here? (I had no trouble putting files onto my HTC Desire phone's card)

    If I however double click an MP3 file I get the option of 2 music players come up and both will play the file. Also worked with an AVI file which used Video Player. Just won't allow pictures. (From USB Stick "UDISK 2")

    Advertisement
  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Sounds like a faulty SD Card.

    You could try an app like h2testw to see if there is anything wrong with it.
  3. Flashrat

    Flashrat Member

    Oddly, when I turned the Flytouch 3 back on later in the day and went to the Gallery it was now showing the picture folders I had earlier put on the SD card.

    Maybe some type of scan was needed before the computer would see the files. Strange.
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Indeed.

    As long as it's working, that's the main thing :)
  5. Jodabro

    Jodabro New Member

    I have been fighting this issue for 6 months, off and on. Used to think it was the SD Cards, but have concluded its got to be software. I used different methods to fix it, but over trial and error I think I found the easiest way.

    Reboot into Recovery, go to advanced options. Select to mount via USB, then connect to a pc. May take a few times plugging in and out, till you get the sd card drive to appear on your pc. Once you get it, back out of usb mount. Disconnect the cord, and verify your sd card is mounted. I just go into the install a zip from sd card option, if I see files/folders I know its mounted. back up and select the restart device.

    This method I stumbled on, in my efforts to just try and get my phone back. After I made the mistake of formating everything includeing the boot, and other internal components. Was pure luck, but it works. I know now it wasn't the format of the SD Card nor the sd card itself, cause I have tried several. Also used to think it was the file system, cause I used to get the cards working again by formating and then pasteing saved files/folders from an earlier back up. Also have factoy reset many times, that doesn't fix it, and reflashing a ROM sometimes does appear to work, but I think its because of restucture of the file system during that process. Anyway let me know if this helped you.
    Aralia likes this.
  6. Aralia

    Aralia New Member

    Thank you! I got that error message and I fixed it following your instructions :)

Share This Page