Support Errors when transferring music to samsung galaxy SII

Discussion in 'Android Devices' started by samger2, Dec 22, 2012.

  1. samger2

    samger2 Member
    15

    Dec 22, 2012
    9
    0
    15
    I have a Samsung Galaxy SII which I use as my music player more than I use as a phone. Lately when putting music onto my phone I've been getting two different error messages, this is one:

    [​IMG]

    The other says something to the effect of "cannot copy file root is too deep". However, I can copy the files to a thumb drive, then copy the files to my work PC and from there to my phone without issue. So the problem appears to lie between my home PC and my phone. I tried updating the drivers on the USB ports but they were up to date. Any suggestions?
     

    Advertisement
  2. Digital Controller

    Digital Controller The Real Bass Creator
    Guide
    843

    Sep 5, 2012
    12,647
    3,553
    843
    Male
    Civil Engineer
    Cincinnati, Ohio
    Make sure you are updating to the correct S2 drivers as i know there are alot of different S2's, also if you tell me your carrier I can move this to the correct device forum, that way you can get some more specific assistance.
     
  3. samger2

    samger2 Member
    15

    Dec 22, 2012
    9
    0
    15
    Ok thank you. My carrier is AT&T.

    And as a smal update, it turns out I CANNOT move stuff to a thumb drive...so it almost sounds like there's an issue with my USB drives of some sort. I tried to move music to my thumb drive and couldn't...same error.
     
  4. Rush

    Rush {<>}~{<>}
    1,033

    Jan 31, 2011
    18,742
    3,140
    1,033
    Male
    Entrepreneur / Business Owner - Freelance Writer
    Loganville, GA
    Hi samger2...

    Welcome aboard. I moved your thread to its area of support for more specific assistance as suggested by Guide member, DC.

    Best of luck. :)
     
  5. samger2

    samger2 Member
    15

    Dec 22, 2012
    9
    0
    15
    Much appreciated
     
  6. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    8,028

    Jun 12, 2010
    31,383
    24,924
    8,028
    Male
    IT
    Pennsylvania
    If the error you are getting is about file root being too deep, I would guess that the full path is exceeding the 255 character limit for transfer. If you have a lot of descriptive folder/file names with a lot of nested folders for organization, you can easily hit the limit. For example:
    Code (Text):
    1. /sdcard/music/my account path from windows/my music/all albums that have been copied/my favorite albums/my artists/my favorite artists/the first album by my favorite artists/1-the first track by my favorite artist on the first album.mp3
    is not quite 255 characters but could easily cause a problem with commands included.
     
  7. samger2

    samger2 Member
    15

    Dec 22, 2012
    9
    0
    15
    Wouldn't it error regardless of what computer I'm trying to transfer from though?
     
  8. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    8,028

    Jun 12, 2010
    31,383
    24,924
    8,028
    Male
    IT
    Pennsylvania
    Only if the path were exactly the same. You might see that error if there are any non-standard characters in the file name.
     
  9. samger2

    samger2 Member
    15

    Dec 22, 2012
    9
    0
    15
    I guess I'll have to look at the path...thanks!
     
  10. samger2

    samger2 Member
    15

    Dec 22, 2012
    9
    0
    15
    I checked the path...there's really nothing in there other than well...the path. It's not very long, no additional characters. It's obviously a communication issue between my phone and the puter or the USB outlets. Yesterday I plugged my western digital hard drive in and attempted to move some music from the PC to the HD...it worked flawlessly. It worked so flawlessly that I actually moved my entire library onto the HD with no hiccups or errors.

    Not sure what on the phone is causing this error when it's plugged into my PC.
     
  11. samger2

    samger2 Member
    15

    Dec 22, 2012
    9
    0
    15
    Well I narrowed it down even further. Last night I moved a bunch of music from my external HD to my laptop, plugged in my phone and began transferring music...while it did NOT error this time, it DID however never complete...just kept taking forever...like 10 minutes to copy one album of music from the HD to the phone...and it still never completed. So I finally removed my mini USB from the phone and plugged it directly into the laptop and was then able to move music from the laptop directly to the USB card quickly and without issue.

    So the issue lies somewhere in the communication between my phone and the computer. For now I'm pleased that I can finally add music to my phone.
     

Share This Page

Loading...