ES File explorer weird issue


  1. Flatsix_Power

    Flatsix_Power Member

    I want to create a directory called "app" in the root /data/sdext2 which it refuses "sorry,operation failed!", in the same directory I can however create a new file without a problem. What's going on here? Since I can create a file I obvious have write permissions for that folder.

    I can create files in all directory including root, while folders can only be created on the sdcard. I can't find a logical explanation for this

    Advertisement
    :
  2. BigRedGonzo

    BigRedGonzo Well-Known Member

    In ES File Explorer, go to settings>root settings check the box to mount file system. Then try to create the directory. Make sure you unmount the system after you are done.

    BigRedGonzo
  3. Flatsix_Power

    Flatsix_Power Member

    Thx for replying,

    Nope didn't work, already tried that.

    Cannot "create" a folder in the /data/sdext2 directory (sorry, operation failed!)
    I can however:
    -Create File
    -Delete File
    -Rename File
    -Rename Folder
    -Delete Folder

    This is why this does not makes any sense to me, if I didn't have any permissions I shouldn't be able to do any of these. All permissions are rwx

    Just tested with root explorer lite, and tis can "create" a folder no problem, I can then rename or delete it in es file explorer, but if I want to create it again in es file explorer "sorry, operation failed!" message

    it almost looks like a bug in es file explorer, but if it was I should be able to find it on google shouldn't I?

    Maybe some extra system info:
    Wildfire S 2.3.5, unlocked S-ON with simonz utility, CWM recovery, stock rom, apps linked with link2sd

    edit: I also can't move a folder, it says moved successfully but the folder is not in the directory. If I do the same with a file no problems.
  4. saptech

    saptech Well-Known Member

    Maybe naming the folder app is the problem within that path. Did the other app let you create the folder name app?

    Just a thought!
  5. BigRedGonzo

    BigRedGonzo Well-Known Member

    I apologize, I didn't read well enough. I can create a folder on the root, but I don't have the directory structure that you are referencing. I have root\data, but no sub named sdext2. I was going to check and see if maybe there was a hidden app directory in the sdext2, but since I don't have it I can't. I'd like to help more, but without that directory tree, it's not really possible. You may want to check for a hidden directory called app in the sdext2 directory.

    Good Luck,
    BigRedGonzo
  6. Flatsix_Power

    Flatsix_Power Member

    Thx, for all replies

    it doesn't have to be in the sdext2 directory (this is the mounted ext2 formatted partition created by link2sd by the way) I also tested it in other directory under different name but all attempts failed.

    ES file explorer refuses to create a folder "anywhere" in the root, I can create files everywhere I want just fine but not folders. I can also rename en delete folders anywhere I want.

    Personally I'm thinking the create folder option in ES is the culprit, but why does it let me create folder on the regular SD partition (music for example)

    Normally logical thinking solves many things, but it does not make any sense anymore.
  7. hstroph

    hstroph Well-Known Member


    Hmmm ... I can create "Folders" anywhere I choose. The only time I get the exact error you describe is when creating a "Folder" in any directory where the name already exists.
  8. saptech

    saptech Well-Known Member

    I'm not seeing this /data/sdext2. Not on internal or external sd card.
  9. BigRedGonzo

    BigRedGonzo Well-Known Member

    Flat,

    I get the same results as hstroph. The only time I get that particular message is when there is already a directory named that way in the path location where I'm trying to add the directory.

    BigRedGonzo
  10. Flatsix_Power

    Flatsix_Power Member

    Sorry for the late reply guys,

    I managed to do what I wanted to do, through the command emulator without any problems.

    ES file explorer now updated to a newer version, but still have the same problem. Can't create a directory anywhere in the root or root folders.
    Files are no problem. I tried different names of folders, nothing works...

    What I did noticed is that when I try to create a file it says "superuser access granted" followed by "file created". When I try to create a folder it immediately says "sorry operation failed", and it doesn't say anything about superuser. I tried reinstall, cleared superuser data, nothing works.
  11. EarlyMon

    EarlyMon The PearlyMon Moderator

    You're calling /data/sdext2 the root folder?
  12. RyanB

    RyanB Distributor of Awesome VIP Member

    OP, I may be in way over my head, but is there a reason you can't create the folder elsewhere, and simply relocate it to the directory of choice?
  13. Flatsix_Power

    Flatsix_Power Member

    @ earlymon,

    No I'm not calling the "/data/sdext2" the root directory. The root directory would be "/".
    I can't create folders anywhere, would it be "/", "/data", or any other folder for that matter.
    The only place where ES let's me create a folder is on the regular fat32 partition of my SD card.

    @ ryanb,

    No, I also can't relocate/move/paste folders. Files are no problem
    EarlyMon likes this.
  14. EarlyMon

    EarlyMon The PearlyMon Moderator

    It must be unhappy with your phone, no problem doing it on an HTC.
  15. Flatsix_Power

    Flatsix_Power Member

    Ok, but why is it doing this? There must be a reason
  16. RyanB

    RyanB Distributor of Awesome VIP Member

    Skimming this thread again, I'm inclined to ask if you've tried a different file explorer. Also, if you can access the same files via Windows Explorer, do you have the same problem there? I'd imagine not, but I figure it can't hurt to ask.
  17. Flatsix_Power

    Flatsix_Power Member

    @ RyanB:

    An answer to your question was already in my second post in this thread :), I tried root explorer lite and it has no problems creating a folder.

    Terminal Emulator can also create folders.
    File Explorer ADB can also create folders.

    ES File explorer is the only thing with a problem :dontknow:
Loading...

Share This Page