ethernet problems in ubuntu 12.04


  1. h4x0rj3ff

    h4x0rj3ff Chemist

    so today i popped out my hdd with ubuntu on it and put in a fresh hdd and installed win8 (wanted to try it). i got everything installed, upp and running and decided to go back to ubuntu (for obvious reasons lol) but when i boot back into ubuntu my internet connection will not connect. i booted into a live cd of ubuntu and it still would not work. i thought i blew up my onboard port so i booted back into win8 and the internet worked without flaw. so i booted back into my ubuntu install and i have a usb to ethernet adapter that im using but i still cant get my onboard to connect. any ideas?

    Advertisement
    :
  2. argedion

    argedion The TechnoFrog Moderator

    Try this

    Shut the computer down and unplug you usb ethernet adapter. Restart the machine. Once Ubuntu fully loads plug back in your adapter and see if its recognized and starts to work. I hope that does the trick if not maybe someone much smarter than me can help you.
  3. h4x0rj3ff

    h4x0rj3ff Chemist

    i dont have a problem with the usb ethernet working my onboard isnt working...
  4. argedion

    argedion The TechnoFrog Moderator

    Oops
  5. Prinny

    Prinny Resident Linux Nutcase Guide

    sudo ifconfig

    Look for your interface. Should be eth0 or something like that.

    Then

    sudo ifconfig eth0 up


    Then try



    ping -c 3 http://www.google.com
    ocnbrze and argedion like this.
  6. h4x0rj3ff

    h4x0rj3ff Chemist

    ok when i do that i get

    and the data icon in my notification bar just loops at trying to connect (wifi icon then loading circle) then i get a toast message stating that eth0 is not connected to the internet or something like that

    eth0 is my onboard and eth1 is the usb ethernet adapter
  7. EarlyMon

    EarlyMon The PearlyMon Moderator

    9to5cynic and argedion like this.
  8. h4x0rj3ff

    h4x0rj3ff Chemist

    ok i gksu gedit /etc/network/interfaces

    and added

    auto eth0
    iface eth0 inet dhcp

    then i did

    sudo service networking restart

    and nothing happened so i restarted the computer and it hung on boot at waiting to establish a connection and then waiting another 60 seconds for a connection or something to that effect. then when it did finally boot i had no connection icon in my tray... so i deleted the

    auto eth0
    iface eth0 inet dhcp

    and everything went back to normal... but still no eth0...
  9. Prinny

    Prinny Resident Linux Nutcase Guide

    I would suggest posting on the ubuntu forums at this point. Though can you disable onboard things in the BIOS?
  10. h4x0rj3ff

    h4x0rj3ff Chemist

    yeah everything is enabled in the bios... its a pretty close to fresh install right now anyways and it only takes like a half hour to format and redo everything so im gonna post over at the ubuntu forums and see if i get a bite there before i make any rash decisions. thank you everyone for everything!
    argedion and EarlyMon like this.
  11. h4x0rj3ff

    h4x0rj3ff Chemist

    ok so after posting over at ubuntuforum, i got no replys... o well there. i posted over at askubuntu and i fixed my problem! turns out windows 8 disables your nic after shutdown in the bios... to fix you can ether reset your bios by pulling your battery or use the cmos jumpers and it will do the same thing. OR you can do what i did and boot back into windows 8 and disable the ethernet adapter in device manager then shutdown. after i booted back into ubuntu everything connected without flaw and im back up and running again!
    Granite1, ocnbrze, argedion and 2 others like this.
  12. 9to5cynic

    9to5cynic Well-Known Member

    Hmm.. I wonder why Win8 would need to(choose to) shutdown the NIC..?
  13. h4x0rj3ff

    h4x0rj3ff Chemist

    im not really sure but when i tryed the win8 preview it left a bad taste in my mouth and now that i just tried win8 pro and had this sort of problem, that hdd is gettin reformatted and im done with win 8... been using ubuntu for over a year and going back to windows felt like i just downgraded from my smartphone to an old motorola green screen brick phone... lol
    argedion and EarlyMon like this.
  14. argedion

    argedion The TechnoFrog Moderator

    Because Microsoft is arrogant enough to think that you wouldn't have a dual boot machine. That and they are just butts like that.


    @OP glad you got it working and I'm glad that you have seen the light :D
    ocnbrze and 9to5cynic like this.
  15. h4x0rj3ff

    h4x0rj3ff Chemist

    i normally like to try out new os's when there released to see what they bring to the table. win 7 is a very very nice system. i ran hackintosh for a while and before that i ran mandriva one back when it was mandrake linux. i ran vista for a while when my laptop can preinstalled. and the good ole xp... ran it for years and years. but above all the one that i prefer is ubuntu.
    argedion likes this.
Loading...

Share This Page