1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

Events missing from Calendar - ICSSupport


Last Updated:

  1. Fulltime Traveler

    Fulltime Traveler Well-Known Member

    Since the ICS upgrade, I have been poking around to see if there are any problems on my Bionic. I just noticed that there are many events on my Google calendar that no longer show up in the Calendar app on the phone. All future events seem to be there, but there are many events in the past that are now gone from the Calendar app. Some are on days with other events that are still there, and some are on days in which they are the only event.

    On edit: It appears that the only events still in the Calendar app prior to this month are recurring events.

    I think I would have noticed this if it had been the case before the ICS upgrade.

    Ideas?

    Advertisement
  2. doogald

    doogald Guides Guide

    This is standard Android calendar syncing behavior - when the calendar is first synced after a data wipe, it will only go back 1 month in the past (with the exception that you noted: recurring events in the past month with start dates earlier than one month ago.) As you continue to sync, those events will stay, but if you ever wipe the calendar data, the same thing will happen.

    I don't think that there is any way to change this behavior.
    Fulltime Traveler likes this.
  3. DanDroide

    DanDroide Well-Known Member

  4. Fulltime Traveler

    Fulltime Traveler Well-Known Member

    Thanks.

    Do you know why that didn't happen when I first synced with my Google calendar, back when I bought the Bionic earlier this year? I'm wondering whether I could do something like remove that account from the phone then add it back in.
  5. doogald

    doogald Guides Guide

    I'm not sure. I have had an android phone for three years now, and my last one was rooted and I flashed new ROMs frequently - and my calendar always came back with only one month of history. Again, I always thought that was standard android behavior.

    At this point it won't hurt to try removing the account to see if it does the same thing. Of course if this is your first Google account on the phone you may not be able to remove it. However, on Gingerbread and earlier you could go into settings.applications.manage applications, find Calendar Storage and tap it, tap clear data and it would remove all calendar entries and induce a new sync. I'm not sure what the mechanism is for ICS.
  6. Fulltime Traveler

    Fulltime Traveler Well-Known Member

    Thanks for the suggestion. I cleared the calendar data, and it immediately did a new sync, but it still has nothing other than recurring appointments prior to September 27.

    Sigh...
  7. dave1812

    dave1812 Well-Known Member


    ah, did you update the calendar app in the Play Store to the latest and greatest?? ONLY the new app will give you one year of prior events!!
  8. Fulltime Traveler

    Fulltime Traveler Well-Known Member

    I am using the Calendar app that came with ICS. It's version 4.0.4-29.

    In the last couple hours I have found many reports of this problem, going back several years. (I guess I never noticed it until the ICS upgrade.) There have been at least two workarounds that work with other phones and/or versions of the Android OS, but so far none have worked on mine.

    On edit: I see that others have reported over the years that after first importing their calendars into Google Calendar old events do show up on the phone. It's only after a data reset caused by updating the OS that they disappear.
  9. Fulltime Traveler

    Fulltime Traveler Well-Known Member

    After plowing through hundreds of posts on this issue, including a couple of fixes that didn't work for me, I found one that did. It's here: Issue 3672 - android - Calendar app won't sync events older than 1 month - Android - An Open Handset Alliance Project - Google Project Hosting

    The part that worked are steps 1-10 in that post. Essentially, it involves exporting the Google calendar on the web, making a trivial change to the exported file using Wordpad, then re-importing that file. It takes about five minutes. After the first sync of the calendar, I now have eleven years worth of history at my finger-tips and searchable.

    Huzzah!
  10. dave1812

    dave1812 Well-Known Member

    that's the same version I have, which gives me ONE YEAR of events (going back).
  11. dave1812

    dave1812 Well-Known Member

    please explain "trivial". I tried editing the data but couldn't see any simple way to search/replace all the various strings that needed to be changed.
  12. Fulltime Traveler

    Fulltime Traveler Well-Known Member

    You only need to change a single string. As he said, "Search the first non repeating event, some event that was created just to happen once in the beginning of your Web calendar from where you want to start syncing and CHANGE its SUMMARY: description slightly..."

    I simply added an "x" to the SUMMARY description of an event from 2001, and that did the trick.

    Later in that thread one user reported than changing the SUMMARY line in any non-recurring event is sufficient.
  13. dave1812

    dave1812 Well-Known Member

    Will give it a try tomorrow
  14. dave1812

    dave1812 Well-Known Member

    \
    So what am I missing? I edited a backup of my main calendar, adding an "x" to the text of a Summary item, near the beginning of the file (an event from 2010), saved it, imported it to a test calendar. it shows all the data on the web, but when synced to an android device, it only shows repeating events.

    The calendar I created to test this out is obviously not my "main" or "primary" calendar. Looking at Calendar Settings on the web, it seems as though the first calendar created has different attributes than subsequent calendars. ie, we can't uncheck that calendar from the list, although it can be deleted. Does the process of fooling the sync process to Android, require that it be done on the "primary" calendar--ie it won't work on additional calendars?

    can someone clarify the editing process a bit, as I can't imagine what I did wrong when editing?
  15. Fulltime Traveler

    Fulltime Traveler Well-Known Member

    I only have one calendar, so I have no direct experience with your question. However, I see in the thread I cited earlier that another user used that solution to fix multiple calendars: http://code.google.com/p/android/issues/detail?id=3672#c281
  16. doogald

    doogald Guides Guide

    Now, in that test calendar, go through the process to export that. Edit the earliest non-repeating event in the .ics file. (The items may or may not be in chronological order in the .ics file, so you may need to search for it.) Re-import that .ics file to the same calendar - do not create a new test calendar. See if this works.

    If not, try the same for your primary calendar. (I'd make a copy of the .ics file so you can easily recreate the calendar, just in case.)

    Just be aware - I believe that Google limits the number of syncs that you can make to a Google calendar, and too much of this may hit the sync limit and could cause your calendar to be unsyncable for a brief period of time.
  17. dave1812

    dave1812 Well-Known Member

    When I export calendars on the google calendar>calendar settings>calendar page, the only calendar that exports is the primary calendar. there seems to be no option to export any other calendar. ie, when I view the ics file in notepad, when I search for CALNAME, the only one that shows up is the primary calendar.

    am I missing something?
  18. dave1812

    dave1812 Well-Known Member

    I tried the following, but it didn't work, because while the date was set to 2008, google calendar showed "no calendars".

    "
    1. From home screen hit menu and go to settings. 2. In settings go to Accounts and Sync 3. Turn off the background update and autosync. 4. Go back to main settings menu and go to Applications. 5. Go into manage applications. 6. Press menu button again and select Filter and then All. 7. Find Calendar and select it and delete all data (it will warn you about losing all files just hit OK). 8. Do the same for Calendar Storage. 9. Go back to main Settings menu and scroll down to Date and time. 10. Turn off Automatic and then set date to January 1st 2009 and hit set. (I tried to go all the way back to 2006 on my first try and it just kept rolling the date back to the current one) 11. Wait a second and make sure date remains set to the date you selected. Then select Date again and select your desired date (should be before first entry on calendar.) 12. For good measure I then shut the phone off and then powered it back up after about 5 minutes. (Don't know if it was necessary but I wasn't taking any chances this time.) 13. Go back into Settings menu and select Accounts and sync. 14. Select the Calendar to sync and then go into calendar to ensure its all there. 15. Once it is you can then safely turn on auto time and date again and let all apps auto update in background. "
  19. doogald

    doogald Guides Guide

    When I export the calendars, it creates a zip file (named with my gmail account name with ".ical.zip" added after.) When I unzip that file, there is a folder that has a single .ics file for each of the calendars on my account (in fact, I have 14, one reason why I would not bother to go through a step like this.)
  20. dave1812

    dave1812 Well-Known Member


    ah. DOH! I cant believe I missed that. because I had the file name column a bit narrow, i failed to notice a second file in the unzipped directory, that has an ICS extension. thanks.
  21. dave1812

    dave1812 Well-Known Member

    I'm going to try the edit thing again on the ICS and import it back into an empty primary calendar and see if that does the trick.
  22. doogald

    doogald Guides Guide

    No, I think that the key procedure is to import into an *existing* primary calendar. It *changes* one of the earliest events in the calendar, somehow triggering the sync procedure to sync all events, not just 30 days back.
  23. dave1812

    dave1812 Well-Known Member


    holly crap, my primary calendar (empty) will not import any events (over 1000) even when I try to import an undoctored ICS file. it says that they have been imported before. wtf??

    I created a new calendar and was able to sync all 1000+ events, but wth is going on with the primary calendar not accepting the data from the ICS file (undoctored), when it is empty? I tried empting / reimporting several times. no luck
  24. dave1812

    dave1812 Well-Known Member

    this is the import error I get: (undoctored ICS file)

    "
    Processed 1142 events.
    Successfully imported 0 events.
    Failed to import events: Some of the events in this file were not imported because you had imported them to Google Calendar before. Other events in this file have been imported.."
  25. doogald

    doogald Guides Guide

    That's precisely what you want. You want to change one of the earliest events in the .ics file. You want to keep all of the events in your Google calendar - do not delete them. You want to import the changed .ics file. You want Google calendar to not create a complete calendar of duplicate events - you want it to ignore the items that have not changed, recognize that one was never in your calendar, import that to the calendar.

    In other words, follow this exact procedure, linked earlier by Fulltime Traveler: Issue 3672 - android - Calendar app won't sync events older than 1 month - Android - An Open Handset Alliance Project - Google Project Hosting

    According to that procedure, this will somehow signal to the Android sync agent to sync further back than 30 days.

Share This Page