Evil boot loop!!! Can't seem to fix.


  1. CRADICAL

    CRADICAL Member

    So.... my rooted incredible entered into the evil boot loop. Not sure what exactly triggered it, but occasionally my battery would come a little loose and the phone would reboot. I did quite a bit of searching to try and fix it, but no luck. I can only load hboot, no clockworkmod recovery. Any additional suggestions or help would be awesome.

    A little info about my phone -

    Rooted HTC Incredible - Rooted using unrevoked
    s-off
    radio - 2.15.00.07.28 (was previously running a different radio, an earlier one, but flashed this radio as part of an attempted fix)
    hboot - .92
    was running CyanogenMod7 when evil boot loop started
    AMOLED (non-slcd, I think?)
    no overclocking
    no kernel changes
    sd card is FAT32 formatted

    Attempted fixes -

    I have tried flashing a few different clockworkmod versions with PB31IMG.zip files. Most just enter the boot loop, however, one version loaded CWM for a few seconds, then entered the boot loop. I saw the green text of the clockworkmod recovery and thought I was home free. I believe that was this file (http://dougpiston.com/files/Recovery/recovery-clockwork-2.5.1.2-inc_PB31IMG.zip), or another version that was 2.x.x.x.

    Next attempted fix was flashing a stock build through hboot and a PB31IMG.zip. I used this build (http://dougpiston.com/files/RUU/bui...and-2.15.00.07.28-hboot-0.92.0000_PB31IMG.zip). The build installed fine through hboot and appeared to be successful, but on the post-installation reboot, the evil boot loop showed up again.

    I am going to try and flash a stock image using an RUU file (as summarized here How to get back to complete stock from s-off), but considering that the install appeared to be successful though PB31IMG.zip, my hopes are slim that this will work.

    My gut is telling me that this is a software problem, and I feel like there should be a way to wipe the whole drive and install working software, but none of my fixes seem to be working. Any suggestions are appreciated, an insurance claim is my last resort.

    Advertisement
    :
  2. FramCire

    FramCire Well-Known Member

    From HBoot you can not go into recovery? If so, you can factory wipe or restore a nandroid backup.
  3. iowabowtech

    iowabowtech root@android:/ #

    Regarding your final plan, you've already done that when you loaded the PB31IMG from Doug Piston's site. Since it went through, you are now unrooted with S-off. So you've pretty much tried every avenue.

    I'm curious how you knew the early reboots were due to a loose battery? Did jostling the battery cause the phone to start up back then? Do the contacts on your battery look clean? Do you have good spring retention on the brass "springs" that touch the battery contacts? And finally, if you have ANY way to try a different battery, I would absolutely rule that out if possible.

    Final thought is to either try booting with no SD card, a different SD card, or your current card after the files are moved off it and its been reformatted. Believe it or not, a corrupt SD file can cause major issues with phone function although its somewhat rare that it would be to this degree. I'd say this is the least likely fix but one that should be considered as a last ditch effort.
  4. CRADICAL

    CRADICAL Member

    I can't get into recovery. I've tried flashing several clockworkmod recoveries through hboot, but when I choose recovery, after flashing, the boot loop occurs. I found one cwm recovery version that would stay on the screen for like two seconds, then the boot loop resumed. Very frustrating.


    About the battery... I've been using a seidio 3900 mah extended life battery for some time. It didn't quite fit in the casing as well as the factory battery, and when it got a little loose, the phone would lose power and reboot. Sometimes i would ghetto rig it with a little piece of paper to hold it more firmly in place. It worked surprisingly well.

    I just tried to get it working by flashing a new build with RUU (no sd card involved). Like this How to get back to complete stock from s-off .... The ROM flashed successfully, but after it was done, and the phone rebooted, the evil boot loop was still there.

    I may try a few more recoveries since the phone seems to react differently to different versions of cwm, but other than that, I'm out of ideas.
  5. CRADICAL

    CRADICAL Member

    After flashing a few recoveries, this screen appears for about two seconds before the evil boot loop resumes. Newer versions of cwm don't even flash this screen. Anyone know if that error message in white text is normal?

    [​IMG]
  6. sdrawkcab25

    sdrawkcab25 Guides Guide

    Sounds like a hardware issue to me. Doing the ruu and the 2.2 pb31img.zip files wipes and reinstalls the os, and would(should) clear up any software related issues..

    Like iowa said, I'd try a new battery and sd card(or no sd card).
  7. CRADICAL

    CRADICAL Member

    Tried with a different battery and no sd card. Looks like it'll be an insurance claim. :(

    Any tips on dealing with big V?
  8. iowabowtech

    iowabowtech root@android:/ #

    It's not mounting internal memory or your internal memory got inadvertantly formatted. That's the deal with the dev/block errors.

    You can try the solution in post #7 here if you want, otherwise do the claim. Come to think of it though (edit), I don't think you'll be able to get shell without some form of boot so claim may be the only option:
    SOLVED: messed up partitions on internal storage - CyanogenMod Forum
    CRADICAL likes this.
  9. CRADICAL

    CRADICAL Member

    I'll give this a shot. Thanks.
Loading...

Share This Page