Evo 4G Reset Itself, Apps No Longer Open


Last Updated:

  1. marissacre

    marissacre Member

    I have a rooted Evo 4G running Warm Two Point Two for about a year. I connected my phone to the charger last night and went to bed. When I woke up and tried to check my email, the phone was on the welcome tutorial. I went through the tutorial and tried to check my email again. My Gmail account wasn't there and the Gmail app prompted me to set up my account.

    I tried rebooting twice. I noticed that upon reboot, my custom background is there but as soon as the reboot completes several apps give me an error message saying they stopped unexpectedly. After this mysterious reboot, my phone even had the old Android Market, complete with the old shopping bag icon and all. Upon opening it, I was prompted to upgrade to Google Play.

    I checked in the settings and it recognizes my SD card. However, several apps that are on my SD card are showing up on the phone with the droid icon and I get a message saying they're no longer installed on my phone.

    Can anyone tell me what happened?

    EDIT: I removed my SD card and reinserted it. This stopped the multiple app failures upon startup. However, many settings were still on the factory default (haptic feedback on, touch input instead of Swype, etc) that I had changed previously.

    Edit 2:I had to restart my phone after the app store froze while uninstalling something. My phone was again reset. Apps stored on my SD card were showing as no longer on my phone, apps immediately failed when opened, etc. Could my SD card be corrupt?

    Advertisement
  2. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Is your SD card partitioned?

    If so, Into terminal emulator Try typing:
    Su
    A2sd repair

    If that doesn't seem to help try
    Su
    A2sd reinstall

    Also can be done from recovery in the partition menu I believe
    Granite1 likes this.
  3. argedion

    argedion The TechnoFrog VIP Member

    Did you leave the phone on while it was charging? it is sounding like to me that you got an update. You should check your settings>about>software and post the build number.
    Rxpert83 likes this.
  4. marissacre

    marissacre Member

    I left my phone on while charging.

    Android version 2.2
    Build number myn's warm twopointwo (RLS5)
  5. marissacre

    marissacre Member

    I vaguely remember partitioning being a step when I rooted my phone. However, I have no idea how to perform the steps you suggested.
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    warm 2.2? man i have not been on that rom for such a long time. i'm amazed you are still on it.lol

    i really do not think that this is a sd card issue. are you still on warm 2.2? go to the settings>about phone>software info and tell us what you see there.
  7. argedion

    argedion The TechnoFrog VIP Member

    Do you have a windows computer?
    Also do you have a recent backup of your SDCARD?
    What is the method you used to move apps to your sd? Was it dta2sd that you flash in recovery and have a seperate partition for? or was it an Apps2SD that you download from the Play Store? It's very important if you can tell us which.
  8. MizzouBrent

    MizzouBrent Well-Known Member

    This is confusing. Even when something like A2SD doesn't stick on a reboot, you'll still have your Google account info saved since it's not stored in the EXT partition. Maybe a virus of some sort got on the phone? That's the only thing that would make any sense to me. In any event, with all the security updates that HTC has released since Warm came out, I would say it is time to get you on a new ROM anyway. MikG or Evo Classic Supermagic would be my top two choices.
    Rxpert83 likes this.
  9. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    I agree, get yourself onto an updated Rom.

    Also, there were a2sd issues with decks reloaded (which has been fixed now) where I would have to sign back into Google each time I rebooted the device, so im not throwing it out as a possibility. It's easy enough to check and fix.

Share This Page