Evo 4G to Boost Mobile Guide/Evo 3D


  1. eripey

    eripey Member

    I keep reading the phone when it boots back up and has active still at profile 1, I have tried to write to the phone about 6 times already, I get the same error and check what profile is active and still says profile 1.

    Edited to add
    Okay, I tested a phone call, texting and they both work. I tried the internet and I get an error 67. I am going to re-read the topic again to see if I missed something.
  2. eripey

    eripey Member

    I am using the shared secret and the aaa password from the qxdm info I queried from my incognito, I chose to enter the values as hex, is this wrong or correct?
  3. new optimus

    new optimus Well-Known Member

    ok your error 67 is your internet data access is incorrect. You have 2 options you can try, 1st go to menu/settings/system updates/ and try data profile update.

    if that does not work you will want to turn the evo off and turn on the incognito and make sure everything works, data and voice.
    Then go into QXDM and get the info, yes the values need to be entered into the evo using qpst service programing on the MIP tab profile 0 and profile 1 in hex form.

    Remember you need both the HA which is the same for all of us, and the AAA which is specific to that incognito and those for both profiles.
  4. eripey

    eripey Member

    Yes, I tried to do the updates and that didn't work. I will try again later this evening, and give another update.
  5. Estes0109

    Estes0109 Active Member

    Thank you, I tried it and it worked. But it knocked out my data, I kept getting error 67. I worked it on it for hours, I plugged in my incognito and copied everything down from the CDMA & QPST then re-plugged in my Evo and compared the info. I have NO IDEA what I did but after I changed some info to match the incognito, it still was giving me an error code 67. So I remembered what you said about taking out the battery, so I took it out..again! (fell asleep) woke up the next morning, put the battery back in and EVERYTHING WAS WORKING!!! :eek:
    (I DO NOT RECOMMENDED DOING WHAT I DID IT IS WHAT I TRIED, PLEASE TAKE OTHER EXPERIENCED PPL ADVICE ON THIS COMMUNITY BOARD)

    One thing I can tell you I changed is the incognito had "Lock" off and a lock code # so i made the evo say the same thing. Does that matter at all? Like I said I don't know if that did anything or not but do I need to change it back or will it cause any problems?

    "NAM" INFO: I also noticed that when I "read" the NAM info on the incognito, different information popped up. The same info but sometimes not all of the info which meant that when it was saved (as NAM 1 & 2) it could have saved an incomplete file (which it did) so when I read the Evo all the info wasn't there. I only had this problem with NAM2 (NAM1 was fine), so I kept reading the incognito til all I got all the info (which I didn't get all in one read so I wrote down what was filled in and kept reading til I wrote down all info filled in, then put in the info that was missing and saved the file. So I rewrote the Evo NAM2 file, then read it and made sure all the info was in.

    So again I don't know what worked and what really didn't make a difference but it's fixed now...

    Oh Yeah...
    "ACTIVE PROFILES"- On my Evo I used ##786# "Data Profile" It still said "Profile 1" but I noticed the info is the same as "Profile 0" so I didn't have to worry about it anymore because the information was right(I don't know why it saves like that)...FYI...for people that keep trying to change it. I DID change the "Profile" to 0 in my phone and edit the AAA & HA in my phone then "Committed Modifications".

    So this is everything I did. Let me know if I should change something back or not. And I do get random error code 107(I believe) but I haven't looked into it because at this point I'm just glad I can do the basics..lol. Also my mms comes in as a website link. Is there an easy fix for this? (Depending on what it is i may not try to fix it for a while...don't want to mess up a good thing...lol)

    SORRY FOR LONG POST... I HOPE THIS HELP SOME PPL :)
    ocnbrze likes this.
  6. eripey

    eripey Member

    new optimus, I finally got it to work!!!! Thanks for all the help and suggestions, there were a few different steps that I had to take, I will make not of it right now.

    I was using a incognito donor phone to a evo 4g. I used the evo 3d to zero out the esn and meid, used build 366 for qpst. On the directions to retreive the ha shared and aaa secret, I only requested for profile zero and that is where it went wrong, I went back just now to request for profile 0 and 1 on the incognito and ha shared were same for both, but the aaa secret for profile 0 was 32 and profile 1 was 12, I made the changes in the mip tab, write to the phone, ignored the write error, phone booted up and saw 3g right away.

    test phone call, text, mms and internet, all working! Hope this might help someone as well. Thanks androidforums community, you guys rock!

    edited to add:

    I forgot to test voicemail, so i called the phone, left a message and waited for some kind of message warning or something, never got anything. dialed up my voicemail and the message I left was there. Is there anything I need to do, to fix this issue, if it's an issue?
    ocnbrze likes this.
  7. Pokeemonn

    Pokeemonn Member

    Glad to see this thread still getting attention, since I have gotten my evo up and running on boost everything works except I personally can not send MMS messages, Every other thing works fine. I can receive MMS but not send, it's saying they are sent but the recipient never gets it. Anyone have this problem?
  8. ralphnome

    ralphnome Member

    Hi all. I'm a noob. I followed all the instructions using the Samsung Prevail as a donor phone, but I keep getting a code 16.

    I didn't downgrade my EVO 4G to 2.15.00.11.19, I kept it at 2.15.00.12.19. Could that be a reason?

    I have 3G on Evo and for about 5 minutes, I had talk and text and then it went away.

    I'm not sure what I did wrong. I don't have another Boost phone to switch accounts for a few minutes so I called Boost Mobile to reset, but they did and it still doesn't work. They said that it looks like I was using a non Boost phone on a Boost network and asked if that was the case.

    Any help would be greatly appreciated.

    Thanks.
  9. new optimus

    new optimus Well-Known Member

    16 is 2 phones being on the network at the same time, it basically says you cloned your phone.

    You should look for a boost esn on howard forums, then change the phone for 5-10 mins and then you will have your talk and text working again.

    However then you will probably get error 67 data failure, you can try to update data profile on the evo, sometimes it works.
    other wise you may just have to put the prevail back on the network and make sure everything is working then pull the nv item 1192 out and get the AAA KEYS for profile 0 and 1 then make sure the phone is off and remove the battery and then use QPST to put the AAA keys in the evo.

    one thing to note always remove the battery of the phone you do not have on the network, the evo with gingerbread does not really shut off when you power off, unless you have fast boot unchecked it just goes into a sleep mode.
    Mikestony likes this.
  10. ralphnome

    ralphnome Member

    Thanks for the reply.
    I guess the phones being in airplane mode is not enough then. I'll try to get an ESN from Howard Forums.
    Thanks again.
  11. joseph.g

    joseph.g Member

    i am trying to flash my evo to boost and downloaded all the files necessary.

    however, i am missing these 2:

    CLICK HERE FOR AUTOROOT W/2.15.00.11.19
    Download only if downgrading to 2.15.00.09.01

    i copied that from the instructions. the autoroot and downgrade is nowhere to be found. does anyone have these files?
  12. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    unfortunately the exploit used to root the evo 4g then has now been closed so this root method will not work. do you know what your hboot is? go to the bootloader screen. power off (make sure that fastboot is disabled, settings>apps>uncheck fastboot) then press and hold power+vol down. report back what you see on the screen.
  13. Pokeemonn

    Pokeemonn Member

    I can receive pics but I can't send them, anyone have any idea what this could be?
  14. turbonerd

    turbonerd Member

    I have the same issue :)
    My hboot is 6.16.1002, radio 2.15.00.0808 (from rEVOlutionary)
  15. saga13mx

    saga13mx Member

    That tutorial says "phone already activated to metro", does that mean the line that I already have on metro right? That would be my donor phone?
  16. mike5112

    mike5112 New Member

    I have an htc evo 3d that is on sprint and an active incognito with boost. After I go through the flash and the process, how do I keep the phone number from the sprint account? Should I port the number to the incognito before I cancel my sprint service and flash?
    Please Help!!!!!
  17. alexandroid5

    alexandroid5 Well-Known Member

    any metropcs android phone. it can be the one that you are currently using or it can be just any phone that is originally from metropcs
    atljatl likes this.
  18. Pokeemonn

    Pokeemonn Member


    Yes, when you activate the incognito on boost you will need to port over your current sprint number if you want to keep that number on your boost plan.
  19. saga13mx

    saga13mx Member

    ok i followed everything and when i dial *228 i get a message that says that the number is incorrect and to check the number, and if i dial any other number it says that my acc couldnt be validated.

    now in the qpst when i edited the two files (0 and 1943) i had to delete the files from the phone first and then drag the edited ones to the phone (when i tried overwrite it gave me an error)

    and also what are we supposed to do with the nam1 and nam2 files??
  20. turbonerd

    turbonerd Member

    Having some trouble getting my nvitems and HA/AAA codes. My donor phone is an ancient LG Remarq. NVITEM 466, 1192, and 1194 return access denied, like so:

    Skipping ahead, the second problem I expect to encounter is in what OP called "Round 4." Where do I find the password for my donor phone to enter in QXDM?

    If I should tire of beating my head against the wall, am I correct in assuming that without the HA/AAA set up properly, the Evo won't have 3G but voice, text, mms should work?

    Thanks in advance.
  21. turbonerd

    turbonerd Member

    Got half an answer at the Howard Forums. I should be able to read the NVITEMS if I put my phone in diagnostic mode.

    Now I just need to find where the code to enter diagnostic mode for an LG Remarq...
  22. new optimus

    new optimus Well-Known Member

    No mms without 3g just regular text messages
  23. turbonerd

    turbonerd Member

    nuts. I knew that...
  24. saga13mx

    saga13mx Member

    I just want to thank alexandroid5 for his help...me been a newbie flashing to another carrier, i follow the tutorial from the OP but there's a couple of things missing or not clear enough like at the very end you should update the PRL, but all in all I want to thanks also to the OP for this guide... Finally I flashed my little cousins phone and he is no stuck with one of those metro pcs phones ;)
    alexandroid5 likes this.
  25. ralphnome

    ralphnome Member

    It works now just like new optimus said.
    My next question is if I can root the Evo after it has been flashed to boost or should I have rooted it before I flashed the Evo to Boost?
Loading...

Share This Page