EVO cannot connect to 4G (settings grayed out)Support

Last Updated:

  1. Daypass

    Daypass New Member This Topic's Starter

    Oct 9, 2010
    Likes Received:
    I recently received a replacement EVO to replace one that got wet through the Best Buy insurance program thingy. Anyway it is a brand new EVO but it will not connect to 4G. My wife has an EVO as well and sitting side by side hers connects and mine will not. If you go to Wireless and Networks settings the setting titled 4G is grayed out and says turning on underneath but it never changes. You cannot tick the check box. The next setting is titled 4G settings and when you click it ALL the options are grayed out and none of the check boxes ca be ticked.
    Like I said I know we have 4G coverage as my wife's phone is getting it fine. Also if you go to About Phone in the settings and look at hardware information it lists 4G MAC address as unavailable. Any ideas or similar problems out there? Could I have turned something on or off that is stopping the 4G radio?

  2. Palmetto Fellow

    Palmetto Fellow Well-Known Member

    Sep 24, 2010
    Likes Received:
    Your 4g MAC address will say unavailable until 4g is turned on.
    Mine is like that. However, your inability to turn it on is worrisome. Have you tried using the included toggle switch on screen 3? It can take 20 seconds or so for 4g return on after enabling.
  3. whatsitsname

    whatsitsname Well-Known Member

    Jun 5, 2010
    Likes Received:
    I had the same problem. I had to do a factory reset and the 4g connected right away. Before that I was waiting for the grey out 4g for a few hours.

Share This Page