EVO defaults to speaker mode: defect or not?Support


Last Updated:

  1. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    Every time I make a call (and on most INcoming calls as well), my EVO automatically goes to speaker mode, forcing me to finagle with it just to turn off the speaker so I can use the handset. Is there a way to stop this--I've looked around but haven't found the answer yet--or is this a defect I will have to correct with a replacement phone? I've only had it 3 weeks, so I'm within the 30-day return window.
     

    Advertisement
  2. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    I remember seeing a setting somewhere but cannot find it. right now all I can find is

    open voicemail, menu, settings, uncheck speakerphone

    I thought mine did this once in voice calls and I can't remember if that is how I fixed it. pretty sure it isn't


    it may have just been doing it in voicemail. Is it possible that the headset jack is defective?

    I have tried a few things to replicate the issue on my phone and cannot
     
  3. drexappeal

    drexappeal Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    10,781
    Likes Received:
    3,118
    I'm almost positive there is a setting that can be toggled on or off (can't remember exactly where), but that setting allows the phone to automatically go into speaker mode, so I'd check all the different settings before returning it. I think it might be in the dock settings.

    If you've downloaded any apps that are connected to calls, I'd check those to see if they have any settings that force it into speaker mode as well.
     
  4. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    Headset appears to be fine, and my voicemail settings were already set to speakerphone off.
     
  5. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    Well, it's not in the dock settings, so that is moot.

    Other than PhoneFusion, I don't have any apps that are tied to phone settings.

    I appreciate the suggestions, but it seems I'm still stumped. FWIW, Sprint's tech support recommended I do this:

    1. Take to a Sprint corporate store to have them do a wire xfer software upgrade. They claim that OTA upgrade (I am on the latest software version) often leaves the phone with malfunctions.

    2. If #1 doesn't work, have the Sprint store exchange the phone outright.
     
  6. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464

    being that you are within the 30 days this sounds like a good option.


    have you tried to do a hard reset yourself?
     
  7. sonya1224

    sonya1224 New Member

    Joined:
    Jul 14, 2010
    Messages:
    4
    Likes Received:
    0
    I had the same problem last month. All calls would automatically be on speaker. I finally just did a battery pull and it's been fine ever since.
     
  8. dgrobe2112

    dgrobe2112 Well-Known Member Contributor

    Joined:
    Jan 11, 2010
    Messages:
    462
    Likes Received:
    76
    Mine has this issue now.
     
  9. flyjbaker

    flyjbaker Well-Known Member

    Joined:
    Oct 17, 2009
    Messages:
    1,192
    Likes Received:
    266
    So does mine.... It is definitely tied to the car dock in some way. I am rooted and have tried wiping everything and have installed multiple different ROMs(including a stock one) and it is still there. I restored a nand backup from months ago that definitely did not have this issue when I ran the backup....still has it. I have deleted the Car Dock app completely....no dice. So I have done all I can do........
     
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    Joined:
    May 13, 2010
    Messages:
    23,596
    Likes Received:
    14,435
    well not everything. you can always try and unroot it and see if it is happening in stock as well. if so you can then take it in to get fixed or replaced.
     
  11. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    It's happening in root or unrooted on my phone. It's ridiculous. 99.9% of all in coming calls always answer in speaker mode, while whenever I make an outgoing call, 95% pop right into speaker mode.

    The only choice I have, absent returning it (mine's 7 months old, though) is to disable entirely the speaker phone.
     
  12. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    This is really frickin' annoying. Every, and I mean EVERY damn phone call I receive answers in speaker phone. In fact, when I press the green "answer" icon on my phone to answer an incoming call, I put the phone to my ear to listen, only to have the speaker phone instantly kick in. I then have to pull the phone away, press the speaker phone icon to disable it, then continue the call.

    God! I HATE this!
     
  13. terricripp

    terricripp New Member

    Joined:
    Jun 13, 2011
    Messages:
    1
    Likes Received:
    0
    It happened to my husbands phone, Something was in the earphone plug like dirt we cleaned it out and then it worked fine. You might want to make sure it is not dirty where the earphones go in.
     
  14. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    Nope, that wasn't the problem.
     
  15. RogueStallion

    RogueStallion New Member

    Joined:
    Jun 28, 2011
    Messages:
    1
    Likes Received:
    0
    Mine was doing the same thing....tried removing the battery and left it out for a minute or two...that worked for now....
     
  16. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    That only worked for a few minutes, then it reverted back to speaker phone auto mode. Worse, I've answered calls that began in nonspeaker mode--I'd say hello using the nonspeaker mode, then within a half second or second, it would switch on its own to speaker phone. Damn annoying!
     
  17. iamxavier

    iamxavier New Member

    Joined:
    Jun 29, 2011
    Messages:
    2
    Likes Received:
    0
    My was doing the same thing. I changed from desk to docking mode. I did not relaunch. Fixed for now.
     
  18. iamxavier

    iamxavier New Member

    Joined:
    Jun 29, 2011
    Messages:
    2
    Likes Received:
    0
    Yep, go from desk mode to docking mode. Do no auto relaunch. Should work fine. No more auto speaker w/each call.
     
  19. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    I've always been in docking mode. It hasn't made a difference.
     
  20. marlo231

    marlo231 New Member

    Joined:
    Jul 9, 2011
    Messages:
    1
    Likes Received:
    0
    Pulling the battery works.
     
  21. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    No it doesn't. I've done this several times. No effect.
     
  22. MagrathMandD

    MagrathMandD New Member

    Joined:
    Jul 16, 2011
    Messages:
    2
    Likes Received:
    0
    My husband's phone just started doing this today. Was this ever resolved for you???
     
  23. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    No.
     
  24. dswatson83

    dswatson83 Member

    Joined:
    Apr 8, 2010
    Messages:
    24
    Likes Received:
    0
    Same problem. Started when I was stock and has continued when I rooted. I cannot figure it out and it is extremely annoying
     
  25. Lord Vader

    Lord Vader Well-Known Member This Topic's Starter

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    I'll say! The damn problem is constant.
     

Share This Page

Loading...