Evo not getting incoming CallsSupport


Last Updated:

  1. NickOrsak

    NickOrsak Member This Topic's Starter

    Joined:
    Jul 1, 2010
    Messages:
    7
    Likes Received:
    0
    So I have had my evo for a little over a month now and I love it, only problem is it wont accept any incoming calls anymore. At first it would accept some but now it I don't get any. I updated to froyo today hoping it might fix something but no luck. :( I took it to sprint a few days ago he updated it and said see if it works now if it doesn't take it to the repair shop and if they cant fix it then they will give you a new one but I don't know how you'll be able to get a new one because we don't have any. I would rather not get a new one because I got the invisible shield put on my phone and I would rather not have to waste money getting a new one/putting it on. Has anyone else heard of evos doing this or know of anything that could make this happen? Everything else works fine on the phone.

    Thanks in advance.
     

    Advertisement
  2. BetterMost

    BetterMost Banned

    Joined:
    Apr 25, 2010
    Messages:
    1,066
    Likes Received:
    119
    Did they not try calling the phone from the Sprint store? Take it to a service center it has to be fixed or replaced. I lost FOUR Zagg protectors on defective Evos it sux but ya gotta get it fixed if its not ringing. Do you have adequate signal when you notice it no ringing?
     
  3. vacoray

    vacoray Active Member

    Joined:
    Dec 12, 2009
    Messages:
    38
    Likes Received:
    0
    Are your calls going to voice mail? Somehow on my wife's phone when i would call her it would go directly to voice mail. There is a setting in contact info to turn voicemail on or off and somehow i got changed to on.
     
  4. paradox183

    paradox183 Well-Known Member

    Joined:
    May 31, 2010
    Messages:
    104
    Likes Received:
    12
    My phone stopped receiving incoming calls after the Froyo update, even after a hard reset. When I tried calling the EVO, I would hear lots of rings and then get my voicemail, but the EVO never did anything. After updating my profile on the phone it appears to be fixed.
     
  5. NickOrsak

    NickOrsak Member This Topic's Starter

    Joined:
    Jul 1, 2010
    Messages:
    7
    Likes Received:
    0
    No the dude just told me it should work and told me to go to the repair center if not... pretty lame I thought, and yes my calls are going straight to voicemail thank you for that info I'm going to check that right now. Where did you find that setting?
     
  6. EarlyMon

    EarlyMon The PearlyMon Moderator

    Joined:
    Jun 10, 2010
    Messages:
    57,614
    Likes Received:
    70,271
    Have you tried installing the Network by Philipp Mangelow app from the Market ?

    This gives access to the now-removed radio configuration parameters via the keypad.

    In that - where it may say CDMA auto (PRL) - change that to GSM auto (PRL), exit the app, then re-launch and change back to CDMA auto (PRL).

    It's possible that your radio lost its mind and is fixable.

    If by some chance this works - then your very next step would be to go to Settings -> System updates -> Update PRL and also to update your profile.
     

Share This Page

Loading...