1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Evo V 4G rebooting after failed ROM flash


  1. Xa27

    Xa27 Member

    I recently installed rooted and flashed my Evo V 4G.

    Everything seemed to be working well and I managed to flash the ODEX ROM mentioned in the guide, making a recovery and everything. After I did that, I attempted to flash the CM10.1 Android 4.2.2 ROM for Sprint Evo 3D (to my understanding this should work with the Virgin Mobile version as well?). After flashing, the CyanogenMod logo popped up and a screen stating that it was initialing and updating all the apps came up. Once that finished, however, the phone began to constantly reboot itself without me ever actually getting to use the ROM itself. It simply displays the HTC logo for a bit and then the CyanogenMod logo before rebooting again.

    Since I still have access to TWRP (removing the battery, then pushing down the volume button plus the power button), I attempted to load the backup that I had saved prior. However, after a long time (1066 seconds), it loaded only to suffer the same rebooting fate (although it no longer says Cyanogen Mod since the backup was saved with the ODEX ROM). Is there any way I can simply access my phone normally again (I don't care if I have to return it to stock conditions in order to do so). Thanks.

    Advertisement
  2. OverByter

    OverByter Resident Slide Rule Guru

    Are you s - offed, what hboot are you on, did you try wiping everything but the sd card before flashing?
    OB
  3. remanifest

    remanifest Well-Known Member

    You must be S-OFF and using a different HBOOT than the one you've got to flash that ROM. Also, you either have to have taken the OTA update or have performed the "fix everything" steps.

    I'd also recommend flashing 4ext recovery instead of TWRP.

    Seems a few people's issues would have been resolved by following my guide today... just sayin :p
    Xa27 likes this.
  4. Xa27

    Xa27 Member

    Yes, I did wipe everything and made a recovery before originally flashing ODEX (that went without a hitch). I'm on HBOOT 1.57.0000, S-BOOT is on, and I followed this guide:

    http://androidforums.com/evo-v-4g-a...ing-evo-v-4g-roms-kernels-using-fastboot.html

    Would you guys hapen to know why I have the same rebooting problem with the ODEX ROM then? I've flashed it once already so I know it's capable of working. Also, I will use 4ext in the future, but is there any way to recover my phone for now?
  5. remanifest

    remanifest Well-Known Member

    My recommendation is to pull the battery out of the phone, then replace it.

    Hold the volume down button, and press the power button. Your phone will reboot into the HBOOT.

    Once in the HBOOT, select bootloader, then recovery. Wipe your phone and restore your backup. If that doesn't work, flash 4ext using fastboot (I will provide the file if you need it -- I haven't uploaded just that file yet, it's in a package).
    Xa27 likes this.
  6. Xa27

    Xa27 Member

    I think I tried that already but I will do it again. Also, I'm not sure if this is of any importance, but when I enter HBOOT, I see a bunch of lines that say "no image". In addition, can you explain how you would flash 4ext? I'm new to all this stuff as you can probably tell. Thanks again!
  7. remanifest

    remanifest Well-Known Member

    Those "no image" lines strike me as odd. Any chance you can take a picture of that screen and upload it to imgur or another image host? OH!! Any chance you have a PG86IMG.zip (or another similarly-named zip file) on the root of your SD card? If so, that has to be deleted.

    At this point I'm thinking that running the RUU would be a good option.

    To flash 4ext, download this file and place it in the same folder that you will be running fastboot from. After that, run the following command:
    [HIGH]fastboot flash recovery recovery.img[/HIGH]
    Xa27 likes this.
  8. Xa27

    Xa27 Member

    What menu should the phone be on to run the command?
  9. remanifest

    remanifest Well-Known Member

    You should be in the bootloader (HBOOT) before running the command.

    Also note after flashing 4ext you cannot restore your backup made with TWRP, so you'll be starting from scratch with a ROM.
    Xa27 likes this.
  10. Xa27

    Xa27 Member

    Should the recovey file be placed in the sdk-tools folder on my desktop? Also, after flashing 4ext, should I just try to flash the ODEX ROM? Thank you so much for all the help.
  11. Xa27

    Xa27 Member

    I ran the code and it said <waiting for device>. Do you know what the problem is?
  12. remanifest

    remanifest Well-Known Member

    Yes sir, put it in your sdk-tools folder and it should flash without issue from the bootloader. I would try the ODEX rom first, since that's the one you've got. If it doesn't work, there's a couple other steps that will most likely fix your issue.

    Once you have 4ext flashed, you can select "bootloader" from your HBOOT, then recovery.

    Once inside 4ext, select wipe | format. The second-to-last option is format all partitions (except sdcard). Tap on this and confirm your selection.

    Once that's done, flash the ODEX ROM.
    Xa27 likes this.
  13. remanifest

    remanifest Well-Known Member

    You're in the HBOOT? Sounds like you have a driver problem -- uninstall HTC Sync if it's installed, then install this driver package.

    Once you've got that installed (may require a reboot), issue "fastboot devices" when it's in HBOOT, and you should get a return of a serial number.
    Xa27 likes this.
  14. Xa27

    Xa27 Member

    I tried to flash the 4ext recovery file and got this:

    C:\sdk-tools>fastboot flash recovery recovery.img
    sending 'recovery' (5132 KB)... OKAY [ 1.540s]
    writing 'recovery'... OKAY [ 1.883s]
    finished. total time: 3.424s

    However, once I select recovery, I still see the TWRP recovery. Did I not flash it correctly?
  15. remanifest

    remanifest Well-Known Member

    Seems like the recovery image you flashed wasn't 4ext. Delete the one in that folder and replace it with the one linked above. There may be a slight difference in size because I'm on Linux, but for me it's a 6914 KB file.
    Xa27 likes this.
  16. Xa27

    Xa27 Member

    Oh wow yeah I had an extra folder similarly named no my desktop and put the new recovery file there instead :p 4ext is working now, and I'm in the process of flashing ODEX. Crossing my fingers!
  17. remanifest

    remanifest Well-Known Member

    Awesome, as long as you did a full wipe you should be good to go after that.

    If you still want CM10.1 after this, I've got a guide that can help you get there with S-OFF.
    Xa27 likes this.
  18. Xa27

    Xa27 Member

    It finished flashing but it still goes through the same constant rebooting process as before :( Maybe the ROM is bad?
  19. remanifest

    remanifest Well-Known Member

    That's odd.

    Just to confirm, did you do the full wipe from 4ext?

    Only thing I can think to do is to relock your bootloader and run the RUU.

    Go into your bootloader again, and do this:
    [HIGH]fastboot oem lock[/HIGH]Download this RUU, and run it from your computer.
    Xa27 likes this.
  20. Xa27

    Xa27 Member

    Yes I did do the full wipe in 4ext. Right now I'm running the program. Hopefully this works or I don't know what else to do.
  21. remanifest

    remanifest Well-Known Member

    Cool, just keep me posted and we'll get this sorted out.
  22. Xa27

    Xa27 Member

    It didn't work. At the end it said:

    ERROR{140}:BOOTLOADER VERSION ERROR

    Also, when it detected my ROM and showed the one it was replacing, it showed that I had 1.14 and was replacing it with 1.13 (not sure if going backwards is a problem). The program suggests that I get the proper RUU (also, the phone in the RUU does not seem to be an Evo V 4G, not sure if that matters or not).
  23. remanifest

    remanifest Well-Known Member

    So you are S-ON, correct? I think performing S-OFF and flashing a new bootloader may work for you.
    Xa27 likes this.
  24. Xa27

    Xa27 Member

    Yeah I am S-ON. Another thing, I noticed that the RUU you linked says Radio-1.06 while the bootloader menu on the phone says 1.09. Also, running that code locked the recovery option, and I can't access it anymore.
  25. remanifest

    remanifest Well-Known Member

    All you've got to do is unlock the bootloader again.

    fastboot flash unlocktoken Unlock_code.bin
    Xa27 likes this.

Share This Page