Excessive lag with LauncherPro Plus?Support


Last Updated:

  1. EKG

    EKG Well-Known Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    667
    Likes Received:
    103
    Has anyone had super lag with LauncherPro Plus? Every time my phone will flip into landscape or back into portrait, the phone is unusable for about 2 minutes. It is just frozen up. It often just freezes up and nothing happens. Is there a way to fix this? When it works right, I like it a lot more than the stock interface.
     

    Advertisement
  2. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784
    When you're running LauncherPro (or any home-replacement app), unless you cleaned house before installing, you still have widgets running in the background. You should use Home Switcher or a similar app to switch back to Blur and remove all the widgets from your screens, then maybe clear the cache again, reboot and use LP again.

    Also, calibrating your compass should help with the lag. (Settings... Location & security... Calibrate compass)

    Thirdly, you can disable landscape mode in LPP to prevent the problem. (Behavior... uncheck "auto rotation"). Also under advanced... memory usage... memory preset... set to "high".
     
  3. mahers

    mahers Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    1,320
    Likes Received:
    164
    Is it your homepage that is flipping between landscape and portrait? If so, and you DON'T want that (as most folks keep their homescreens in portraint, but it will turn to landscape for apps/games/etc), then do the following:

    In LPP's Preferences menu, hit Behavior Settings, and uncheck Enable Auto-rotation
    In the Phone's Settings menu, Display, and check Auto-Rotate screen

    But, if you want your homescreens to rotate along with everything else, then make sure both options are checked.

    You may also want to recalibrate your stock compass setting under the Location and Security in the phone's setting menu. It's made the auto rotate much smoother for many folks here.


    EDIT: Doh! Colchiro types faster than me!
     
  4. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784
    I can read without moving my lips too. :D
     
  5. EKG

    EKG Well-Known Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    667
    Likes Received:
    103
    Thanks for the tips guys, turning off the rotating did help a bit. Unfortunately, it still randomly freezes up when sliding through home screens and LauncherPro is force closing quite a bit :/
     
  6. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784
    Install Watchdog and see what's using a lot of cpu or memory. It told me my email was using a lot of cpu and I rebooted and haven't seen it since.

    O/W you could note what apps you have on your screens (and where) and remove them and see if that fixes the problem, then add them one at a time until the problem comes back. A better solution, if you're rooted, would be to back up your current config to a nandroid with CW Recovery and Rom Manager while you play. Then if you hose something you have a backup.

    OTOH, if you're getting FC's, I'd switch back to Blur with Home Switcher, uninstall LP, clear the cache partition and dalvik cache (if you have recovery installed), reinstall LP. You might even need to do a system reset, but that means having to reinstall/setup everything again so you'd want to try everything else first.

    FWIW, these are my LPP advanced memory settings:
    Memory preset: high
    Use homescreen caches: checked
    Cache type: normal
    Build, clear and Prevent FC's are all unchecked.
     

Share This Page

Loading...