Exchange and pin after 2.2 update?Support


Last Updated: 2012-03-15 18:43:36
  1. ylomnstr

    ylomnstr Member

    So I just installed Froyo on my X, but now I have this annoying issue with my exchange account and having to enter a pin? I can't seem to disable it. If i go to security, there's an option under security called Change screen lock. I go to that, but the option for None and Pattern are both grayed out saying Disabled by remote phone administrator. what is that all about and how do I get rid of this? It's annoying and I don't need it.

    Advertisement
  2. redifrogger

    redifrogger Well-Known Member

    I'm in the same predicament ylomnstr. Mine is disabled too - I don't want to have to enter a pin every time I turn the display on. Ridiculous.
  3. ylomnstr

    ylomnstr Member

    Well I think I fixed it. I removed the corporate sync account. Then I went back to the security settings and I was able to disable it. I then re-added my corp account, and now I seem to be OK. PHEW!
    nancer and redifrogger like this.
  4. redifrogger

    redifrogger Well-Known Member

    Yes - that fixed it for me too. Thanks a ton!!
  5. rock.the.casbah

    rock.the.casbah New Member

    Ok, I had this same exact problem, and did the same thing: removed my corporate sync email and re-added it and it did the trick too. The screen lock settings were not greyed out and I could remove the lock.

    Must just be a minor glitch with upgrading over existing settings. Thank you for saving me a huge headache! :)
  6. psipher

    psipher Active Member

    yes that did the trick.

    However I'm disappointed that the "Corporate Directory" app is now gone. I know that from the email client you can search the Exchange GAL to find an email address, but I haven't found a way to find someone's phone number that isn't already in my Contacts.
  7. andross77

    andross77 Well-Known Member

    doesn't work for me. i deleted both accounts and the greyed out option of "None" turned white and i clicked it. so it looked like it worked. and it said it did in the settings. added the 2 corp accounts back (1 for work and 1 for university) and when i did my school one, it forced me to do a pin again.

    so i think the pin can be forced security by any school or business. just depends where you work/go to class. that's my take anyways.
  8. redifrogger

    redifrogger Well-Known Member

    oh yes - definitely can be set by the exchange admin. This thread was to help those where the PIN wasn't being forced by the admin.
  9. skyysteve

    skyysteve New Member

    Can you please post instructions that i can provide to my IT dept to have them remove the required PIN. Right now, they don't understand why it is happinging. thx
  10. redifrogger

    redifrogger Well-Known Member

    If your IT isn't requiring a PIN (sounds like your case; mine too) then the exchange admin doesn't do anything, you do. Remove your exchange acct on your DX and then the setting in Security will be enabled, allowing you to 'uncheck' the option of whether to use a PIN when unlocking the phone. So uncheck the option and then re-add the exchange acct, and presto. Problem solved.

    But if your IT is forcing a PIN upon unlocking phone, then I can't help clarify where this option is on the server. I just know it's there somewhere. I'll ask my admin if he can help clarify where it is.
  11. cheech721

    cheech721 New Member

    I get my work email through the exchange - we set up a policy to not have to put the pin in every time, but it keeps forcing us to. "None" and "Pattern" are both grayed out. I have tried a few times to remove the account, remove the pin then re add the account, but it's not working. we have other people that have droids that don't require the PIN that use the same policy... any suggestions?
  12. SamM330

    SamM330 New Member

    I have a Droid 2...Use 1and 1 for my exchange..an i am the Administrator.

    Phone security lock requires me to enter password each time I want to use my phone...to date i have:
    Called motorola..they said to remove corp acct...set security to none..reinstall corp acct...didnt work.

    Called verison...did master reset reloaded corp acct..didnt work.

    Hard booted phone reinstalled corp acct...didnt work.

    Called 1 and 1 and asked how to disable mobil devise password security...said Cant be done by user...maybe they could do it for me...and would email me results...no response.

    Has anyone figured out how to disable security passwood on droid 2..using 1 and 1 exchange?

    I am a week and a half into 30 day trial...like phone..but this is making it to goofy to keep.
    thx
    sam
  13. ekyle

    ekyle Well-Known Member

    there may be a policy on the network set up by the IT department that requires you to have a key
  14. aghavami

    aghavami New Member

    Hi,

    I own a Nexus-One with Android Version 2.1.1 and build number FRG83. I have the same problem as other here. So I removed my corporate account, rebooted my phone but it still prompts me for entering PIN.

    When I go to "Change Screen lock" , "None" option for "set screen unlock security" is disabled with a message underneath "Disabled by remote phone administrator". This is a personal phone and not a corporate phone.

    Any suggestions? thanks in advance
  15. ttbit

    ttbit New Member

    Removing and re-adding corp worked for me. Thank you.
  16. Mjo

    Mjo New Member

    I am the Exchange Administrator for a company that just rolled out 30 Droids- half are Droid X (mix of 2.1 and 2.2) and half are Droid 2 (all 2.2).

    ALL the Droid 2 phones require the pin lock when connected to the Corporate Exchange account. Yet I have created and applied an Active Sync policy that does NOT require the pin lock or password and applied it to all mailboxes.

    Applying the policy to the mailboxes of users with Droid X phones running 2.2 immediately enabled them to disable their pin locks. Problem solved. Applying the policy to mailboxes of Droid 2 users (also 2.2) did nothing. Nothing at all. Sure, I can disable pin lock if I remove the Corporate account, but if I re-add it, I am forced into the pin once again and the settings are again greyed out. If connected to the Corporate account, pin lock is enforced and control is greyed out on the phone. I have tried factory reset after the policy change and I have tried deleting the mobile partnership within Exchange. No luck.

    The biggest problem for us is that our email, despite being set to push, only seems to sync when the phones are not in a pin locked state. Therefore, we only get email notifications when the phones are not time locked out. This is not acceptable in an environment where people are on call and phones automatically lock after 15 minutes.

    I am within half a heartbeat of returning all my Droid 2s for Droid Xs at this point, and crossing my fingers that the next update doesn't break the Droid Xs I have. Exchange needs to work in every update or I need to find a different phone for my users.
  17. JohnCL

    JohnCL Active Member

    Exchange admin here too, and this is the main reason I returned my Droid 2 and got the X. You can mess with it all day and it will never work correctly on the D2. I created fresh policies like you did to no avail. The DX works just fine and I am running 2.2 and do not have to enter a PIN. I have Epic's, DX's, and Intercepts online with Exchange working fine. The only holdout was that blasted D2!

    I think that I read somewhere on the Moto forums that this is a known bug with the D2 and there are plenty of unhappy Exchange & D2 users. They need to work this out with a patch or something.
    Mjo likes this.
  18. gkeane

    gkeane New Member

    I'm the exchange admin and just saw this issue on a users D2, I believe a patch was just released that fixes this issue, but not sure on the version (2.3.20??). Disabling corporate sync, disabling pin, then re-enabling corporate sync finally fixed the issue.

    greg
  19. roadhunter

    roadhunter Member

    Try removing the battery after you remove the account, then try again to disable the PIN. A friend of mine had to use this method.
  20. redifrogger

    redifrogger Well-Known Member

    And some droid 2 people are having no luck whatsover. Hope that's not the luck with the newer ROMs.
  21. Sluggoman

    Sluggoman New Member

    So I've finally been able to upgrade to 2.2 - good news - my phone (galaxy S) has quit shutting itself off at random times - bad news - I have the same issue with the PIN now, so I deleted my corporate account, but cannot recreate it.

    When I go to add a new corporate account, it will ONLY add an exchange account - which our admins have set up so it can't be accessed from outside of our network without using IMAP/POP. So I can create a mail account, but I can't create a corporate account - which means I can get my mail, But I have lost all my outlook contacts on my phone.

    Anyone know a workaround? on 2.1 when I created the corporate account I don't remember having this problem at all. Syncing contacts with google is not free...
  22. redifrogger

    redifrogger Well-Known Member

    sluggoman - I am so confused by your post. My exchange account is the corporate account, giving me access to all my outlook contacts, calendar, and email.
  23. Dewey

    Dewey Member

    So I had the same problem too. Then it went away by itself - after about a month. My IT guy said he didn't do anything or change anything. Now my exchange server is telling me my password is going to expire. So I changed my password. I had to update the password on the corp exch account on my Droid2 (2.2) and guess what? The PIN push is back. WTF? I had no PIN for at least 3 months. WTF?
  24. Euph0rik9

    Euph0rik9 New Member

    FIXED IT! (CM7)

    For those who've tried all the above and still have disabled "None" and "Pattern" Screen Unlock Settings...

    Settings > Location & security > Select Device Administrators > remove Email.

    I'm a Exchange Admin and originally had an EAS policy to require a PIN. However, after wanting to use gesture-based login I couldn't get around the PIN screen, so I switched to a non-PIN EAS policy, but even after removing the Corporate account, clearing Email app cache and rebooting, I still had to enter a PIN and the "None" and "Pattern" were disabled. Removing the Email admin rights finally enabled the use of gestures.

Share This Page