Exchange Calendar Sync Constantly ResynchingSupport


Last Updated:

  1. gauldin

    gauldin New Member This Topic's Starter

    Joined:
    Sep 10, 2010
    Messages:
    2
    Likes Received:
    0
    I've had my Incredible for about 3 months now, and have always had crappy battery life - roughly 12 hours avg, 18 hours max. I'd just chalked it up to smart phones being battery hogs, but recently it got much worse - 3-4 hours and the phone would sometimes get so hot I couldn't keep it in my pocket. Verizon gave me a new battery, but no difference.

    I started checking the forums, and learned a few things about apps that won't let the phone sleep. I checked the Battery page, and sure enough, my up time and my awake time were virtually identical (even though the phone *appears* to go to sleep. Started checking various possible sources, and as I was going through my Sync settings, I discovered that my Exchange Calendar was constantly synching. Literally every 1-2 seconds, the sync icon would pop up next to Exchange Calendar.

    So first, I simply turned off Synch Calendar for Exchange. That did the trick - my awake time dropped to a small fraction of the total up time. However, it sucked that I wasn't able to see my calendar on my phone (or at least any new/changed entries). So then I changed the update schedule from "As Items Arrive" to 15 minutes, and then reactivated Synch Calendar. That also seems to have done it. Exchange Calendar only syncs once every 15 minutes instead of hundreds of times per hour.

    I know lots of people have been having battery life issues, and I just wanted to share this in case it helps someone else.
     

    Advertisement

Share This Page

Loading...