Exchange doesn't like changing between Wifi and 3G


Last Updated:

  1. etherial

    etherial Member This Topic's Starter

    Joined:
    Apr 23, 2010
    Messages:
    23
    Likes Received:
    4
    Hi all, I've had my HTC Desire since last Thursday and this issue has driven me nuts. I even tried a factory reset but that didn't help.:mad:


    It seems that if I am on WiFi OR 3G my phone will work fine and will sync with the exchange server no problem. But if I switch from one to the other, it won't. Ie I am at home in the morning, works on WiFi, I leave for the office then it stops. I have to reset the phone by turning it off and back on again to get it to start working again. No changes in settings, just a reset.


    Ive tried all matter of things, re WiFi off, 3G on, leaving both on, changing the order I switch them on or off etc. Setting it to push email, manual check etc. The only thing that makes it work is a reset.


    Anyone else having an issue like this? Found any solutions or even other people having a similar issue? :confused:
     

    Advertisement
  2. Vertigo1

    Vertigo1 Well-Known Member

    Joined:
    Apr 20, 2010
    Messages:
    118
    Likes Received:
    9
    Not that it helps you solve your issue but, for the record, mine seems to work fine on either 3G or WiFI and survives a switch between the two. I have push enabled and, 95% of the time, it pushes new emails through literally seconds after they arrive at the server. Once in a while it'll take 10-15 mins to get the email but it's not a big problem. One thing I don't know is whether these "delayed" emails correspond to a switch of connectivity as, if so, perhaps it takes a while to re-establish the connection to the Exchange server?
     
  3. etherial

    etherial Member This Topic's Starter

    Joined:
    Apr 23, 2010
    Messages:
    23
    Likes Received:
    4
    No-one else having this problem?? I keep doing net searches and aren't finding any clues. :-(
     
  4. dunbad

    dunbad Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    117
    Likes Received:
    11
    I suspect its not just exchange, but a total internet connectivity issue. Mines the same. There are many posts on this. Somehow connection gets lost occasionally. Switching to aeroplane mode and then back usually fixes it. If not remove the battery and it will work.

    At the moment I'm.putting the sale of my iPhone on hold!
     
  5. etherial

    etherial Member This Topic's Starter

    Joined:
    Apr 23, 2010
    Messages:
    23
    Likes Received:
    4
    Thanks for the reply, but no all my other things like internet, gmail etc all work fine. I can reproduce the problem every time. Wifi On, email works fine. Send one to myself appears straight away. Turn off wifi, system connects itself to 3G. Emails won't send. Gmail/internet/FB all pick up and work perfect. I can then switch Wifi back on and it will all be fine again, or I can reboot phone and it will start to work on 3G. Same going back the other way.
     
  6. rasobey

    rasobey Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    96
    Likes Received:
    6
    Just tried this - emails continue to be sent even after I toggled wifi off and the Desire connected to 3G.

    Sorry :(
     
  7. biker74

    biker74 Well-Known Member Contributor

    Joined:
    Apr 29, 2010
    Messages:
    209
    Likes Received:
    29
    Your lucky,I cant seem to get 3G ever, get G, whatever that is, and something called hpsa I think.
     
  8. etherial

    etherial Member This Topic's Starter

    Joined:
    Apr 23, 2010
    Messages:
    23
    Likes Received:
    4
    HSDPA is a good thing mate, it is 3G, in fact really good 3G!
     
  9. Vertigo1

    Vertigo1 Well-Known Member

    Joined:
    Apr 20, 2010
    Messages:
    118
    Likes Received:
    9
    Just had a bit of a hiccup with my Exchange Activesync - all but about five emails disappeared from my inbox for some reason and they weren't even the latest five but just a few random ones from the past few days.

    Had to remove and re-add the account to cure it, which was a bit annoying. Will keep an eye on it and see if it happens again
     
  10. asis108

    asis108 New Member

    Joined:
    May 3, 2010
    Messages:
    1
    Likes Received:
    0
    Is yahoo compatible with MS Exchange Active Sync
     
  11. etherial

    etherial Member This Topic's Starter

    Joined:
    Apr 23, 2010
    Messages:
    23
    Likes Received:
    4
    I've been in contact with HTC about this issue, but they seem to have no idea! Here are their responses, any help translating them would be good! They are not being much help!!!!

    1st May
    Thank you for contacting HTC.

    We understand the urgency of your concern regarding your connection to My Exchange Server. Please be informed that we are currently working to resolve it and once we have the accurate resolution for your concern, we will be contacting you via email.

    14th May
    We are dedicated to providing you with the best quality service and promptly responding to all your questions and concerns. I apologize for the inconvenience you are experiencing with the HTC Desire. Please follow the steps below.

    1. Copy/transfer Encrypted Certificates (ex. certnew.cer) from the PC to memory card.
    2. Insert memory card to the phone
    3. Press MENU on the Home screen, then tap Settings > Security > Install from SD card.
    4. Choose certificate to install (exporting the certificate in the .p12 format)


    I then asked where do I get such a certificate!!!

    15th May
    We are dedicated to providing you with the best quality service and promptly responding to all your questions and concerns on the HTC Desire. I apologize for the inconvenience. The process is still into the testing stage and we still don’t have any update on this. We will be advising you as soon as there is an update available. We do not recommend any specific 3rd party software for this particular feature but you can freely use search engines like google.com to search the web for Encrypted Certificates.
     
  12. stepheng

    stepheng New Member

    Joined:
    May 26, 2010
    Messages:
    1
    Likes Received:
    0
    I installed Touchdown Demo (free) and can now send emails via the HTC Desire email programme. So far so good.
     
  13. lobug

    lobug Banned

    Joined:
    Jan 8, 2010
    Messages:
    137
    Likes Received:
    13
    I was having the same problem as the OP and did the following and now it seems to be working fine.

    Open: wifi settings -> mobile network settings -> Network operators -> Select Automatic.

    I also changed: wifi settings -> mobile network settings -> network mode -> GSM only.

    I'm not sure if it was either of these that did the trick but it couldn't hurt to try.
     
  14. sirlylos

    sirlylos Member

    Joined:
    May 19, 2010
    Messages:
    12
    Likes Received:
    0
    I was just about to put a post up about this. I think this is my only major frustration with the Desire.

    I noticed this again this morning, when I'm in the house I connect seamlesly to the wifi and everything's peachy. However, when I head to work and begin to check my emails I've got no kind of data connection. If I power off and back on again I get the 'H', 'G' or '3G' connection fine.

    I've tried the suggested method of changing to GSM only which I'll test but I think this then means that you can't connect to 3G? Unable to test at the moment because I'm in the office and connected to wifi but I'll check later and get back.

    Thanks,

    Lylos
     
  15. masherthemash

    masherthemash Active Member

    Joined:
    Apr 29, 2010
    Messages:
    32
    Likes Received:
    3
    Exactly the same problem with mine and really starting to annoy me. Tried airplane mode and turning 3g off and on. As quoted the only resolution is to turn off and on.

    Not sure if the network provider is at fault but I'm on orange.

    Anyone else experiencing this??
     

Share This Page

Loading...