Exchange E-Mail Eating Up BatterySupport

Last Updated:

  1. fatalysis

    fatalysis Active Member

    After setting up my Exchange e-mail, I've noticed that I'm going through my battery much quicker (dropped from full charge to 90% in less than 30 mins) and the battery itself is getting hot. Is anyone experiencing the same issue?

  2. Jersey Tom

    Jersey Tom Well-Known Member

    How much does "Exchange Services" register in the Battery usage stats?

    I set my Exchange email up yesterday... and in 9h 49m of usage it only amounted to 5% - beaten out by Screen (37), Android OS (36), Phone idle (6), and Cell standby (5)
  3. dren

    dren Well-Known Member

    I'm not. Exchange Services on my phone is at 2% usage.
  4. john30308

    john30308 Well-Known Member

    It might be just syncing your mail, contacts and calendar the first time. I'm using Exchange and it's all good.
  5. fatalysis

    fatalysis Active Member

    Exchange Services is the 2nd most being utilized:

    Screen - 44%
    Exchange Services 37 %
    Android OS 8%
    All other: 3% or under.
  6. gobluejd

    gobluejd GOBLUE! VIP Member

    Like the poster above, it may be just the first sync if you have allot to sync at first. Mine is at 2% as well.
  7. jamosjamos

    jamosjamos New Member

    I have had Exchange setup for 3 days. I'm still seeing Exchange Services take a big chunk of battery. It is always first or a close second to screen in battery use. I have tried tweaking the settings. I tried changing from push email to update every 5 min. I even tried changing it to 10 min. I am synching email, calendar and contacts. I have it set to not auto download attachments. Are there other settings I should be looking at? I also turned off 4g since it's not available in my area yet. Phone is rooted, but I'm using stock ROM, kernel, etc. I ordered extended battery but it looks like it only adds ~15% capacity.

    For those who have very low Exchange Services battery usage, can you post details of settings?
  8. wedgemoose

    wedgemoose Well-Known Member

    Not mine. it's perfect. Barley even registers on batt usage(2%). And for the first time with an Android phone, it synced easy.

    But not problems here. And your setting seem correct. Humm
  9. Gdwheel

    Gdwheel Well-Known Member

    Mine says 4%.
  10. gobluejd

    gobluejd GOBLUE! VIP Member

    Mine now says 4% (Just downloaded a large PDF).

    Here are my screens:

    Uploaded with
  11. gobluejd

    gobluejd GOBLUE! VIP Member

    I will say I only have 30 contacts (most are in gmail, personal) and about 100 calendar entries (some with attachements).

    As far as days to sync, my complete email has about 8k emails, but only syncing 30 days, my guess is about 500 emails.
  12. MikeDiggityD

    MikeDiggityD New Member

    Hey - you're not alone here. When my corporate account is setup my battery lasts about 3hrs with NO use at all (comletely idle). Exchange Services takes up about 80% of the battery. I even exchanged the handset to make sure it wasn't the unit itself.

    Since I disabled it battery life seems to be normal (at least based on what others have posted). Only thing can think is that it's hanging on first sync and burning juice. I noticed that several of my calendar appointments were missing and never got to the bottom of it. Seems like a software issue that may be localized based on a companys exchange setup...

    Highly annoying...Haven't been able to get Touchdown working on ICS as an alternative so figure I'm stuck for now...

    - Mike
  13. andym127

    andym127 New Member

    I have similar problem exchange eating all the battery whenever i setup exchange or even the new hotmail app. I notice in gobluejd's post that the keep awake time is only 2m 5s, in my case been on battery for 3h 2m and exchange has kept it awake for 2h 9m!!! this must be the do we fix that???
  14. Jay3

    Jay3 Well-Known Member

    I use Good as middleware to get work emails and contacts, and it seems to be running very efficiently with almost no battery use.
  15. arche3

    arche3 Well-Known Member

    Using touchdown exchange client. Lowest use. Very little use of battery. I get emails all day as well.
  16. wedgemoose

    wedgemoose Well-Known Member

    I'm wondering if it's the sync time? I have mine on every 5 mins.

    Are you guys set to "As they arrive".

    i know you probably already tried that but i figured i would ask. I just find it hard to beleive that some it's a hog and mine (and others) it works perfect.

    I'm going to change mine right now to test.
  17. camphill

    camphill Well-Known Member

    ...agree. Touchdown is the best.
  18. arche3

    arche3 Well-Known Member

    As items arrive. Push.
  19. jamosjamos

    jamosjamos New Member

    I think my issue w/ Exchange Services using huge battery is resolved. I noticed (as did another on this thread) that certain calendar events were not showing on the phone. I had to go through my Outlook calendar and change any reoccurring events with no end date to have an end date. After that, the Android calendar showed all Exchange events, updated correctly and battery usage for Exchange Services has gone way down. I still don't have a full day, so I'm not sure how low, but I am sure it's gone down to a much more reasonable level.
  20. gobluejd

    gobluejd GOBLUE! VIP Member

    For those that have problems:

    Have you checked Settings>Accounts & Sync>Exchange Account and see if you have the SYNC ICON instead of check mark?

    Check Mark = It has completed Sync
    Sync Symbol = White Sync moving means your exchange sync is in progress. I think this also shows in the notification bar by time, alarm, wifi, signal etc.

    On my HTC phones sometimes this would hang and drain my battery. Sometimes it was a contact it did not like or a repeating calendar entry.

    I would try this:
    do not sync everything. Start off with just email, then let that for a while and see how battery life is. Continue adding services until you find what is causing it.

    My bet it is a calendar entry.
  21. MikeDiggityD

    MikeDiggityD New Member

    Wow - thanks for nailing it. I isolated it to Calendar last night by re-enabling Exchange but excluding Calendar sync. Battery life was what I would expect and a huge improvement from before.

    Now my problem - i have a ton of recurring events and am not the organizer of them all. It will be a major pain to police this. Will give it a try though....

    - Mike
  22. jamosjamos

    jamosjamos New Member

    One alternative I read about but have not tried seems to be to synch your Exchange calendar with Google calendar, then synch phone with Google calendar. This does seem to allow one to leave reoccurring meetings with no end date, but it's not as secure because your calendar replicates to Google. There is supposed to be an app that syncs Google to Exchange both ways.
  23. baldbull

    baldbull Member

    Same problem with exchange but I refuse to disable my calendar if that is really the cause - I need it for work. Google just needs to work this issue out. There was a problem with froyo and exchange when it was first launched.
  24. MikeDiggityD

    MikeDiggityD New Member

    Yeah - i remember the issues. I actually had Exchange issues with my D1 and Eclair, so i'm not feeling very confident about Google getting a quick fix though hopefully it will get tracked somewhere. Seems like an easy fix.

    I'm trying Touchdown but also having issues syncing there on the GN. Works fine on my D1 so not sure.

    Being an early adopter is greeeeeeaaat....:)

    - Mike
  25. dfwkootz

    dfwkootz Member

    I had issues with exchange services sucking up all my battery life and phone showing awake almost all the time for the first 3 days. I removed the exchange account, watched battery life for a full day and got 18+ hours and the phone awake started matching the screen on. OK so that guaranteed that the awake issue was related to exchange services.

    I then added my exchange account back and it worked for two days with great battery life. awake continue to match screen on, so thought this was awesome, guess it fixed itself. Whoo Hoo!

    Well, this morning now it's back to being awake all the time and exchange services is sucking up all the battery life... Tried pulling battery and still doing the same thing... Wish I could figure this out. Nothing changed for my calendar appointments (there are plenty of recurring apts with no end dates). These were present when it was working correctly so I'm not convinced this is the cause for me.

Share This Page