Exchange not workingSupport


  1. bryantchoung

    bryantchoung Member

    Anyone else's exchange not working?

    On the phone with verizon right now, but I don't have much hope.

    I had my exchange working with the SDK emulator. Could my corporate be specifically blocking the droid?

    It says:
    Setup could not finish
    ---------------------
    Unable to open connection to server.

    Advertisement
  2. lumns

    lumns New Member

    i havent had much luck either its just tells me its thinking
  3. Robobandit

    Robobandit Well-Known Member

    a lot of corporate exchange servers are configured not to allow activesync devices as many corporations are blackberry only shops.

    You should be on the phone with your IT department rather than Verizon, imho.
  4. bryantchoung

    bryantchoung Member

    Thanks,

    I've had a winmo device for about the past 5 years. I've been able to sync with my exchange through verizon no problem.

    So now that I have a new phone and it's not working, I wanted to make sure that verizon isn't somehow blocking or disabling something on my account or phone.
  5. knickerbocker

    knickerbocker Well-Known Member

    It all depends on how your IT department has stuff set up. Luckily, I work for a small company so I am just handing my Droid to the IT guy and say make it work!
  6. dblake15

    dblake15 Well-Known Member

    maybe a stupid question, but you got the plan from verizon that allows you to sync with exchange right?? It was more expensive. They are doing it like the BES plans, and without a BES plan you cannot sync to your BES server.
  7. jmmille

    jmmille Member

    No they are not. The $30 plan works fine. It's more about the server you're syncing with than Verizon's plan.
  8. dblake15

    dblake15 Well-Known Member

    I don;t think that is the case. I had active sync open as I had an iphone that was working fine. Soon as I upgraded to the 45 plan it worked fine.
  9. bryantchoung

    bryantchoung Member

    I had the $45 plan with my last phone, so I thought it would be the same.

    I called verizon to double check. They said i was on the $30 plan. I just reactivated my phone for the $45 plan.

    It doesn't work yet, but i'll give it 15 minutes.
  10. bryantchoung

    bryantchoung Member

    grr. still not working.
  11. fshine

    fshine Member

    Exchange does not work on the Droid for servers that require PIN locking and/or remote wipe security policies. Confirmed that. You have to use a 3rd party app like 'Touchdown' to access Exchange. In fact, try to see if Touchdown works and, if it does, then you know that is why your corporate email account isn't working.

    Very annoying that this phone has been advertised as able to sync with your corporate email via Exchange, yet not ONE reviewer mentioned this VERY big limitation.
  12. bryantchoung

    bryantchoung Member

    The annoying part is that I was able to sync using the android 2.0 emulator in the sdk.

    I guess i'll have to "invest" in touchdown
  13. dchiver

    dchiver New Member

    OK, I just got my phone and it has already synced to Exchange. When you setup a new account make sure that you enter the correct exchange server. If your email address is BenDover@Howdy.com, you cannot just put Howdy as your Exchange server. If your exchange server allows OWA, put that address in. Like webmail.howdy.com. You do not need the $45 plan. You only need the $30 plan for data.
  14. junktrunk

    junktrunk Member

    Wow. Is that really true? If so, I'm also VERY irritated. How can you claim you support Exchange when not supporting something so basic as this....

    I'll have to give Touchdown a try too to see if that fixes it. Thanks for the tip.


    UPDATE: Yep, that was it. Wonderful, a clunky add-on that doesn't tie in with the standard Android Contacts and Calendar database... Here's hoping Android 2.1 fixes this and quick...
  15. knickerbocker

    knickerbocker Well-Known Member

    I had it set up in a couple minutes. No problem.
  16. skytower31

    skytower31 Member

    What are the fields that are required for the Exchange setup?
  17. Redflea

    Redflea Well-Known Member

    The level of disappointment over this is hard to express...I am very unhappy this was never mentioned in any of the zillions of reviews I read.

    Man...what a bummer on what should be a pretty happy day....
  18. bryantchoung

    bryantchoung Member

    I'll agree with you. My heart sank a lot when I saw that exchange didn't work.

    But there is a workaround.

    You guys have to remember they're throwing these systems together really quickly. IPhone didn't have exchange support, sms, or even copy and paste for that matter for the longest time.

    I can't imagine google not fixing this. I'm guessing it was left out in the interest of deadlines. I'm hoping the 2.1 update solves this.

    Overall, I'm happy enough with the rest of the phone that I'm keeping it.
  19. robvy35

    robvy35 New Member

    absolutely disapointed :(
  20. Redflea

    Redflea Well-Known Member

    Touchdown is not working for me...could it be my company is blocking all access somehow? They do allow IMAP access, I used that on my BB.

    But Touchdown could NOT complete setup trying active sync (which I knew wouldn't work - we only allow activesync w/a few WinMo devices) or Exchange 2003 or 2007 access.

    If all I have is IMAP access I'll be worse of than w/my BB, as I don't have a way to even USB sync contacts/calendar/Notes to the Droid!

    Anyone have any suggestion?
  21. jpetersen5

    jpetersen5 Well-Known Member

    I routed everything through our corporate webmail server and was able to get my mail and calendar synced in seconds. Mail pops up on my phone before it hits my Outlook inbox...
  22. Indygreg

    Indygreg New Member

    Ok . . . the palm pre had this same issue . . . would not work day one with Exchange systems that require a PIN (FYI, that is required for the ability to wipe your phone remotely - I manage our exchange team at work). Palm got ripped for it, as they should. They corrected it in less than one month. There is no way Android does not correct this in a few weeks . . . but it still is a HUGE oversight. Looks like it will cost me $10 for touchdown in the meantime. UGH
  23. flexte

    flexte Well-Known Member

    A heads up!! when i first tried to setup exchange on my hero it took 2 minutes. a week later i had to do a hard reset and it took 30 minutes. the problem is with android. the manual setup and automatic setup get all messed up. pay close attention to the profile fields. it kept saying connect connect and when i went back to the page the settings had changed. i dont remember how i finally got it working but i think i used the auto setup then let manual setup take over. sounds crazy but i knew it had to work because the first time i set it up it worked fine. keep trying and pay close attention to the connection fields.
  24. rpartin

    rpartin Member

    Droid does email (Exchange)... Droid does contacts (Exchange)... Droid dont do Corporate Calendar.. I get the authentication failed wheen I try to refresh. Anyone have any ideas for this? And we are using Office 2002 so the google calendar sync option isnt even viable.
  25. blazingwolf

    blazingwolf Well-Known Member

    Set up exchange on mine took about minute and all is well. Received Email, Contacts and Calendar. :D

    Not sure what would be different on mine.
Loading...

Share This Page