Exhibit II 4G won't get a signal - need advice

Last Updated:


    GAMESHARQ Well-Known Member

    I've really enjoyed my Exhibit II 4G on Tmobile for the past year or so. It's worked great so far, even when I am indoors.

    But I recently started a new job and when I am at work, I get no signal whatsoever. I can't make calls, check emails, or access the web.

    Is there anything I can do to increase the signal and resolve this problem?

    If not, are there any other phones that I can get that would have a better signal? I am currently on the $30/month unlimited data plan so I need a phone that I can use on the same plan.

  2. eljefe0000

    eljefe0000 Well-Known Member

    well its easy enough to know that there are certain spots where you dont get signal has nothing to do with the phone can you get a signal elsewhere?

    GAMESHARQ Well-Known Member

    I can get a signal everywhere else. I don't recall ever having trouble anywhere else I've been.

    As soon as I step outside of the building, it works fine.

    I could somewhat understand if the 4G signal indoors was weak, but I thought if the 4G didn't work, it would kick in with the 3G instead.
  4. eljefe0000

    eljefe0000 Well-Known Member

    sounds like your in a dead zone doesnt matter if your in a 3g zone a 4g zone think of it as being under ground here in nyc once you go down to the train stations you have no reception. you can contact tmo to see if they are having tower trouble in that area but i doubt it since once you go outside everything works ine
    tube517 likes this.
  5. tube517

    tube517 Well-Known Member Contributor

    Do any of your coworkers have a Tmobile phone? Do they have any signal at all?

Share This Page