1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Exit StrategiesGeneral


  1. NowVoyager

    NowVoyager Well-Known Member

    For those who used the Exit Strategy of going with the G2, take a look @ this puppy - G2 running ADW Launcher EX (Home screen and app drawer program) The G2 in this video is supposedly running with Android OS 2.3 (Whatever its running, its fast and smoooooooth!!!) Take a peek! Look at the G2 fly

    http://www.youtube.com/watch?v=XAR5ggcqJjQ&feature=player_embedded


    Here are some other screen shots of the ADW Launcher EX replacement app:
    ADW Launcher EX Android App: It's the best home replacement app for your Android Phone | TheAndroidSoul
  2. Hugh2d2

    Hugh2d2 Member

    Hi gang.

    I have had it up to here *raises hand above head* waiting. I'll be using this thread to root tonight.

    Thanks for all the info.
  3. NowVoyager

    NowVoyager Well-Known Member

    Hi Hugh, Welcome!

    We all feel your pain. But now you can do something about it, one way or another. Its very empowering, LOL. At least its a whole lot better than Moto's dangling carrot torture. Ask out loud if you need help
  4. AdrianG2

    AdrianG2 Member

    Im stuck on the part where you have to do the commands to see your imei number in the cmd box. I typed in all the codes but were getting wrong messages.. Do I actually have to do this part first?
  5. 41rw4lk

    41rw4lk Member

    Should just have to type 'ADB devices'
    However, I never seen the IMEI number for my phone, just a 10 digit alphanumeric, but either way it was my phone and it was recognized. Hope that helps.
  6. Kinghat

    Kinghat New Member

    Free Free Free at last LOL using same name as on Moto forums rooted and using ADLXMOD 2.1.54 not sure why i didn't do this before thanks goes out to Mastermind and NowVoyager and the rest who are now free
  7. Mastermind278

    Mastermind278 Well-Known Member

    Hey guys a Speakerphone toggling fix has been found:
    Speakerphone Toggling Issue Fixed

    Hopefully myself and Adlx will post updates to our ROMS that will get this fixed.
  8. Mastermind278

    Mastermind278 Well-Known Member

    crunch514, taztech, jmasters and 6 others like this.
  9. 41rw4lk

    41rw4lk Member

    Just installed the fix and it works great. Awesome work.
  10. Kinghat

    Kinghat New Member

    Fix works great
  11. NowVoyager

    NowVoyager Well-Known Member

    @Mastermind278 Wow!!!!!!!!!!!!!!! You are THE best!!!!!!!!!!!!!!!!!

    Welcome to Kinghat and 41rw4lk!!!
  12. AdrianG2

    AdrianG2 Member

    I keep getting a 'adb' is not recognized as an external or internal command, operable program or batch file message. Does anyone know what that means?
  13. Overbord

    Overbord Member

    taztech, jmasters and butcheroftexas like this.
  14. 41rw4lk

    41rw4lk Member

    Make sure that you are in yours tools folder of the androidsdk directory in the cmd prompt eg C:\AndroidSDK\tools
    make sure adb.exe adbwinapi.dll adbwinusbapi.dll are in that folder by typing 'dir'
    if all checks out just type 'adb devices' and it will work. From the sounds of it though, you don't have adb installed in the right directory or you're issuing the command from the wrong place.
    I know that the android sdk r8 release didn't include the adb files for some reason, so I'm attaching the 3 files needed just in case you don't have them. Just extract these to your AndroidSDK/Tools/ folder and you should be good to go.
    One more note - you should have the folder path in your environmental variables. Goto Control Panel > System > Advanced System Settings > Environmental Variable - then in the system variable window dbl click the "PATH" variable and add the location of your tools folder eg C:\AndroidSDK\tools to the end of the path string
    Make sure that the new location is separated by a comma like the rest are.

    Attached Files:

    AdrianG2 likes this.
  15. Asym

    Asym New Member

    Just had to register and for the record, canadian geese are white and fluffy and found in the sky. It did not take that as a correct answer during registration.

    Has anyone tried the Z4 root app on the XT yet? Its listed as compatible with the original Cliq but no mention of the XT.
    [APP] z4root - xda-developers

    For anyone wanting to try it just download the app to your SD card, browse to it with a file explorer application and run it. I've used it on a few samsungs and it worked well on those. Wish I would have known about Z4 before, trying to root on a linux machine was a painful waste of time.
  16. 41rw4lk

    41rw4lk Member

    lol that's funny about the registration. I believe I tried the Z4root, but it wouldn't work for the cliq xt, maybe it was just me. For the record I used SuperOneClick [APP]SuperOneClick v1.5.5 (Root, Unroot, Enable Non-Market App, Get UNLOCK code) - xda-developers
    It's not flawless and just one click though, it more of a timing thing, but ultimately it does work and rooted my XT. Hopefully this serves for future reference.

    Just curious - Did you get root Asym?
  17. NowVoyager

    NowVoyager Well-Known Member

    Welcome to Mikelloyd and Asym!

    @Modders - Please remember our users who are on Macs! If you can, point to instructions for Rooting/Modding/Installing ROMs for Macs as well as Windows if possible.

    Please remember to use the "Thank" button to say "Thank you" to those who are helpful!

    Please thank Mastermind for the Speakerphone toggle fix!!! This is great news!!!
    Woo-hoo we're free!!!
  18. Asym

    Asym New Member

    I rooted with the standard windows instructions. I usually run linux but I also have windows loaded on one of my drives on this netbook. I used to also have OSX loaded but got sick of the updates breaking it and just use linux on it now. Trying to root in linux is a major pain and I found the z4 after I already rooted, so thought I would post it to maybe see if it made it easier for others.

    I do find it funny how much easier it is to root Android(linux) from a windows machine. In linux the guides I found require over 400mb of install files.
  19. blackrob1010

    blackrob1010 Member

    I'm finally free of 1.5 and it feels so good. I have no respect for Motorola engineers. Modders are the best. I'm running ADLX mod and it is great. The speakerphone fix worked great as well. Moto can now go to hell. All those who are thinking of modding it is worth it 100%. just be careful and follow the directions closely and you should be fine. If you need help there are many knowledgeable people in the forums to help you (you can read through the post too, any problem you're having I'm sure was encountered and solved by someone else). 2.1 rocks hard.
  20. Overbord

    Overbord Member

    @brob1010 what did you use for recovery?
  21. AdrianG2

    AdrianG2 Member

    Thank you for the files. Now, I need to know where I should be typing 'adb devices'. I went to the search bar in the start menu (Windows 7) and typed in cmd, the black cmd box popped up, and I typed it there. Is that where I should be?
  22. socko99

    socko99 Member

    @mm278 and @adlx What it the timeframe for a fully integrated ROM with issues fixed.

    I want to root/rom my wifes XT but don't want to do all the patching like on mine.

    No rush. Just wondering. Thanks for all your hard work.
  23. 41rw4lk

    41rw4lk Member

    In the CMD box type
    cd / (that will put you at the %systemroot% or "C:\")
    cd androidsdk/tools (that will put you in the proper folder assuming yours is named appropriately)
    dir (to verify that the 3 adb files mentioned in earlier post are in that folder, if not, put them there)
    adb devices (that will list any adb devices connected) *Don't forget to have usb debugging turned ON the phone
    Now if you see your device (should be the only thing connected), then you're ready to start the root process with whatever method you choose.

    Hope that helps.
  24. NowVoyager

    NowVoyager Well-Known Member

    Happy New Year To Everyone - And a SPECIAL thank-you to Mastermind278 for all that you do on the XT platform and in our community!!!

    [​IMG]
  25. lcihon40

    lcihon40 New Member

    Was sailing through the process of getting 2.1 on my XT. I made it as far as flash_image and the USB cable got knocked out of the phone. Now when I plug the phone back into my computer I get device not recognized. Is there any way to fix that? I still have a working phone but can't finish my "project". Any suggestions would be greatly appreciated.

Share This Page