Experiencing GPS issues on the HTC EVO 4G LTESupport


  1. Crimson01

    Crimson01 Well-Known Member

    Today I went to use Google Navigation for the first time since I got my Seido Surface case. Oddly enough, my phone while it found the destination I was trying to drive to, Navigation kept saying searching for GPS..... so I assumed it was the case. I tried it without the case, and still no dice. Rebooted the phone, and still no GPS signal. My wife is next to me with her Galaxy Nexus, so she fires the same app up and voila, no problem.

    Later, at home I test it out and it connects without issue. What gives...anybody else have any GPS problem? My og EVO never failed me like this.:mad:

    Advertisement
    :
  2. Ryuinferno

    Ryuinferno Well-Known Member

    Maybe it is because of the gps chipset in your phone...galaxy nexus has a better one i guess,so it detects gps satellites faster...usually I would recommend people to stay at a place and wait for the gps to be set before driving as it is easier for a satellite to detect stationary objects...by the way,you have packet data working right?Google navigation requires an internet connection to function...
  3. PattiCakeUS

    PattiCakeUS Well-Known Member

    I use my GPS a lot (almost daily) and haven't had that issue on this phone.

    The only issue I've had regarding GPS so far was yesterday; I tend to plug my phone into power when using GPS and yesterday I was running around quite a bit and used GPS to guide me from place to place. At one point I noticed in the status that it said my phone was overheating, and if I remember correctly it also said it was discharging - which I thought was odd. Maybe that's a normal reaction to overheating? I don't remember ever seeing that on my previous phone (HTC Shift) so it's something I'll keep an eye out for to see if it happens a lot or was a fluke.
  4. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Having the phone charging heats the battery even more, so as a safety feature it will stop charging when overheated. That is a normal response.


    I ran into that on the EVO 4G once.
    KENNECTED and PattiCakeUS like this.
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    Take the phone to a Sprint service center and have them perform an RF test.

    How is the upper back cover? Is it on properly, no issues?
    marctronixx likes this.
  6. EarlyMon

    EarlyMon The PearlyMon Moderator

    Probably not on the radio chip.

    But - good advice for anyone relying on GPS is to use GPS Status (free) and calibrate your compass and sensors. Accuracy issues are often addressed that way.
    flyjbaker, dustwun77 and marctronixx like this.
  7. Turkey

    Turkey Active Member

    After coming from a epic galaxy s2, this gps is 100% better. Mine looks on in 5 seconds and I'm good to go, but I also live in a 4g lte area and get great reception.
    3vodroid likes this.
  8. Hellion

    Hellion Member

    I also am seeing this issue of the GPS loosing signal. It happens after about five minutes or so of use. I have the car dock. It I exit navigation and then restart it I will get right to my destination route, then five or more minutes later it will start searching for Satellites again. It's driving me rather nuts since I use the GPS almost every day. On my OG Evo it never had a problem. Someone else suggested calibrating it with GPS status. I'll try that tomorrow and report back...
  9. JMac202

    JMac202 Well-Known Member

    I would argue it has a better chip. Sammy has some of if not the worst gps chips on the market.
    3vodroid and simcha like this.
  10. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    I had a 10-mile run yesterday, and the GPS suddenly quit after 2.7 miles. On-screen, the radar was flashing (GPS searching for satellites), but it never recovered. I've done many runs with this phone, and this is the first time this has happened. Sounds similar to some of the other issues being reported in this thread.
    Mr. Ed likes this.
  11. Archon810

    Archon810 Well-Known Member

    Same issue on my EVO LTE. Took a 2 hour drive yesterday and at first it couldn't acquire gps for maybe 10 minutes. Then it did but would drop out every few minutes. Eventually I got sick of that and we switched to my wife's EVO 3D which has never had a single gps issue.

    Very disappointed with this phone so far, gps just added to the growing list of frustrations. Looking forward to getting the Sgs3 when it comes out. It is almost impossible that they would be able to screw it up more than this phone.
  12. JMac202

    JMac202 Well-Known Member

    Good luck with the GPS on the S3. It will probably be just like most Sammy phones and have gps issues as well. Which is a known issue with Sammy across the board.
  13. EarlyMon

    EarlyMon The PearlyMon Moderator

    Please note, many thanks in advance! :)

    I wonder if this is related to our multitasking problem and therefore fixable.

    For anyone willing, please get this app - https://play.google.com/store/apps/details?id=org.jtb.alogcat&feature=nav_result

    Android has a running log of its operations tucked away, that app makes it accessible.

    When GPS trouble hits, open aLogcat - then, menu, Save - you may be driving and it may not be convenient - please do as soon as SAFELY possible after the trouble, many thanks.

    This next bit you can do later when it's convenient:

    That creates a text log file in /sdcard/alogcat (ends in .txt).

    Please zip that and attach that here. To attach - click the "Go Advanced" button below the posting tool, look for the paperclip tool at the top of the post entry too.

    Perhaps the cause will stand out with a good log review.

    That's the best I can offer for a path to solution at present. :(

    PS - log analysis is time consuming, I'll do my best. :)

    PPS - maybe until we have this resolved, best to not throw too many Samsung stones. I'm seeing this issue crop up on other forums, and it's not the same few people posting everywhere.

    It's evidently a limited problem - but it's a REAL problem. ;)
  14. Archon810

    Archon810 Well-Known Member

    I used GPSStatus (https://play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2) today to try to identify how many sats it locks onto. After 5 minutes, I had 0/21. Zero.

    I don't see how multi-tasking can have anything to do with this - when you're in Maps or GPSStatus, the GPS icon starts blinking as it's trying to obtain a lock, and it just never turns solid, while my wife's EVO 3D locks on instantly right next to me.
  15. EarlyMon

    EarlyMon The PearlyMon Moderator

    Maybe worthwhile to schedule a test at your nearest Sprint service center (per my post above).

    I had those symptoms on my Evo 3D, they replaced the phone and I was a happy GPS camper after that.
  16. Archon810

    Archon810 Well-Known Member

    Doh. Do you think they'd still do this considering I've unlocked the bootloader using htcdev? I spent like 2 days configuring everything and restoring apps.

    If I have to do this, I'll wait for the SGSIII, then reset and exchange the EVO LTE and give it to my wife. That way I at least won't have to waste time re-setting it all up.

    The weird part is that the SGS II had the same symptoms - GPS was perfect at first, then started deteriorating, then went to crap like this, then returned, worked for a few days, then went back to crap again, and it's super sensitive. It's amazing that the EVO LTE is doing the same thing now - it's like I'm cursed.
  17. Hellion

    Hellion Member

    Well, I tried GPSStatus and reset it through the tools. I turned off LTE and even turned off the Car Dock mode to use straight NAV. Still looses GPS satellites after 10-15 minutes of use. Couldn't get it to come back for a while.

    I guess next step is to take it into the store to test it out. What a pain in the ass. I used the GPS on my OG Evo so much without ever having an issue. It's sad to have this nice new super awesome device fall so flat on something that should be working.

    I have not tried Sprints NAV program yet, I guess I could give it a try. I'll let you know what I discover.:(
  18. Crimson01

    Crimson01 Well-Known Member

    I've been trying to remember during my commute to try my NAV & MAPS just to see if the GPS locks, and how long it stays locked. So far, it's been immediate, and consistent over 5-10 minutes. I did download the GPS Status, haven't calibrated, or played with that tool much. But now that I'm aware of others, I plan to check this more, if she fails again, its going back. The GPS one of my favorite things about a smartphone, I use the Sprint Family locator a lot, and it's most definately a FAIL if this feature is inconsistent. Thanks to you all for following up and checking yours, lets continue to monitor, and hopefully, there will be some sort of update that makes this go away.:rolleyes:
  19. KenjiSpencer

    KenjiSpencer Well-Known Member

    I had the same experience the first time I used Google Navigation. It couldn't find a route to anywhere. I went to Settings->Location and turned all of the settings on. That fixed the problem.
  20. Hellion

    Hellion Member


    I am consistently having the problems with the GPS loosing the satellites. I was driving from Jacksonville to Tampa yesterday adn started the GPS up, in the official 4G LTE car dock. All location options are on. after about 20 minutes it failed again.

    The phone seems to get really hot when using the NAV. The screen being on and warming to chipset too much might be part of the problem. I can tell you that it is driving me a bit crazy because other than this one issue the phone is the most amazing thing I have ever used. So frustrating...
  21. skinnybandit

    skinnybandit New Member

    I just got my htc evo 4g lte about a week ago and just tried to use the gps today, however it takes forever, after about 2 min i give up. Just wondering if anybody else had this problem and seeing if anybody was able to fix it Thanks.
  22. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums! :)

    It's not rampant, but you're not alone either.

    I suggest checking other posts here, running GPS Status (free, in the Play Store) and running its tools.

    If it won't lock right away you may also consider that you (sadly) got a lemon - happened to me on my last phone, calls were spotty, GPS was atrocious. Replacement cured the problem.
  23. Greens

    Greens Member

    I'm seeing lots of GPS problems with EVO LTE also. Sometimes won't get a gps fix at all, other times takes a long while, drops connection, and last night sent me to wrong location (off by over 5 miles). A friend using the previous EVO with same version of Google maps in same car got entirely different (and correct) nav results so it seemed specific to my EVO LTE.

    I'm taking my phone in today to check RF, so hope that will help. I will post back here if it does or does not help.
  24. yepjimmy

    yepjimmy Member

    Just got new HTC EVO 4G LTE, works great in beginning, GPS signal locks right away. When I
  25. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums! :)

    Others have experienced the issue as well, so I've moved your post here where you can see their experiences.
Loading...

Share This Page