Extended Battery Not RecognizedSupport


  1. MrClean

    MrClean Well-Known Member

    I searched and didn't find an answer to this particular issue, or maybe I didn't use the right keywords.

    I got a Motorola extended battery for my Bionic. Powered down, put the new battery in, tried to power up....nothing. So I plugged it in and when I hit the power button it starts to boot then stops, shows a battery with a '?' in it.
    I tried letting it sit on the charger for awhile - nothing.
    I tried putting in the original battery and calibrating it - nothing, but I didn't expect that to make a difference.

    Anyone seen this before? Thanks in advance.

    Advertisement
  2. Thom

    Thom Premium Guide Member Guide

    Are the battery contacts and contacts in the Bionic clean? (One person recommended using a pencil eraser.) Is the battery properly seated?

    If you are using the charger and cable that came with your Bionic and the battery came from the Verizon store I suggest that you return it for a new battery.

    If any of my assumptions are not correct ... what are they?

    ... Thom
    MrClean likes this.
  3. MrClean

    MrClean Well-Known Member

    Thanks for the question about the battery contacts Thom. The prongs in the Bionic looked good. I got out a magnifing glass (those are needed at my age :D) and found one of the battery contacts on the new battery wasn't properly positioned to make contact with the prongs in the phone. I grabbed my tiny little pick tool and used it to pry the contact over so it aligned like the rest and whamo, phone powers right up.

    That explains the '?', it was seeing a battery, just not the full power it expected. Thanks again Thom.

Share This Page