Factory original Android or a custom ROM?General

Last Updated:

  1. britheguy

    britheguy Member

    I had bought an T301 from eBay and the seller said he had put a custom ROM on the device. I had later decided to install the factory ROM and overwrite the suspected custom ROM with the factory update I downloaded from the Velocity Cruz Website.

    I had followed the directions on the website to update the factory ROM I downloaded and it appears that it was successful because I watched the update process as it was happening. However, upon checking the build number and version in the "about device" menu, the build number and version is still the same as it was before the tablet was flashed. So, did the factory ROM really overwrite the custom version the seller installed, or does the custom version still exist despite updating back to the factory ROM?
    Or did the seller take me for a ride and never updated the ROM afterall?

    Here is the information about the build number and version. Could someone please tell me if this is the actual factory version or the remains of a custom install which did not get wiped? And if the case is that this is a factory ROM, could someone tell me how to get back to the factory ROM using the update downloaded from the cruz website?

    Kernel Version:
    szhao@szhao-desktop #2

    Build Number:
    T301-eng2.2.1 FRG83 en.szhao.20110513.0133

  2. Electritech

    Electritech New Member

    What you have there matches exactly what I have on my T301. You are updated to the most current release from Velocity Micro. I think there is only one custom ROM for this tablet. You could always update to that and check the build and version number. It's easy enough to flash back and forth. :)
    britheguy likes this.
  3. britheguy

    britheguy Member

    Thanks for the reply. Since you also happen to have the T301, have you experienced the tablet browser force closing at pretty much every page that requires or runs javascript? I have tried both the stock browser as well as Dolphin HD and both of them close when opening a page that uses javascript. The Google homepage, for example always closes. As well as almost everything else that uses js.
  4. Electritech

    Electritech New Member

    I just seen a work around for this. Can't remember if it was on slatedroid forum or xda or here on this one. There may even be a work around on the Velocity Micro Cruz website. What I have done is turned off javascript in the settings for both the stock browser and in Dolphin Browser. From what I understand you still can't use the google search page, so stay away from that and use yahoo or whatever other search page you would like.

    Make sure when you start up the browser that wifi is off, then you can get into settings and turn off javascript, then re-enable wifi and you should be able to access the internet. Mobile versions of pages seem to work the best, and your page viewing will be somewhat limited without the java, but it has been acceptable enough for me for the limited amount I use it.

    Feel free to ask any other questions, I'll try to answer what I can.
  5. justtom

    justtom Well-Known Member

    Thank you Electritech.

Share This Page