Factory reset not working?Support

Last Updated:

  1. stupidchicken0

    stupidchicken0 Active Member

    So my phone (Droid Pro) was rooted with Z4root. Verizon issued an update over the weekend and i installed it, and did not unroot my phone, and I guess you're supposed to do that first.

    So the "SU" icon is still on my phone but i dont have root access anymore. Tried reinstalling Z4root and nada.

    So I said screw it ill just do a factory reset. Backed up all my contacts with Verizon Backup Assistant and pulled my SD card out.

    The first time I did it, this is how I did it:
    -Powered phone off
    -Held down M and R keys and turned the phone on
    -Then pressed the @ key once the screen came up
    -I selected 'wipe data/factory reset' and off it went.

    Phone rebooted and i redid all my gmail account and all that good stuff.
    the contacts that ive manually entered into the phone since i got it, were still there. I still had the same browser history AND about 7 apps were still installed, including the "SU"!

    Second time i tried a factory reset I did it thru the phones options.
    -Privacy - Factory Data Reset ect ect.
    This time it went thru a different screen or two and on boot up, i had to reactivate my phone (press 1 blah blah blah) and then redo my gmail stuff again.

    AGAIN the manually entered contacts, apps and "SU" are still there!

    Any ideas on what to do?

  2. bsweetness

    bsweetness Well-Known Member

    Did you wipe the cache partition? It's the fourth option when you boot into recovery mode.

    If you've done that and you're still having problems, you might want to try flashing the 2.26.20 SBF.
  3. stupidchicken0

    stupidchicken0 Active Member

    I did not do the cache partition. Does that get selected/wiped out first? Then "reimage" the phone?
  4. stupidchicken0

    stupidchicken0 Active Member

    Ok so i just cleared the cache partition and then did a factory reset.

    Upon boot up this time, i have NO previously installed apps, BUT I still have all the manually entered contacts and "SU" icon. What the heck?

    EDIT: and i still have the same browser history as well
  5. bsweetness

    bsweetness Well-Known Member

    I'd try flashing the SBF. From what users have said on other forums, if you applied the update while rooted, you could end up in a state that's kind of between rooted and unrooted, which won't let you do either. Flashing the SBF and then accepting the update while unrooted has fixed this for them.

    The Droid Pro forum here is barely active. There's a lot more discussion and information here on everything related to the update and rooting:

    Motorola Droid Pro - Droid Forum - Verizon Droid & the Motorola Droid Forum
  6. stupidchicken0

    stupidchicken0 Active Member

    ill check that out thank you.

    im still i big n00b with the Droid, its my first one. What is SBF and how do i flash it?
  7. bsweetness

    bsweetness Well-Known Member

    A SBF is a system boot file. It's essentially what the company uses to actually load the software onto a phone. By flashing it yourself, you're essentially resetting the phone in the same way that Verizon or Motorola would. It's also a way to recover a bricked phone. If a SBF is available, it's almost impossible (almost) to truly brick a phone permanently if you have access to it. In order to flash it, you have to download the proper SBF for your phone along with RSDLite (the program to flash it with).

    This thread is the originator of the Pro's SBF file along with instructions on what to do: Droid Pro SBF File (2.26.20) Full and RSDLite

    There's also some more detailed directions here, including a video walk through using a Droid X (the process is the same for the Pro): The official Droid pro sbf from TBH - Droid Forum - Verizon Droid & the Motorola Droid Forum

    I've done this a few times (both with the X and the Pro). It's a pretty easy process. But much like rooting, flashing custom roms, or making any other major changes to your phone, there's always a chance that something could go wrong. Make sure to follow the directions exactly.
    stupidchicken0 likes this.
  8. stupidchicken0

    stupidchicken0 Active Member

    Again, thank you. Once i get some free time ill have to read up on all that and try it out.

    As for now, my phone is acting fine. It was a little sluggish right after the update but after doing a "factory reset" (that didnt do much lol) it seems to have sped up (but like you said, its kinda in limbo).
  9. stupidchicken0

    stupidchicken0 Active Member

    Ok so i installed RSD Light. Downloaded the SBF file. Updated drivers. Then followed the video that you linked me to.

    Everything seems to have worked. It said my phone passed and then I did a factory reset after using RSD light.

    I still have the manually entered numbers, browser history. But the "SU" is gone!! :D

    Im starting to wonder if the google backup (when I first boot up the phone and i add in my google account info) stores browser history as well? Thats the only think I can really think of right now.

    But again, thank you! So far so good! Ill look into the other rooting app you suggested as well :)
  10. bsweetness

    bsweetness Well-Known Member

    Glad it seemed to have worked. You have to do a factory reset, choosing to wipe everything, directly following the SBF flash to remove all of the user-entered data like contacts. But then again, you've done that previously, and your contacts do sync with your Google account, so they should come back when you sync up your account after a reset. I'm not sure about browser history though. aRoot worked great for me after installing the latest Motorola USB drivers for rooting. Just make sure to do that after installing the latest update. You don't want to be rooted again when installing that. :)
  11. stupidchicken0

    stupidchicken0 Active Member

    Can you easily unroot with ARoot as well? Simply plug it back in and click a button to unroot?
  12. bsweetness

    bsweetness Well-Known Member

    Yes. There's an unroot.bat file in the download.

Share This Page