Factory Reset Not WorkingSupport

Last Updated:

  1. geeraffe

    geeraffe Member

    Hello, I'm trying to completely reset my phone strip the software down to the basics. The only problem is I've tried doing that through going to Privacy->Factory Data Reset and it didn't quite reset it as I thought it would have.

    After completing it (even checking the box to Erase SD card) I still have some apps on there. Namely QQ (I'm in China), the Superuser program, Angry Birds, Maps, Gmail and some Chinese keyboards among others. What I'd like to do is reset everything back completely and re-root it. The phone was rooted when I received it and I didn't have direct involvement in it being rooted...I want to change that.

    Is this possible? Have I missed some setting or checkbox when doing a factory restore? For reference here are the contents of my 'about phone' page:

    System updates


    Battery use

    Legal information

    Model number: HTC Incredible S 710e For AT&T

    Android version: 2.3.5

    Baseband version: MAUI.11AMD.W11.37.SP.V6, 2011/10/29 13:22

    Kernel version:

    Build number: Snapdragon MSM8255 1024Mhz AT&T ROM 576MB+RAM 768MB

  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    You could try running an RUU (ROM Upgrade Utility), that would completely restore your handset to a specific software version, to just as it was when it came out of the factory. Root would be removed.

    Is it the stock ROM that's on there currently or is it running custom firmware? What is your software version/number in About Phone?
    geeraffe likes this.
  3. geeraffe

    geeraffe Member

    Thank you for your response about the RUU. I'm a complete noob and sorry if this is posted somewhere (I tried searching but couldn't find anything) - is there a link somewhere to a RUU? Where would I find something like that?

    I'm sorry if I can't provide much more information on the phone - I'm actually not sure what rom is installed on there already. It was a gift and I don't think my friend even knows what ROM is on there, and if he did it would be kind of a hassle to figure out as he bought it from TaoBao (Chinese eBay).

    I think my version # is 2.3.5 - is that correct?

    Thanks again
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    There is a link, but before I know which one you need to download and run, I do need to know the exact software version (or at least I need to know if your handset is network branded or not). If you head to Settings -> About Phone -> Software Information, it should tell you there. It will be in a format similar to this x.xx.xxx.x (pbviously the X's will be numbers).

    BTW, no need to apologise for being a "noob" or not finding any similar topics etc. You've asked, we'll endeavour to answer, that's how we roll.
    geeraffe likes this.
  5. geeraffe

    geeraffe Member

    Thanks again for your reply El Presidente.

    I'm not seeing "Software Information" in my About Phone section. What I see I have already pasted in my OP. About it being branded or not, when I start the phone up I get an AT&T animation/logo if that means anything.

    For reference in the About Phone listing I pasted in my OP the first 4 entries are clickable...when I click on

    System updates

    it takes me to a screen that says "Your system is currently up to date." When I click on


    I come to a menu that has information about my Batter status, Wi-Fi MAC address, Bluetooth address, Up time, SIM Status and IMEI information. The latter two are also clickable which lead me to

    SIM Status

    has information about my phone #, Network (China Unicom, I'm using a GSM sim card) Signal strength, whether I'm roaming or not and my Mobile network state/type

    IMEI information

    has info about my IMEI(Slot1) which is a big string of numbers: (mod deleted for privacy protection) and IMEI SV(Slot1) whose entry is just XX. I have another two entries called IMEI(Slot2) which has the same long string of numbers and IMEI SV(Slot2) which is the same as Slot1, XX.

    Back to the main menu

    Battery use

    just tells me about my battery information

    Legal information

    has Open source licenses and Google legal.

    Other than that I don't think there is any other info I've left out in my About Phone menu. Maybe I went a little overboard in describing the menu items haha.
  6. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Ok, thanks. There is no such thing as going overboard on info btw ;)

    I can't find a suitable RUU, sorry. Would flashing another ROM be sufficient? The RUU is a exe and is ran via windows (and is from an official HTC source) where as flashing a ROM involves using a tool called clockwork mod and is done on the phone itself. Sounds daunting, but I'll make it as easy as possible for you.
    geeraffe likes this.
  7. geeraffe

    geeraffe Member

    I would be open to anything where the end result is that I can have my phone go back to 'default' - and then afterwards I want to re-root my phone so I know exactly what I'm getting into. I'm not afraid to get my hands dirty, in fact I'd rather that way than not so then I can know a bit more on how the device works.

    Actually the real reason I'm doing this is because I have a VPN that hasn't been able to work on my phone (it worked on my coworkers HTC on the same wifi network using wifi only, same as me) but not on mine. I wonder if maybe some program I have is getting in the way and blocking my VPN from access. I also don't want all these Chinese programs/markets/etc on my phone as I'm not Chinese haha.

    Out of curiosity, what would happen if I use a RUU that isn't 'right' for my phone? Will it brick the phone? Also, is there some other way to find out how my phone is branded?

  8. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    The issue is that I can't find an RUU that I believe will work for your phone unfortunately. Your phone (and all HTC's, not sure about other manufacturers) is hard coded with something called a Carrier ID. Each network has their own CID and their own software to put on the phone. If the CID doesn't match the software the phone is trying to load, it can cause issues. It's not really an issue with a custom ROM as they're programmed to work with all CID's. You can check with this: CID Getter. You might be in luck, you could have an unbranded phone in which case, sourcing an RUU would be a lot easier.

    If you flash a new ROM, it would be like having a new phone from scratch, all previous apps/info on the phone would be gone, I take it that's ok?

    Does that all make sense?
    geeraffe likes this.
  9. geeraffe

    geeraffe Member

    Thanks for the explanation on what a CID is. Too bad you can't use a different CID on a different carrier's phone...but makes sense!

    I downloaded and ran the CID Getter application you linked. When I open it there's a screen with a bunch of different strings of text...what should I be looking for? ro.carrier is listed as [unknown], I assume this is the most relevant information I'm looking for.

    EDIT: After looking at the CID Getter app description page, in a screenshot of the app in action there is some red text at the top of the screenshot that says "CID is: " - when I run the app on my phone I do NOT see this text.

    And that's fine about flashing a new ROM - I've already backed up all information I'd like to keep so no issues there.
  10. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    You could be in luck then! :) There's one more thing I want you to check, it involves doing something slightly technical, so if it seems daunting, don't worry, it's relatively easy.

    Can you turn the phone off and remove the battery for 30 or so seconds, re insert and then turn on the phone whilst holding the volume down button. You'll be taken to a white screen with 3 skating androids at the bottom of it. At the top of the screen it should say something like VIVO PVT SHIP S-OFF/S-ON. Can you confirm what it says please?

    Underneath that, there should be some options, something along the lines of:


    Usnig the volume buttons to navigate and the power button to select, move down to SYSTEM INFO and it should list your CID there, what is it? Once done, hit power to go back, then fastoot, then reboot.

    If the first screen you see says:


    Just select Bootloader and you will be taken to the screen with system info on it.

    Once I've got that info, we can take it from there.
    geeraffe likes this.
  11. geeraffe

    geeraffe Member

    I'm going through the volume down powering up menu now.

    When I boot it up I have to go through a series of...tests? it seems. No skating androids or VIVO PVT etc.

    The first one is where I have to touch three red circles to turn them green. After that I have a menu 'Bluetooth' where I have two options - Test Pass and Test Fail. At the bottom of that there is some yellow text that says ---End of Device List No dev found ---

    I click on Test Pass with the volume up button and the next screen is similar to the Bluetooth page but now says Wi-Fi. I have three options here, Test Pass, Test Fail and Renew. I click on Test Pass and...

    The next page says GPS at the top with 4 options this time, Test Pass, Test Fail, Hot REstart and Cold Restart. I click on Test Pass and...

    The next one is Loopback with 4 options again: Test Mic1 loopback, Test Mic2 loopback, Test Pass and Test Fail. I click Test Pass once again and...

    Now I get to what I think you were describing in your post. It says Factory Mode at the top with the options of: Full Test, Item Test, Test Report, Clear Flash, Version and Reboot.

    I've clicked on Version and I don't see anything that looks like it is CID. After clicking on Full Test, it took me through a test to see if my power button and volume buttons are working, then once I've confirmed they are it leads me to another screen where it just says dev not found: -1...none of my buttons have any affect on this screen. I need to take the battery out. I'm going back through the Volume Down boot again, back to the Factory Mode page...

    Don't know what else to click on in here. I'll just list out what I see on the Version page.

    BB Chip: MT6573
    MS Board.: bird73_gb
    IMEI1: same as above post
    IMEI2: same as above post
    Modem Ver.: MAUI.11AMDW11.37.SP.V6. 2011/10/29 13:22
    Bar code: 021100103604
    Build Time: Wed Nov 30 21:25:45 CST 2011
    UBoot Ver.: 2010.06
    Kernel Ver.: (yanwj@ubuntu) (gcc version 4.4.3 (GCC) ) #1 PREEMPT Wed Nov 30 21:15:33 CST 2011
    Android Ver.: 2.3.5
    SW Ver.: Snapdragon MSM8255 1024Mhz AT&T ROM 576MB+RAM 768MB
    Custom Build Verno.: 1322659402

    Since I can't do much else here and don't want to try clicking on Clear Flash just yet I hit reboot, which boots up the phone normally.

    Have I missed something? I can't find where it says Bootloader or anything else.
  12. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    I have no idea what that is unfortunately. It's certainly not a standard HTC Bootloader and part of me is now leaning towards it not being an Incredible S, but a Chinese imitation (it wouldn't be uncommon).

    Given there are 2 IMEIs, are there spaces for 2 SIM Cards? Do you also have a link to the actual auction where it was bought please?

    Can you try it again as well please, keep your finger on the volume down button for between 5-10 seconds.
  13. geeraffe

    geeraffe Member

    I have a strong feeling that the phone is fake. Going through the menu there are sometimes spelling or grammatical errors!

    Good call on the IMEI...Even though there are two IMEIs listed, there is only one slot for a SIM card!

    Sorry, I don't have the list to the original auction...it's most likely fake.

    Does this limit the options I have?
  14. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Very much so, I wouldn't even know where to begin if it was fake :eek:
    geeraffe likes this.
  15. geeraffe

    geeraffe Member

    Hmm I see thanks though for all your support. Do you have any idea what I could do from here?
  16. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    None, I'm sorry.

    Do you still have the CID Getter app installed? There should be a ro.serialno, does that begin HT? What about the ro.product.model, brand and name?
  17. geeraffe

    geeraffe Member

    The ro.serialno is blank, ro.product.model lists HTC Incredible S S710e For AT&T, ro.product.brand lists HTC, ro.product.name lists bird73_gb
  18. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    I'll have a look around, but it doesn't look good.
  19. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Star A3 - OpenGL ES performance and system information

    Searching for bird73_gb brings that amongst other things, all of which point to it being a knock off. I can't see any way of getting another ROM on there and I fear any official (from HTC) or real Incredible ROM might brick it.
  20. geeraffe

    geeraffe Member

    That sounds about right, signs point to it being a knockoff.

    Too bad about that too, I really want to solve these problems I've been having with it. I guess I'll just have to use it as is or get a replacement!

    Thanks again for all your support on this!
  21. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    No problem, sorry it turned out the way it did though.

Share This Page