Failed Cyanogen 7. Now stucked in CWM Recovery :(


Last Updated:

  1. edsoneicc

    edsoneicc Member This Topic's Starter

    Joined:
    May 4, 2012
    Messages:
    9
    Likes Received:
    0
    Hello, I just got my Xperia Ray ST18i, so basically, I'm new to the Android scene. I followed the instructions here Sony Ericsson Xperia Ray: Full Update Guide - CyanogenMod Wiki except for the optional backup. After installing CM7.1, I got stucked in the "touch the android..." I followed the instructions here Troubleshooting - CyanogenMod Wiki But when I selected the zip in the clockwork mod recovery, some assertion error appeared. I tried using other versions of CM but still the assertion error appears. In short, I am stucked in the Clockwork mod recovery. I am thinking of using the Flashtool and downloading the stock official firmware. Do you know any solution to this before I revert back to the original firmware? Thanks, I'm really frustrated right now. I've been doing this for around 8 hours :(
     

    Advertisement
  2. karandpr

    karandpr Well-Known Member

    Joined:
    Feb 16, 2011
    Messages:
    2,951
    Likes Received:
    1,815
    Usually assert fails when you dont have the ROM for the relevant device .

    If the first firmware worked(the one with touch the android) ,then flash the firmware again and dont flash Gapps .
    You should automatically Boot into CM android

    Did you download the files from here ?
    CyanogenMod Downloads
     
  3. edsoneicc

    edsoneicc Member This Topic's Starter

    Joined:
    May 4, 2012
    Messages:
    9
    Likes Received:
    0
    Yes I did use the update-cm-7.1.0.2-XperiaRay-ST18i-signed.zip I also use this one for troubleshooting the bootloop but then the assert error came. I don't see why when I first install the 7.1.0.2-XperiaRay worked and when fixing the bootloop with the same CM didn't work.
     
  4. karandpr

    karandpr Well-Known Member

    Joined:
    Feb 16, 2011
    Messages:
    2,951
    Likes Received:
    1,815
    Hmm .
    Maybe check another ROM from here :) .
    Xperia Ray Android Development - xda-developers
    Sorry I cant help you much .

    its funny it worked for the first time and not the other :(.

    Just in case do one thing .
    Do a factory reset and try flashing the ROM again .
    I cant think of anything else .
     
  5. edsoneicc

    edsoneicc Member This Topic's Starter

    Joined:
    May 4, 2012
    Messages:
    9
    Likes Received:
    0
    Finally got it to work. It seems that 7.1.0.2 is the problem. I installed 7.1.0.1 and it worked. Thanks everyone.
     
  6. Slug

    Slug Check six! Moderator

    Joined:
    Aug 1, 2009
    Messages:
    20,173
    Likes Received:
    15,896
    Glad you got things worked out. I've moved this to the Xperia Ray - All Things Root sub-forum so that it can be of help to others who may run into the same issue.
     

Share This Page

Loading...