Failed to communicate with the serverSupport


  1. Terry S

    Terry S Well-Known Member

    Every time I try to do an update on this phone it says "failed to communicate with the server". I have not rooted or sideloaded or done anything to the phone. How will I be able to get the updates?

    Advertisement
    :
  2. fafik90

    fafik90 Member

    I have the same issue on my phone. I tried a couple times and get that message every time.
  3. CrimsonPride

    CrimsonPride Well-Known Member

    i had the same problem, turned off wifi and got the update, started downloading, 1 second later said update failed, restarted my phone which will now not turn on
  4. zeezz

    zeezz Member

    same problem here, using "cognition" rom with lagfix removed, no dice. not even connecting!
  5. looksbetterinred

    looksbetterinred Well-Known Member

    Does anyone have a clue why this happens or an alternate way of forcing the update? Preferably not one that requires a master in computer science.
  6. George0211

    George0211 Well-Known Member


    Well, I do have a masters in computer science (software engineering to be exact) and I'm having the same problem. I used AT&T chat and they couldn't help me, they couldn't even push the update onto my phone.
    I flashed my phone back to stock and no dice.
    I might be taking it back to the store and getting a new one.
  7. looksbetterinred

    looksbetterinred Well-Known Member


    Well I don't feel as stupid as I look then. :D On the subject of the return, if you are past the 30 day mark, would it then be dealing with warranty and Samsung I wonder?
  8. George0211

    George0211 Well-Known Member

    I have no clue, how it would get resolved. I just called AT&T instead of using chat and the immediately transferred me to Samsung. AT&T rep said they've been instructed that for any Captivate issues to send people straight to Samsung CS. I am currently on hold with Samsung, while their rep is trying to figure it out.
  9. looksbetterinred

    looksbetterinred Well-Known Member


    Are you beyond the 30 days? Let us know how it goes. Good luck!!
  10. kspec1212

    kspec1212 Member

    I have the same problem. I've never once been able to communicate with the server. WTF?
  11. George0211

    George0211 Well-Known Member

    OK, so here is my update on this issue.
    I called AT&T yesterday morning and they immediately transferred me to Samsung.I went thru all 3 levels of their support just to be told that it's AT&T's problem.
    I called AT&T back, got bounced around for a while between a few people who knew nothing. Then I finally got to someone in Data Support department who actually knew of this issue. First thing he did was check the IMEI number on the phone and noticed that it was wrong in their update system. He updated it with the correct one, but it didn't fix the problem. So then he tried to push the update to my phone. Within a few hours, I received a notification but it eventually came up with the same error "Failed to Communicate".
    So later that night, I called AT&T back and got bounced aruond for over an hour, until I got to "Android Specialist" department. The girl I got there was clueless, I mean completely clueless. She actually told me that this phone does not have a GPS problem. When I politely told her that this is a world-wide issue with ALL Galaxy S phones, she was stunned. Then I told her that this is what this update is for, to fix GPS issue. So to that, she told me they are not recommending this update at all, because it seems to be breaking phones. To which I replied, how the hell is AT&T is still pushing this update to people when it is supposedly causing an issue.
    So then she told me no matter what, GPS is NOT a warrantable issue and would not be covered under warranty. At this point(I'm on the phone for over 3 hours now), I was starting to lose it. And I told her, she was completely wrong, and that they sold me a defective phone and I demand a new one.
    So she transferred me to a supervisor. Supervisor said, that update is not "not recommended" and she wasn't sure why her rep said that and she would talk to her about it.
    The supervisor setup a return procedure to send me another captivate, albeit a refurbished one.
    Here comes the interesting part.
    This morning, I got to work and decided to try the update again and lo and behold, it started downloading. My guess, is that the IMEI number update finally propagated thru their system.
    So the download completed and it gave me a few warnings about how I couldn't use the phone while the update is being installed and so on. Then it restarted and went into the update installation screen.
    There it got to 34%, sat there for a while and then jumped to 50% and immediately said "Update Failed" and rebooted.
    I tried to re-download the update a few more times and got the same result.
    I called AT&T again and after talking to them for a while, they just said, wait for the replacement phone to arrive, because they have no idea why it is not installing.

    So my suggestion to everyone who is having the "Unable to Communicate" problem, call AT&T and get their Data Support Center on the line and have them check for the correct IMEI number and then ask them to push the update to you. If that doesn't work, then simply demand a replacement.

    I hope this helps.
    looksbetterinred likes this.
  12. looksbetterinred

    looksbetterinred Well-Known Member

    I just got off the phone with AT&T. My IMEI nuber was correct but still unable to connect to AT&T server. They gave me a ticket number and told me it was a known issue and no ETA on a fix.
Loading...

Share This Page