Failed to get the adb version: Cannot run program.


Last Updated:

  1. OddHov

    OddHov New Member This Topic's Starter

    Joined:
    Oct 7, 2010
    Messages:
    1
    Likes Received:
    0
    Hello everybody,

    I'm new to Android and new to this forum. I purchased a Samsung Galaxy a few weeks ago, and I'm very happy with it! I've begun developing my own stuff a few days ago.
    I first installed all the required software (JRE, Eclipse, SKD etc.) to my laptop, which went smoothless. I wanted to install the same software on my desktop pc, but that did not went so well.

    Everytime I want to open a Android-application-file in Eclipse, it gives the following error:

    Failed to get the adb version: Cannot run program "/home/sodenhoven/Program Files/android-sdk-linux_x86/tools/adb": java.io.IOException: error=2, No such file or directory

    I've searched the internet for sollutions, and found that one of the sollutions is to put the right path to the sdk-folder in the Android settings. I've got the following path:

    /home/sodenhoven/Program Files/android-sdk-linux_x86/

    I really don't know what to do anymore.
    Can somebody help me out?

    Cheers,
    Sammy
     

    Advertisement
  2. spark65

    spark65 New Member

    Joined:
    Oct 10, 2010
    Messages:
    1
    Likes Received:
    0
    Are you running 64 bit Linux? If so use getlibs - see here for a description of the problem. Type "getlibs adb" rather than aapt as suggested.
     
  3. ajay meher

    ajay meher New Member

    Joined:
    May 9, 2011
    Messages:
    4
    Likes Received:
    1
    twoHats likes this.
  4. twoHats

    twoHats New Member

    Joined:
    Sep 8, 2011
    Messages:
    2
    Likes Received:
    0
    The solution from ajay meher works perfectly on Linux Mint 11 and eclipse Version: 3.5.2.

    When first starting with the entire system (eclipse, android, the plugin) it is a lot to get set up right! When you throw in 32 vs 64bit and trying to avoid closed language paths (Oracle) it gets crazy!! Thanks for recognising this and giving such a thorough description!
     
  5. The_app_main

    The_app_main Well-Known Member

    Joined:
    Sep 10, 2011
    Messages:
    78
    Likes Received:
    1
    Hi, I'm running windows and I had a similar error. I did a search and came across a fix that works for windows users. The SDK Location field in the preferences tab doesn't like spaces in the path. I originially had the file in the "c:\program files" directory and got the same error. You can either move the sdk folder to a path that doesn't have spaces or you can do like I did and specific the path as C:\PROGRA~1\
     

Share This Page

Loading...