[FAQ] ADB and FASTBOOT for Windows (Updated 1st June 2011)


Last Updated:

  1. GingaB

    GingaB Well-Known Member

    Another excellent guide Dan. I always recommend your easy guides to rooting to all noobs. :)

    Advertisement
    SUroot likes this.
  2. SUroot

    SUroot Well-Known Member Developer

    Thanks matey. Much appreciated.
  3. Eris Ed

    Eris Ed Well-Known Member

    I have a question, I guess this is probably the best place to ask it.

    I used AlphaRev to S-OFF which worked perfectly. Now I'm trying to flash a partition table and it's not working as expected. Here's what I've done so far:

    1. Downloaded PB99IMG_bravo_sense.zip from AlphaRev.
    2. Renamed it PB99IMG.zip on my PC and put it on the root of SD card.
    3. Shut down phone
    4. Start phone in bootloader (Vol down + power)
    5. phone starts ok but stalls when looking for the PB99IMG.zip

    I get this message: "CID Incorrect!! Update fail"

    Now, I suspect that the CID error may be because my phone was originally Orange-branded, and I'm not using the goldcard I made when I first rooted - is this correct? I can't use my original goldcard with my current set up so my next step is to flash the extracted .img file via PC using fastboot.

    Still, I'd like to understand why the .zip file wouldn't flash, just so I know >)
  4. SUroot

    SUroot Well-Known Member Developer

    Ive never used the PB99IMG for this kind of thing, but CID is carrier ID and that error normally happens when flashing an RUU for another carrier so it is possible you are correct about the cause.
  5. Eris Ed

    Eris Ed Well-Known Member

    The method seems established, and is one of the methods stated on the AlphaRev website. But, there's a few people on Twitter who have had errors when trying to follow that route, and resorted to fastboot/PC to complete the flash. It's a shame really.....dropping the zip on SD and rebooting the phone is such a simple solution!
  6. Usta

    Usta Well-Known Member

    I also couldn't use PB99IMG.zip file because my phone was also branded.
    Anyway, I'm using now Android flasher for that and other purposes. It is simple to use and does the job. :)
  7. Rastaman-FB

    Rastaman-FB Well-Known Member

    fastboot flash hboot aphaxxxxxxxx.img is easiest
    you dont have to drop it on to sdcard then
  8. SUroot

    SUroot Well-Known Member Developer

    Added further clarification to the fastboot command.
  9. Eris Ed

    Eris Ed Well-Known Member

    fastboot flash hboot bravo_alphaspl.img
    fastboot reboot-bootloader
    fastboot erase cache

    That did the trick :)
  10. SUroot

    SUroot Well-Known Member Developer

    added

    For ducky ;)
    ducky1979 likes this.
  11. SUroot

    SUroot Well-Known Member Developer

    Added Anchor tags
  12. ducky1979

    ducky1979 Well-Known Member

    so ive got a new windows lappy running windows 7, ive downloaded the adk and put it into c drive ive plugged in in hboot and updated the driver, ive got the htc drivers installed, but when i type adb shell it says no device found. any help please.
  13. Rastaman-FB

    Rastaman-FB Well-Known Member

    is your device booted?
    if so what is it booted too?
    in device manager can you see android > adb interface?
  14. SUroot

    SUroot Well-Known Member Developer

    Try and do from cmd:

    Code (Text):
    1. [COLOR=Black]adb kill-server[/COLOR]
    Then try again.
  15. ducky1979

    ducky1979 Well-Known Member

    booted? yes
    booted to? hboot
    device manager? android usb/ my htc if phone powerd on android interface if hboot usb

    ive tried it now with phone powered on and after i type adb shell i get a # type mount /system and all it says is mount:cant read '/etc/fstab' : no such file or directory
  16. ducky1979

    ducky1979 Well-Known Member

    tried this and same result as above
  17. SUroot

    SUroot Well-Known Member Developer

    you cant adb from hboot. recovery.
  18. ducky1979

    ducky1979 Well-Known Member

    Yeah I realised that, so just plugged in when phone was running, but it came back with the above fail message.
  19. Rastaman-FB

    Rastaman-FB Well-Known Member

    lol ducky
    hboot doesnt use adb
    the reason i asked how you were booted was for this reason
    either booted into android when you type adb shell you will get a #
    system is already mounted when booted into android and if you do adb devices at this point you will see a device id

    you can do this in recovery too
  20. SUroot

    SUroot Well-Known Member Developer

    use recovery option to mount /system then
  21. ducky1979

    ducky1979 Well-Known Member


    So it was already mounted? Even though I didn't type mount system? And when I did it gave me the above info. So what's the best thing to type to test if its connected successfully?
  22. ducky1979

    ducky1979 Well-Known Member

    got it working now, i couldnt sleep till i had. it was a driver issue. it couldnt see the phone in recovery so i had to tell it to use existing driver for the interface and now all is well, adb is working well.
    cheers guys.
  23. apicia

    apicia Member

    Hey all. My phone will not complete the Odin flashed due to the internal file system being screwed up. I am in the ADB and it works. How do I format the internal sdcard and partition it correctly OR can I just force flash the boot, phone, and pda files?
  24. Rastaman-FB

    Rastaman-FB Well-Known Member

    wrong area mate, you need help from people who use samsungs
  25. dbarny_2000

    dbarny_2000 New Member

    I've had a good search around but I cannot find a solution to my particular problem.

    I want to rename the file camera_click.ogg in system/media/audio/ui to disable the shutter sound when taking a picture.

    My phone is rooted (using UnrEVOked 3.21) and S-OFF (using alpharev 1.8) so I assumed this would be easy.
    I am running CyanogenMod 7.0.3 and trying to use the terminal emulator that was installed with this ROM.

    I ran the emulator and typed the following, as I understand it this would mount the system area as read/write

    mount -o rw, remount /dev/block/mtdblock3 /system

    When I hit enter I got this response

    Mount: permission denied (are you root?)

    Can anyone help me with this as I am obviously missing something?

    Phone info is
    BRAVO PVT1 SHIP S-OFF
    HBOOT 0.93.0001

Share This Page