FAQ: Getting your internet to work (O2 mainly)


  1. Jleagle

    Jleagle Active Member

    If you buy the phone on its own you will not be able to get internet right away (apart from wifi). You will need to setup your APN details to know where to get internet from. The different types of internet are as follows:
    GPRS and EDGE are both second generation
    3G and HSDPA are both third generation

    To get third generation internet you will need a modern sim card, the older ones are simply not able to do it. You can get a free sim card from your carrier with the same number etc which will take affect in 24 hours. If your sim card is too old, the "Use only 2G networks" setting in Android will automatically tick its self.

    You can have multiple APN settings stored on your phone but only one activated at a time. Therefore if you want to use internet and MMS at the same time you need to enter their details into the same APN. If the APN you have entered is valid it will allow you to select it.
    APN settings vary from PAYG to contract and also from different carriers. The following is for O2 contract, but you can find any carrier settings with Google:

    Name: O2 Contract
    APN: mobile.o2.co.uk
    Username: web
    Password: password
    Server: http://mmsc.mms.o2.co.uk
    MMSC: http://mmsc.mms.o2.co.uk
    MMS Proxy: 8080
    MCC: 234
    MNC: 10
    Auth Type: None

    This is what i have been using and Ive seen it work from GPRS to 3G (Android 2.1), people in o2 said HSDP will work if I'm in a good area. When you enter these there is no need to restart your phone but you might have to wait a few minutes for it to kick in. I have also heard of a lot more username/password combinations working. Your phone will automatically chose the fastest internet for you.

    Thanks.

    Advertisement
  2. tpr007

    tpr007 Member

    So, does MMS (send & receive) work on your Nexus?
  3. Jleagle

    Jleagle Active Member

    Receiving MMS works, sending just seems to keep trying forever and never sends. The thread was mainly about internet as i never use MMS. Although the bold MMS settings are some i found on the internet which worked for the poster.
  4. tpr007

    tpr007 Member

    Just an update with regard to MMS

    It all works fine - but the APN in use must include the correct mms settings (for o2 in my case).

    The problem is with the default messaging app, as it doesn't reduce the pics down to a small enough size, so they won't send.
    Had to download an app called "Handcent" which allows you to customize the settings and reduce the pics to a network acceptable size - and then they will send.
  5. razputin

    razputin Active Member

    These are tried and tested and work on my unlocked Orange Hero on O2 Simplicity Contract.

    NAME O2 UK Postpay
    APN wap.o2.co.uk
    PROXY <Not set>
    PORT <Not set>
    USERNAME O2wap
    PASSWORD password
    SERVER http://mmsc.mms.o2.co.uk:8002
    MMSC http://mmsc.mms.o2.co.uk:8002
    MMS PROXY 193.113.200.195
    MMS PORT 8080
    MCC 234
    MNC 10
    APN TYPE <Not set>

    Don't forget to press 'Menu' and select 'Save' once you have typed them in.
  6. oc1rob

    oc1rob Member

    Hi, First post first question.....
    I have tried the details above on a Ex Orange Hero and while they work for mobile internet I cant get the phone to connect at anything above either Edge or GPRS, and I know that there is 3G because the Iphone next to it is nailed into the 3G here at home.
    Do you get all data methods with these settings??
    Is there another stage that needs activating that I have not found yet??
  7. hipocrazy

    hipocrazy Well-Known Member

    Any Bell Mobility users care to share their APN settings as well?
    I'm about to purchase and would like all the info I need prior to arrival ;)
  8. razputin

    razputin Active Member

    These settings work fine for me and other people who have tried. They give me all connection speeds where available including HSDPA or 'H' on your phone which is the fastest speed.

    Not sure what your is happening with yours but I would try rebooting again or perhaps typing the settings in again and rebooting.
  9. MartinS

    MartinS Well-Known Member

    Check that you haven't got "Use 2G network only" ticked in the settings and wireless and networks menu.

Share This Page