Fastboot command not found


  1. windsorclarenc

    windsorclarenc Well-Known Member

    I tried to unlock bootloader on Windows and failed. I get all the way to the command "fastboot oem get_identifier_token" then it just tells me it's waiting on the device. And nothing else. All required programs are installed, but no luck. Then I gave up on Windows.

    So I decided maybe Linux would be better. I got all of the required files. I installed android SDK and updated it. In terminal I navigated to where the fastboot file is located. Then I enter the command "fastboot oem get_identifier_token" and it tells me "fastboot: command not found"

    I'm stuck as hell on two different operating systems. Can anybody help me with one of these???

    Advertisement
  2. Granite1

    Granite1 Zercron Encrusted Tweezer Moderator

    OK, I Kanged this from jerofld's guide on the 3vo. It's a standard procedure for all HTC devices, so it "should" work. From jerofld's guide:


    Step 4) Unlocking with HTC Dev






    If you haven't already unlocked your bootloader using HTC DEV Unlock (or Revolutionary if you have HBOOT 1.3 or 1.4), we will do so now.

    If you plan on using Revolutionary, pleast read this thread: [GUIDE] How to Root the HTC EVO 3D [Video Walkthrough] - xda-developers

    If you have HBOOT 1.5, you cannot use Revolutionary and must use HTC Dev. This guide will assume you have HBOOT 1.5.

    For the record: I hate HTCdev. Many users have problems with it. If you have problems with this next section, please send feedback to HTCdev explaining how their process is overly complicated and has issues. But do so politely, please.

    Step 1) Getting into fastboot.

    First, let's turn off one of HTC's defaulted on features. So let's turn off the very frustratingly named 'Fast Boot' in Settings > Power. No, this is not 'fastboot' in the Android SDK. This is a feature that is like Hibernate in Windows but for HTC devices. I really hate how HTC calls it this, but that's what they decided to call it.

    Next, go to Settings > Applications > Development and check USB Debugging. You'll need this enabled for the adb reboot command. Plus a number of rooting apps require it. Give the computer a few minutes to recognize your phone, install drivers, and so on, if it needs to.

    Connect your phone to your computer. From now until you're done flashing your ROM, you will not disconnect the USB cable. So don't even think about it!

    Quick tip: Do NOT connect to a USB 3.0 port. For some reason, fastboot will not detect your device if you're connected through a USB 3.0 port. If you're unsure if you have a USB 3.0 port, don't worry about it unless your fastboot commands say that they're waiting for device when the device is hooked up.

    Now, in the command prompt, type (or copy and paste):

    Code:
    adb reboot bootloader
    You should now be in your bootloader. It should say "FASTBOOT USB" in red highlight. If so, this is good! If not, make sure HBOOT in the menu is highlighted and push the power button. This will change it to FASTBOOT and it'll detect that it's connected to USB and change in a few seconds. Now type (or copy):

    Step 2) Getting the device identifier token and then flashing unlock_code.bin

    Type the following command in the command prompt:

    Code:
    fastboot oem get_identifier_token
    A long text boxes will come up. Right mouse button click on the screen and click mark. Then highlight the token from <<<< Identifier Token Start >>>> to <<<<< Identifier Token End >>>>>, like shown:





    [​IMG][​IMG]




    Do not highlight info or bootloader or any extra spaces or text. Once you have done that, right click again and hit copy.

    Now go to HTCdev - Unlock Bootloader and fill out the forms and paste the code into the device identifier token box and submit. You'll get an email (check your spam folder) with your unlock_code.bin. Once your receive it, transfer that file into your C:\sdk-tools\ folder. Now go back to your command window and type:

    Code:
    fastboot flash unlocktoken Unlock_code.bin
    The unlock token should reboot the phone for you (so that you'll be back in Android). If it doesn't you can do it manually by reinserting the battery and then holding Vol down + power. You should now see UNLOCKED displayed at the top. If so, congratulations, you are now unlocked!
  3. Granite1

    Granite1 Zercron Encrusted Tweezer Moderator

  4. windsorclarenc

    windsorclarenc Well-Known Member

    Cool I got it! Thanks guys!!!!!!!!! :D Time to flash a new ROM

    Edit: I was wrong. Now in HBOOT I get:
    *** TAMPERED ***
    *** UNLOCKED ***
    JEWEL PVT SHIP S-ON RL
    HBOOT-1.12.0000
    RADIO-1.02.12.0427
    OpenDSP-v25.1.0.32.0405
    eMMC-boot
    Apr 26 2012, 19:54:01

    Command prompt said it worked:
    C:\Program Files (x86)\Android\android-sdk\platform-tools>fastboot flash unlocktoken Unlock_code.bin
    sending 'unlocktoken' (0 KB)...
    OKAY [ 0.144s]
    writing 'unlocktoken'...
    (bootloader) unlock token check successfully
    OKAY [ 0.007s]
    finished. total time: 0.153s
    Granite1 likes this.
  5. windsorclarenc

    windsorclarenc Well-Known Member

    I still can't flash viperROM even though it is unlocked.
  6. Granite1

    Granite1 Zercron Encrusted Tweezer Moderator

    Did you flash the TWRP recovery?

    Just unlocking the bootloader won't install a custom recovery. You'll need to follow the thread I posted for TWRP recovery over at XDA. I'm on my phone or I would link you.

    I still haven't rooted yet, I'm taking mine in to a repair center and getting the radios checked out. Then I'll be rooting. ;)
  7. windsorclarenc

    windsorclarenc Well-Known Member

    Yeah I did. (it's bitchin' by the way). I figured out my problem. TWRP was trying to check for a Md5 file. I turned off that check and I was able to flash viperMod 1.2! Thanks for the help, I really appreciate it!
    Granite1 likes this.
  8. Granite1

    Granite1 Zercron Encrusted Tweezer Moderator

    No problem! :)

    Thank you for posting back what fixed your problem. ;)
  9. phillymade

    phillymade Member

    I was able to use HTC Dev to unlock my OG. But for some reason, I canm not get it to work on my LTE. When I'm in "Fastboot" and connect my USB, the device does not connect to my PC.(Windows 7 by the way). I'm not sure how to get it right. Any help would be cool.
  10. windsorclarenc

    windsorclarenc Well-Known Member

    That happened to me too. I uninstalled the drivers installed by HTC Sync them reinstalled them. That worked for me on Windows 7.

    Your computer may not display anything when you connect during fastboot, mine didn't. I just got the device connected beep.
    Granite1 likes this.
  11. cpolasek

    cpolasek Member

    I have an htc one v. my computer is running windows 7.
    when i type 'fastboot oem get_identifier_token'
    it says ''fastboot' is not recognized as an internal or external command, operable program or batch file'
    i'm in C:\Users\Caroline\Android> and i think that might be my problem.. in the guide i am using the example is 'C:\Android'
    please help me
  12. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Welcome to the forums!

    This is the EVO 4G LTE forum, but it sounds like this is just an issue with the command prompt being in the wrong directory.

    The good news is you have windows 7. You can simply hold shift and right click in your folder that contains fastboot in order to open the command prompt there. Then the command will work :)

    [​IMG]
    Granite1 and EarlyMon like this.
Loading...

Share This Page