Fastboot issues galoreSupport

Last Updated:

  1. monkfishb

    monkfishb Member

    I know this problem seems to have been documented before, but I am at my wit's end with this stupid driver problem and I am afraid that both my phone and the plate glass window to the left of me are going to suffer the consequences :mad:

    Last year my power button started to become sporadically uncooperative, and a few months ago it died completely. I can still operate the phone to most of its ability, but switching it on requires a quick plug-in to the mains and unlocking it requires the volume key. Not ideal.

    Seeing as Vodafone refuse to repair it due to it being rooted, I had a quick search on the issue once again and have found that it may possibly be a software issue; while I'm not confident about this, I'm at least willing to give it a try. Here's where the problem starts.

    Fastboot. ****ing fastboot. I have installed and uninstalled more drivers than the bloody FIA in trying to get this to work again. This has never been an issue before...ever...but now it seems to be doing its best to piss me off. I have installed Samsung 1.4 drivers, Samsung 1.7 drivers, Samsung "naked" drivers, PdaNet drivers and nothing seems to work. Here is a list of problems, and I can only provide the promise that I will send you a nice postcard or something for helping me out:

    • ADB is working. Fastboot is not.
    • No USB device is detected in Device Manager while the phone is in Fastboot mode. While the phone is in normal use, it is discovered and installed (albeit as ACER ADB).
    • Acer ADB is the device name, and I can't seem to install it as anything else (choosing drivers from another folder just prompts the computer to tell me that the drivers are already up-to-date).
    • Hardware buttons do not operate in Fastboot mode. The volume buttons work within the OS, and Volume-Up still sends the phone into Fastboot mode.
    • The phone is rooted, but Superuser cannot give permissions to ROM Manager.

    Please, PLEASE help me. I have just had it cut, so I'm struggling to pull my hair out - I'm just afraid what I might try to pull out next...

    EDIT: So it appears I can't even adb into recovery either. Big red triangle. My recovery image is gone. Current stress level: 62%.

  2. quantumrand

    quantumrand Well-Known Member

    What version of Android is your phone running, and have you tried the latest Android SDK drivers, direct from the Android developer site?
  3. monkfishb

    monkfishb Member

    Thanks for replying :) I was running the 4.0.3 AOSP build when it was released, but I changed to the official 4.0.3 Vodafone UK build so I could receive the OTA updates, so I'm currently running 4.0.4.

    The SDK drivers were the ones that worked for me before, but apparently not anymore. I've also tried reinstalling the SDK and using those, but Device Manager still tells me that the ADB drivers are up-to-date. I hadn't tried any adb or fastboot connections since the 4.0.4 update, though, so I'm wondering if something there has broken it?
  4. quantumrand

    quantumrand Well-Known Member

    Does "adb reboot fastboot" work to boot you into fastboot mode? From there, you can easily flash a new recovery image or even a stock system image.
  5. monkfishb

    monkfishb Member

    'adb reboot fastboot' takes me to the same screen I would get by otherwise holding the Volume+ button upon boot. It takes me into fastboot mode on the phone, but once in this mode the computer doesn't recognise it as a USB device, and for some strange and annoying reason the hardware buttons do not respond. I've tried flashing the Clockwork Mod touch recovery, but due to fastboot not working I can't see a way to do that :(
  6. quantumrand

    quantumrand Well-Known Member

    I'm not sure if Odin works with the Nexus S or not, but at this point, that might be your best bet for fixing it. Try looking into that.
  7. monkfishb

    monkfishb Member

    I've just tried Odin and it didn't work, so I installed Root Check Basic to verify that my phone is still rooted...apparently not. What I think happened was that I needed to unroot the phone to get the OTA update from Vodafone, so currently my phone is not rooted. This adds an extra element of 'bugger me' as I can't consider ROM Manager an option. So currently: phone is not rooted, hardware buttons can't make selections in the bootloader and fastboot is still not working.

    I should note that I was able to install the device as "Android ADB Interface" instead of its previous 'ACER ADB', which is what the device has been listed under before when fastboot did work. For anyone who might find this thread in the future (if it hopefully solves my problem), the way to do this is found here. However, the device is still not recognised in fastboot mode.
  8. monkfishb

    monkfishb Member

    After reading around on some other threads, it would appear that my power button issue is a result of the phone thinking that it is constantly depressed (insert sadness joke here). By whacking my phone against my knee whilst in the bootloader, the 'Reboot Bootloader' option is selected. The power button being pressed is probably what is stopping me from using the volume buttons, which is incredibly frustrating for the reason that if I could find a way of booting into recovery I could probably just knee-slap my way through to installing the CWM Touch Recovery image. Sigh.

    As for fastboot, still no luck yet. I'll keep whichever small audience of agitated Nexus S owners are following this thread updated as I continue to throw solutions at the phone and see what might stick.

Share This Page