Root Fastboot Mode

Discussion in 'Android Devices' started by Cjohn8792, Nov 7, 2010.

  1. Cjohn8792

    Cjohn8792 Well-Known Member
    36

    Sep 8, 2010
    146
    9
    36
    Operator
    Upstate,NY
    I tried to reboot my phone into recovery with the Raptor Rom and clockwork mod recovery but it just goes to a blue screen with a line that says fastboot mode then underneath that "start" with some symbols. It gets stuck and I can't type or click anything. If I take out the battery and reboot I have to hold the power, home, and send keys for it to start my phone otherwise directly back to frozen blue screen. Any ideas? I searched some other posts similar to this but none answer the question for the screen being frozen, they all tell you things to type. I should be booting into clockwork mod recovery but I don't.
     

    Advertisement
  2. dots

    dots Well-Known Member
    93

    Aug 5, 2010
    965
    245
    93
    Shelby Township, MI
    You have no recovery img. Try re-flashing the recovery that you we're using if you can boot into android

    Fastboot (bootloader) is used with the android sdk. Which is why you cannot type anything with the phone.
     
    Cjohn8792 likes this.
  3. Vmanisme

    Vmanisme Well-Known Member
    93

    Jun 19, 2010
    599
    149
    93
    Virginia
    Plug in your phone get to adb shell and type "adb fastboot reboot" (on the computer)
     
  4. Cjohn8792

    Cjohn8792 Well-Known Member
    36

    Sep 8, 2010
    146
    9
    36
    Operator
    Upstate,NY
    What is this going to do? I can load my phone and use it, i just need to know how to be able to use clockwork mod recovery again?
     
  5. Indifferent22

    Indifferent22 Well-Known Member
    18

    Oct 28, 2010
    89
    20
    18
    Computer Engineer
    Ohio
    Download a recovery img, and do fastboot boot (Path of .img on computer) and you'll boot into recovery. If it doesnt work post again.
     
  6. death2all110

    death2all110 VIP Member
    VIP Member
    313

    Jun 25, 2010
    1,996
    1,210
    313
    Male
    Systems Administrator Windows/Unix
    Illinois, US
    Yes, but to fix the no recovery img issue he needs to reflash the recover. so similar to what you said but instead fastboot flash recovery c:\recoveryxyz.img (where c:\recoveryxyz.img is the path and name of recovery image being flashed. in order to use fastboot you need the sdk and the modified version of the usb drivers included with the sdk.

    sdk is available here: http://goo.gl/2670
    prepacked with the modified usb drivers i mentioned above.

    extract to your c: drive so when done you see a folder labeled android

    plug your phone in. open device manager. find adb bootloader. right click choose update drivers navigate to c:\android\sdk\usb_driver and choose android_winusb.inf

    once done open command prompt and do cd c:\android\sdk\tools

    and run the commands i mentioned above. so if the recovery image is the one by drellisdee and is in the root of your c drive the command would be

    fastboot flash recovery c:\recovery-RA_GNM_v1.2.4.img

    hope this helps.
     
    LG D321 user likes this.
  7. nyrkid21

    nyrkid21 Member
    5

    Nov 14, 2010
    6
    0
    5
    i downloaded the file from that link you posted but then i dont understand what to do
     
  8. death2all110

    death2all110 VIP Member
    VIP Member
    313

    Jun 25, 2010
    1,996
    1,210
    313
    Male
    Systems Administrator Windows/Unix
    Illinois, US
    extract the folder that is inside the zip file to your C: drive and follow the rest of the directions
     
  9. netizenmt

    netizenmt Well-Known Member
    78

    Oct 3, 2010
    490
    111
    78
    Technical Support
    Mansfield, OH
    <sighs> So many people today have no clue about command lines and folders and files. Windows was supposed to isolate us from all that, but I am glad I've got my old DOS days experience behind me for times like these.
     
  10. death2all110

    death2all110 VIP Member
    VIP Member
    313

    Jun 25, 2010
    1,996
    1,210
    313
    Male
    Systems Administrator Windows/Unix
    Illinois, US
    Agreed. Sad how some people dont even know what the command prompt/terminal is....its my favorite tool ha ha.
     
  11. ravijohn

    ravijohn New Member
    5

    Jan 2, 2011
    2
    0
    5
    Dear All,

    First of all im sorry if im posting this in the wrong area. I have read millions of pages on this forum and other and am really really confused. I have a Desire Z and it was running stock rom with the following details:
    HBOOT - 0.76.2000 (PC1011000)
    MICROP-0425
    RADIO-26.03.02.26_M
    eMMC-boot
    OS 1.34.707.5

    Since d rage method was not working for me initially due to ADB issues, i tried Visionary as an easy way out and now i seem to have semi-bricked my device as im always facing boot loop screen. I hadnt made any typos, everything was done as said. I have managed to get S-OFF and had enable USB Debugging before the perm root. However after this boot loop issue started, im unable to use ADB alongwith FASTBOOT as it doesnt list my device under attached devices on using ADB DEVICES command. Initially i also had a driver issue as it was detecting an android 1.0 device but i guess i solved that by using PDAnet drivers but still no success with ADB. I have never made any custom/ nandroid backups and im very confused as to what to do. I took my phone to HTC but since the 'z' is not yet launced here they said I would have to wait till the official launch (wtf).. is there any way to recover my device? i dont even mind using the old STOCK rom, i only wanted to root to enable 'trackpad wake' and 'overclocking'.. Please help me out folks
     
  12. bnitty

    bnitty Well-Known Member
    38

    Dec 15, 2010
    242
    17
    38
    Wichita/Lawrence, Kansas
    finally an answer to my fastboot problem
     
  13. kc720

    kc720 Member
    16

    Jan 15, 2010
    18
    8
    16
    i have one that is stuck in fastboot. originally it was a brick that would not boot anything other than download mode (5 and plug in) so i tried flashing a masterbin in npst in emergency mode. it flashed but now it is stuck in fastboot. i can fastboot boot a recovery, but cant flash one. tells me "FAILED (remote: flash write failure : name[recovery] start [1382] length[40]." as i said, i can fastboot boot a recovery (recovery-RA_GNM_v1.2.4.img) but trying to flash signed_ally_V8_stock.zip give me error "E:Can't symlink /system/bin/bugreport, E:Failure at line 8: symlink dumpstate SYSTEM:bin/bugreport" when trying to flash velocity_0.4_release.zip, i get error while it's trying to flash gridlock custom kernel, "assert failed: write_raw_image("/tmp/boot.img" , "boot") (status 7). any one have any ideas?
     
  14. bnitty

    bnitty Well-Known Member
    38

    Dec 15, 2010
    242
    17
    38
    Wichita/Lawrence, Kansas
    is there not an easier way to fix this ridiculous problem
     
  15. bnitty

    bnitty Well-Known Member
    38

    Dec 15, 2010
    242
    17
    38
    Wichita/Lawrence, Kansas
    i FINALLY found a way to fix this. it's quite simple. just "fix permissions" in ROM Manager then reboot your phone. should be good to go with flashing after that. worked for me thank God
     
Tags:

Share This Page

Loading...