Fed up. Phone's not detected via USB on any PC!Support


  1. OldHooky

    OldHooky Well-Known Member

    :mad: Have now plugged it in to three machines and none see it! Surely it should at least be detected?

    Advertisement
    :
  2. craighwk

    craighwk Well-Known Member

    Does the battery indicator on the phone change to a charging icon when you plug it in? If so, then you're half way there.

    When you plug the phone in, do you get a notification on your phone that USB has been connected? If so, pull the notification down and select the USB connection to mount the phone into your computer.
  3. teschoen

    teschoen Well-Known Member

    Have you tried another MicroUSB Cable?
  4. screamster

    screamster Well-Known Member

    Need more info also.

    What system are you using? Did it load a driver when you plugged it in for the first time?
  5. DroidJnkie

    DroidJnkie Well-Known Member

    The problem is with Windows (I assume you're using Win?)

    I have the exact same problem. On four machines at work, it will not recognize it. One work machine recognizes it, and my home PC recognizes it just fine.

    It drives me nuts, too! I want to install all these apps into my phone, and the best I can do is save them to a flash drive and do it at home.

    The ONE machine that works at my job happens to be the boss's, so I can't use it unless she's not here.
  6. GDroid

    GDroid Well-Known Member

    I have a hunch the OP is not "mounting" the phone as craighwk described in his reply. The same cable is used for the wall charger, and the OP should have noticed issues with charging as well. This is assuming the OP is not using a different cable when connecting Droid to PC.
  7. YankeeDudeL

    YankeeDudeL Well-Known Member


    So, it is just like at home.;)
  8. teschoen

    teschoen Well-Known Member

    I have that hunch too. That caught me by surprise the first time I tried to hook up via USB, but I did look at the phone and saw it was connected. I did a quick search and bam the answer was provided. gotta love the intertubes-webby thing.
  9. DroidJnkie

    DroidJnkie Well-Known Member

    lol.

    Seriously, on the machines that don't work, I can choose the "mount to pc" option on my phone, and it says it is USB connected. But the stupid computer doesn't do a single thing.

    The phone does charge when connected, but the mount simply does not work. It's not the phone or the cable. It's the computer. I don't know why, but it is. At least in my case.
  10. OldHooky

    OldHooky Well-Known Member

    Wow! Quick replies!

    I'm using XP and have, I think, downloaded the correct drivers from Motorola.

    No indications on the phone an no battery indicator change.
    I'm using the same micro usb with the charger and no issues there.

    Haven't had the option of selecting the USB connection option.
  11. jmt9779

    jmt9779 Well-Known Member

    this is a common problem on work computers because of the numerous network drives we all have linked to our work computers. which essentially means that there are no currently available drive letters to be assigned to your phone when you plug it into your computer. but relax - it's easily fixable. do a google search on how to assign drive letters on windows xp (assuming you're using xp). you can go in and assign extra drive letters.

    I had this same problem with my phone (currently a blackberry) and my mp3 player. and now they both hook up to my work computer fine :)
    pkatmi likes this.
  12. OldHooky

    OldHooky Well-Known Member

    Thanks, I'll try this in a few minutes. It'll be on my home machines, so fingers crossed!
  13. DroidJnkie

    DroidJnkie Well-Known Member

    sweet! I'm going to try this!
  14. teschoen

    teschoen Well-Known Member

    just FYI, I never needed a driver..I just hooked it up and it worked. WinXP SP3 on my netbook and Win 7 Ultimate (64 bit) on my workstation and Win 7 Home 64 Bit on my laptop.
  15. Eugene

    Eugene Well-Known Member

    Xp also has a bug/feature of assigning a new hidden device each time usb storage is used. If you plug things in and out a lot, like a few times a day then after a few weeks it will get slowr and slower to bring up the drive letter. You have to reboot in safe mode, do i device mangler, view hidden devices, delete all the dups then reboot and try again.
  16. DroidJnkie

    DroidJnkie Well-Known Member

    Well, it seems I can't do this without Admin access on my work computer.

    Fortunately, I have the admin password! But I can't do it until the office manager goes to lunch, hee hee.
  17. sooper_droid12

    sooper_droid12 Well-Known Member

    What a weird problem. I have not had any problems connecting my DROID to any computer that I have used. I hope you figure it out. If you do, make sure you post the solution just in case someone else has the same problem.
  18. kraze0g

    kraze0g Well-Known Member

    when you connect the phone to the computer, does the driver automatically install?
  19. teschoen

    teschoen Well-Known Member

    My Droid was recognized as a USB Storage Device with no drivers needed. I then copied several GB of data over to the SD Card and then unmounted.
  20. GDroid

    GDroid Well-Known Member

    There's too many reasons for why this could be happening. You'll have to go through step-by-step troubleshooting, and I'm sure you'll figure it out.
  21. namor189

    namor189 New Member

    I discovered that if I go into safe mode on my widows 7 64 I can then mount the droid.
  22. OldHooky

    OldHooky Well-Known Member

    Well I found that the Motorola cable had, since charging this morning, stopped working.

    Now it's detected! The only problem being that now it get the dreaded message "USB Device Not Recognized". And on both laptops. :mad:

    It had better start working or it's either going to rapidly learn to fly as it soars across the room, or will be boxed up and put at the back of the highest shelf!
  23. teschoen

    teschoen Well-Known Member

    Hooky, I doubt it is the phone. Did you go to the phone and Mount the SD card after you connected?

    Here is how I do it.

    Plug the USB Cable into the PC
    Plug the USB Cable into Droid
    Notice white light glow on Droid if it is charging
    Activate Droid's screen, notice that the lock screen says Charging XX%
    Unlock Droid
    Look at the notice window shade at the top, bring it down
    Tap the "USB connected" area on the screen
    Tap "Mount" on the Droid
    Open up Windows Explorer and bam you have access to the SD Card of the Droid.
  24. OldHooky

    OldHooky Well-Known Member

    Perhaps I'm being thick, but the option isn't there and no indication that it's charging.

    Spoke too soon. This second cable now doesn't work!
  25. GDroid

    GDroid Well-Known Member

    Can you browse the SD card via the Droid? Power off the phone, remove the battery, and re-seat the SD card. Power on the phone, and try again.

    Worst case, try a factory reset before you chuck it against the wall.
Loading...

Share This Page