Figured out why Froyo killed my bettery life.Tips


Last Updated:

  1. Brent Pierce

    Brent Pierce Well-Known Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    197
    Likes Received:
    69
    I noticed today that Froyo re-enabled "auto sign in" in Gtalk.
    I unchecked it, problem solved.

    If you're getting bad battery life after the update, make sure Gtalk is NOT auto signing you in. That's one of the biggest battery hogs.

    Just figured I'd post this to let everyone know a potential problem.
    --
    And yes, I misspelled battery. Let's bring on the grammatical comments!
     

    Advertisement
    Franswai, eirrom, vmbgap and 18 others like this.
  2. JanelleTheRider

    JanelleTheRider Member

    Joined:
    Jun 5, 2010
    Messages:
    15
    Likes Received:
    0
    this might sound silly, but how do you get to where you can un-enable it?
     
  3. EarlyMon

    EarlyMon The PearlyMon Moderator

    Joined:
    Jun 10, 2010
    Messages:
    57,614
    Likes Received:
    70,271
    Goto your app drawer, launch the application called Talk and then Menu-> Settings for it.
     
    Foppa, vblick and JanelleTheRider like this.
  4. simonedwards0947

    simonedwards0947 Well-Known Member

    Joined:
    Jun 25, 2010
    Messages:
    60
    Likes Received:
    2
    good find...
     
  5. whtge8

    whtge8 Well-Known Member

    Joined:
    Jun 8, 2010
    Messages:
    137
    Likes Received:
    11
    Thanks for reminding us to do that. Didnt know it set it back to sign in.
     
    Mr. Ed likes this.
  6. eieio

    eieio Well-Known Member

    Joined:
    Apr 6, 2010
    Messages:
    1,065
    Likes Received:
    823
    also go into sprint zone and turn off all the automatic updates there is a ton of them.
     
  7. slugbug

    slugbug Well-Known Member

    Joined:
    Jul 26, 2010
    Messages:
    171
    Likes Received:
    21
    Just FYI - I did that after I updated to Froyo Monday night. Noticed my battery was draining significantly today. First thing I checked was Talk. I was signed in again. Yes - I did sign out last time. So not sure what is up with that, auto sign is is disabled. I signed out again and signed out.

    I did so many different things to get the most out of my battery I can't really say what one or 2 (or 3 or 10 :) things finally did it for me, but I know this helps for sure.
     
  8. nahpungnome

    nahpungnome Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    187
    Likes Received:
    29
    I actually use Gtalk regularly (also when I was on 2.1) and never really attributed it to battery drain. Glad it fixed your problem though.
     
  9. pgus13

    pgus13 Well-Known Member

    Joined:
    Jun 3, 2010
    Messages:
    165
    Likes Received:
    7
    I noticed the last 2 days my battery was draining WAY too fast. I usually got thru the day at work and get home at about 30% but the last 2 days I was nearly drained. Today (after nearly 16 hours), I am at 25%.....
     
  10. vblick

    vblick Well-Known Member

    Joined:
    May 18, 2010
    Messages:
    78
    Likes Received:
    7
    son of a b1tch
     
  11. meangreengdub

    meangreengdub Well-Known Member

    Joined:
    Oct 18, 2009
    Messages:
    328
    Likes Received:
    5
    I've also noticed that Latitude signed me in without me ever doing anything. I noticed much better battery life after I went in and turned it off so you might try this as well.
     
    figraphiz likes this.
  12. WaSTeLaNd

    WaSTeLaNd Well-Known Member

    Joined:
    May 12, 2010
    Messages:
    415
    Likes Received:
    98
    What does it do if your not auto signed in? Does it stop your gmail being pushed
     
  13. vkdroid

    vkdroid Well-Known Member

    Joined:
    May 18, 2010
    Messages:
    163
    Likes Received:
    16
    No.
     
  14. Jordus

    Jordus Well-Known Member

    Joined:
    May 5, 2010
    Messages:
    283
    Likes Received:
    70
    I use gtalk for work so no go for me.
     
  15. myriam

    myriam Well-Known Member

    Joined:
    May 17, 2010
    Messages:
    63
    Likes Received:
    7
    How do you turn latitude off? When I go there it signs me in, but I don't see a way to turn it off.
     
  16. vgsantiago

    vgsantiago Well-Known Member

    Joined:
    Nov 5, 2009
    Messages:
    196
    Likes Received:
    21
    kinda noticed the same thing. Today seems to be doing pretty good vice the days right after the update. I've also followed all the advice mentioned in this thread so far.

    I don't use a task killer. Trusting Android
     
  17. sitlet

    sitlet Banned

    Joined:
    Apr 11, 2010
    Messages:
    5,867
    Likes Received:
    633
    I've also had HORRIBLE battery life after this update, worse than the very first week. With the 1.47 update, that dramatically helped my battery. I could go 2 days with light usage before charging. Now, with froyo, I made a 5 minute phone call today, sent 5 texts, and checked email a couple times, and i'm almost dead after less than 10 hours. This is ridiculous, something with this update is killing the battery.
     
  18. txcobra96

    txcobra96 Active Member

    Joined:
    Jul 2, 2010
    Messages:
    36
    Likes Received:
    11
    good tip. thank you!!
     
    takirb likes this.
  19. Barats

    Barats Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    470
    Likes Received:
    37
    Thanks for reminding me about this!!
     
  20. Jonhern

    Jonhern Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    221
    Likes Received:
    22
    Thanks. I am rooted, is it safe to remove talk and latitude?
     
  21. Beatranger

    Beatranger Member

    Joined:
    Aug 4, 2010
    Messages:
    5
    Likes Received:
    0
    Thanks man forgot about all of this again
     
  22. lk2500

    lk2500 Member

    Joined:
    Aug 3, 2010
    Messages:
    15
    Likes Received:
    1
    I don't see how to turn off Latitude either. What the heck is it and how do I turn if off?
     
  23. Carl6

    Carl6 Well-Known Member

    Joined:
    Jun 20, 2010
    Messages:
    58
    Likes Received:
    1
    I had an app (not sure which one yet) that was causing my phone to stay awake all the time (awake time and up time were the same). Uninstalled a dozen apps and did a power reset (pwr off, battery remove) and that fixed the problem. I'm slowly re-installing the apps I removed to see if the problem recurs. So far it hasn't.
     
  24. hendodo

    hendodo Well-Known Member

    Joined:
    Jul 14, 2010
    Messages:
    173
    Likes Received:
    15
    Forgot about that...thanks
     
  25. asnski

    asnski Member

    Joined:
    Jun 3, 2010
    Messages:
    8
    Likes Received:
    2
    Open Latitude, then click menu, and the icon with the 3 people bottom row middle, can't remember the name. But go there then the top option is turn off latitude.
     
    Foppa likes this.

Share This Page

Loading...