File transfer on CM9?Support


  1. mrspeedmaster

    mrspeedmaster Well-Known Member

    I can't transfer w. Alpha 2.

    --USB mass storage doesn't work.
    -- MTP & PTP doesn't work.
    The Android File Transfer app that works w/ my Galaxy Nexus doesn't work for the touchpad.

    I have to reboot into webOS to copy movies. Wifi transfer (using samba and other apps) is too slow.

    Advertisement
  2. colchiro

    colchiro Well-Known Member

    Known issue.



    I boot into webOS, but there may be a work-around for CM9 that I'm not aware of.
  3. gryffyn

    gryffyn New Member

    On CM9 alpha 0.6 and alpha 1 I've used an app called "Software Data Cable". Haven't used it since upgrading to alpha2, but I assume it still works.

    It basically sets up a simple FTP server so then you just use whatever FTP program you enjoy (or, at least in Windows, you can just use Explorer or IE):
    https://market.android.com/details?id=com.lyy.softdatacable

    I had an issue transferring via USB to my Transformer so I started using that app. Came in handy for not having to boot into WebOS to put CM9a2 on there.
  4. gryffyn

    gryffyn New Member

    Just noticed that you said wifi is too slow. That's how I use the Software Data Cable app and it seems pretty speedy to me. But I think I'm connecting via 802.11n (at least I was on the WebOS side) and my computer is right next to the wireless router, so that's usually where I am when I'm transferring files.
  5. chaseincats

    chaseincats Member

    easiest way is to just reset to clockwork mod from the reset options and do it that way simply because its way quicker than booting webos
  6. Jeffery

    Jeffery Well-Known Member

    The WiFi File Transfer app works, but it is slow.
  7. alextop30

    alextop30 Well-Known Member

    Have you tried the media device option. I am not sure if this will give you access to the root directory but basically go to storage in the settings menu go to the little menu on the upper right and click the first option which is connect to computer and after select connect as media device. This let's me access the ad card and any downloads I have grabbed off the net.
  8. tysonfarmer

    tysonfarmer New Member

    If you have installed CM9 on your TP then you should have clockworkmod. It has a Mount USB Storage option. I moved my update using this option easy, without booting webOS.
  9. tysonfarmer

    tysonfarmer New Member

    Mostly Harmless likes this.
  10. alextop30

    alextop30 Well-Known Member

    Well I know this might be slightly off base here and a bit old but I thought I would give a little contribution since I solved similar problem with my touchpad and pc. My Windows 7 N was having trouble installing the MTP and cm_tenderloin drivers for the touchpad so it was never mounted as a device. In case you have one of these special distributions of Widows make sure you go to google and search Microsoft Windows Media player features pack for Windows 7 N make sure you know whether its 32bit or 64bit and install that update.


    If you do not have Microsoft Windows Media Player I believe in it was stated that the runtime environment for MTP does not exist so you will not be able to mount your device. Make sure you have it and it is updated to post version 11 and you should be able to mount as a media device for the fix for SD card there is one using mobile terminal on the XDA forums I believe.
  11. colchiro

    colchiro Well-Known Member

    Windows "N".... I've never known anyone who owned it. The EU was behind that.
  12. alextop30

    alextop30 Well-Known Member

    well I don't know if it is easy to admit this but I was a student once and took a class in C++ the professor was really nice and let me purchase it for 15 dollars. Everything is nice and it works fine but the windows media player was not included in the distribution.
  13. colchiro

    colchiro Well-Known Member

    I'm going to be dealing with c# soon.
  14. cmatthaios

    cmatthaios Well-Known Member

    XP1 likes this.
  15. colchiro

    colchiro Well-Known Member

    MTP works fine for me on my phone. It doesn't mount as a drive letter so programs that rely on that might not work but you can still copy files to/from your device.
  16. Covart

    Covart Well-Known Member

    Late to the party on this, but there is no need for clockworkmod, rebooting into webs, etc.

    Whether you have a Mac or PC, makes no difference, just download a program called Android File Transfer, connect Touchpad to PC with supplied USB cable, click and drag files like any other USB device. Easy.
  17. XP1

    XP1 New Member

    Thanks! I didn't have to install anything on Windows 8.

    For those who cannot view the video, go to Settings > Storage > ⋮ (Vertical ellipsis on top right) > Under "Connect as", enable "Media device (MTP)".

Share This Page